Previous 1 2 3 4 5 Next 63 Replies Latest reply: Jun 5, 2012 8:31 PM by BradPDX Go to original post
  • BradPDX Level 1 Level 1 (65 points)

    @magoo_mch - I think the battery life issue concerns the CPU usage of the iTunes store app when it gets "stuck" in the manner described for this issue.

     

    Using the System Activity Monitor app, one can easily observe that when the iTunes store app is in this state, CPU usage on my iPhone 4S exceeds 50%. If one simply closes the iTunes app using the home button, it may stay in this state and drain your battery.

     

    The solution (for now) is to force-quit the iTunes app. See if that helps.

  • BradPDX Level 1 Level 1 (65 points)

    Update: I tried using the iTunes store on my wife's iPhone 4S with her account.

     

    It works fine.

     

    I suspect that it is my account that is affected, and not my individual devices per se.

  • magoo_mch Level 1 Level 1 (0 points)

    I have already force quit the app.

     

    I've just noticed the battery life has worsened in general.

     

    I have a dock for my phone at work and I normally only have to dock and charge 1 or 2 times a week. I've found mysle having to dock it daily recently.

  • BradPDX Level 1 Level 1 (65 points)

    @magoo_mch - This really belongs in some separate thread, but: you've been able to use an iPhone and charge it only twice a week? I can't say that I've ever seen that, my friend. It is pretty normal for any of these devices to chew through a charge every day or two, because there are so many things it may be doing that use battery power.

     

    The same goes for all other brands, not just the iPhone. These are pretty potent computers running on tiny little batteries.

     

    My iPhone 4S is the third iPhone I've had - first a 3G, then a 3GS and now the 4S. Never had a charge last more than 2 days unless I didn't use the phone for anything, ditto for my wife. I usually leave it charging every night.

  • recneps Level 1 Level 1 (0 points)

    Add me to the list of people having this issue. This is really bad timing as I'm going on a trip and won't have my desktop available for syncing. iPhone 4S with 5.1.1

  • Zachery Wood Level 1 Level 1 (45 points)

    Same for me, on 5.1.1. I hope it's fixed soon. It's a real pain. Has anyone tried reinstalling iOS?

  • seanfromtwickenham Level 1 Level 1 (0 points)

    I have done a complete restore back to a time before I had updated to iOS 5.1.1, but it seems that it does not restore the IOS back to the version I was running at the time.

     

    When doing a restore, it seems to install iOS 5.1.1 and then do the restore of all my files and settings.  I think that this effectively answers your question about reinstalling - and I still have the same problem.

     

    It appears, to me, that you cannot go back to an earlier iOS version (unless you jailbreak your iPhone).

     

    I have also noticed/tried the following:

     

    • I am sure that the battery life issue is linked to the iTunes store 'hanging' when looking for podcasts as I have the circle permanently spinning whilst it is searching.

     

    • I have tried to download podcasts from three different internet networks and locations - so I don't believe it to be down to my network connection.

     

    • I have also tried it with different podcasts, so it is not a problem with the publisher of the podcast e.g. BBC

     

    • I am able to download other items e.g. single of the week, economist magazine etc. - so I have no problem with my iTunes account.
  • esolo Level 1 Level 1 (0 points)

    same here, saw it day one of update from ios 5.1.1 but no one online said anything till now. though i was going crazy. this has to be a big problem because no apple tech has chimed in with answer.  I have restored iphone 4s and logged in and out of account and nothing.

     

    they only way to download new podcast is to sync though desktop. it's very inconvenient when i want new smodcast.

     

    APPLE at ****'s heart i stab at thee!

  • FastAndFluid Level 1 Level 1 (0 points)

    Another user with same issue here. Updated to ios 5.1.1. Since then both iPad3 and iPhone 4 can't download podcasts. Been like this for 2 weeks.  Really really annoying since I use both devices for podcasts more than I use them for anything else.  Suspect it is a backend thing because for a day or two my phone suddenly seemed to work OK, but now it's borked again. 

  • jbruels Level 1 Level 1 (0 points)

    This is getting a little rediculous.  Is there ANYONE who has an answer to this with this problem going on for almost 2 weeks?

  • Boich Level 1 Level 1 (0 points)

    Not that it'll help but I'm having the same problem. Can't search for anything on iPhone or iPhone on the store. Which Apple, means I can't buy anything so get it sorted. Can't confirm the battery issue but it's gone down 6% in about 5 mins so could be.

     

    All software up to date. iPad 1 & 4s

  • BradPDX Level 1 Level 1 (65 points)

    As the original poster, I feel a bit responsible for this thread and just wish to remind everyone that this forum is NOT Apple support - they aren't watching this and making a "to do" list, and no one from Apple will chime in with an answer. We can each contact Apple support directly, this is a place for users to discuss matters. It's the "self-help" department.

     

    FWIW, I've already contacted Apple about this and look forward to a reply this next week. I'll keep everyone posted.

     

    Update 1: I tried erasing and restoring my iPhone 4S from iCloud backup. Took a couple of hours, but really works. What I found along the way is that this issue appears tied to iTunes Match for me. When I first used the restored iPhone, iTunes Match was OFF and I could successfully use the store. I then setup iTunes Match and immediately went back to the old "bad" behavior. I am not sure yet if simply turning iTunes Match "off" helps - I do know from experience that turning it on or off involves a lot of client-server transactions, and so it often takes a while to see results. I try to give these systems at least 15 minutes to sort things out.

     

    Update 2: I am fortunate to have 2 iOS devices to test. I just turned iTunes Match OFF on my first-gen iPad, then logged out and back into the store with my account. I waited a few minutes, then tried to access the very same podcasts that have been giving me grief.

     

    Behold, it works just fine.

     

    So, my current hypothesis is that this issue is tied to iTunes Match.

     

    Here is a good use for the Community forums: are the rest of you using iTunes Match? Let's see a show of hands. For science.

  • esolo Level 1 Level 1 (0 points)

    i've never used itunes match. this happen right after ios 5.1.1 update and i already did a restore on phone. i know there are others still seeing this problem. I've done everything and still nothing.

  • mirslam Level 1 Level 1 (0 points)

    Same problem here. Not just podcasts, music too. Intermittent but frequent.

  • esolo Level 1 Level 1 (0 points)

    other post with more than 4000 views.

     

    https://discussions.apple.com/thread/3943101?tstart=0