5 Replies Latest reply: Dec 16, 2013 12:06 PM by thetypicallurker
d@v3 Level 1 (0 points)



I just configured my Snow Leopard Server to distribute Lion update's


http://emeadeployment.blogspot.com/2012/02/using-snow-leopard-server-for-lion.ht ml


I also see that the sync is competed with all latets Lion update's and all are enabled.


I've adjust all the settings on the clients:

sudo defaults write /Library/Preferences/com.apple.SoftwareUpdate CatalogURL http://server.mydomain:8088/index-lion-snowleopard-leopard.merged-1.sucatalog


The problem is that all my 10.6 and 10.7 clients doesnt see any availble update's and running the Software Update on the cllient i get the message "The software is up-to-date"


I checked all the configs.....reset the complete SUS server and started all over but still the same issue!

Tried multiple client adjustments:




SUS log seems all oke!

Mac OS X (10.7.3)
  • gracoat Level 3 (660 points)

    When you disable the client connection to the software update server, does the computer indeed see updates from apple?  Sounds like a silly question given that you sound quite thorough, but you didn't say that you tried that.


    What do the logs on the client say?

    Open up terminal and type sudo softwareupdate --list


    This will output all the log info that the client has to say about communication with the server.

  • d@v3 Level 1 (0 points)

    When I disable the client connection to the local SUS and use the default Apple SUS this is the log:



    Software Update Tool

    Copyright 2002-2010 Apple

    Software Update found the following new or updated software:

       * Safari5.1.7Lion-5.1.7

              Safari (5.1.7), 45564K [recommended]



    When I enable the local SUS this is the log:


    Software Update Tool

    Copyright 2002-2010 Apple

    No new software available.



    And the "Safari5.1.7Lion-5.1.7" is copied and enabled on the local SUS!

  • dhoepp Level 1 (0 points)

    This solved it for me. Go into Terminal and type:

    sudo softwareupdate -i -a

  • Fred Turner Level 1 (85 points)

    I know this is a dated thread, but since I'm seeing the same behavior currently, I didn't see any reason to start up a new one w/ the exact same symptoms. I rebuilt a MacBook w/ a 10.6.6 installer and was surprised to find that most updates from my 10.6.8 Server SUS were not "visible" to the client, including the 10.6.8 v1.1 combo updater.


    This may be a larger issue w/ Apple's catalogs (which I believe are causing 10.5.8 Leopard SUS to bail out w/ an error when checking for new updates), as pointing to another 10.6.8 server on another network entirely results in the same problem. I'm not missing ALL of the updates on the MacBook, just MOST of them, your Safari 5.1.7 above included. Another is GarageBand 6.0.5. So, for comparison, on a 10.8 test Server SUS, I downloaded and enabled both of those updates and pointed the MacBook to it. They show up immediately on the MacBook.


    Are any of you experiencing this currently? And if so, do you have any points of comparison on other SUS machines by chance? Again, I'm thinking this has something to do w/ the upstream catalogs that Apple is putting out.




  • thetypicallurker Level 1 (0 points)

    Resurrecting this thread. Did you (or anyone) find a solution?