Previous 1 8 9 10 11 12 13 Next 180 Replies Latest reply: Oct 15, 2013 12:53 PM by mouche Go to original post
  • wearthefoxhat Level 1 (0 points)

    POSSIBLE SOLUTION

     

    Hi people, was looking for a solution to this as my husband's newly replaced iPhone 4 had the same problem and the same had happened to my newly replaced 3G a year ago but I couldn't remember how I fixed it.  This time I compared the info about IP Address, Subnet Mask, Router and DNS (Settings>WiFi>'Home WiFi' then press the little blue arrow) to that on my 4S and found his settings were completely blank, so I copied across the identical information and voila! It's now connected.

  • BrianWilmington Level 1 (0 points)

    Same problems on 4S on AT&T--all suggested fixes failed including itunes restore.  Finally turned off phone, popped out SIM card, put it right back in, turned the phone back on and bam-wifi works...hope this helps a few people.

  • phillipqq Level 1 (0 points)

    rbrann this is the solution to my iphone 4s on 5.1.1. i have a cheap 1$ case from ebay on and wifi was working until i dropped the phone recently. somethng might have triggered the phone to not pick up any wifi in the area. so i did a power turn off (hold lock button and then slide to turn off) waited one minute and turned it back on with CASE OFF. wah la wifi again

  • shr3721 Level 1 (0 points)

    Same thing here. Really frustrating. No, Wi-Fi. Someone tell us how to use iphone 4s to restore ipad to ios 5.1.1.

     

    Otherwise, even if Apple sends out an update, with no Wi-Fi, I don't know how to update the ios.

  • pmyrick Level 1 (0 points)

    iPhone 4s won't stay connected to wifi after install of IOS 6.  Restoring back to previous backup.

  • oboeman Level 1 (0 points)

    I HAVE THE FIX!!!!! Go to App Store, log out of your Apple ID account, then go and connect to your wireless network, then log back in to your Apple ID. Mine has been working flawlessly after this fix for over thirty minutes now.

  • Shephebc Level 1 (0 points)

    I had the same prob but fixed it. I turned the network data off, tried connecting to wifi, turned it on again and tried connecting to wifi again and it's now working permanently

  • Dgigman2 Level 1 (0 points)

    That fix will only work if you have WiFi, but are unable to connect. The issue here is that after the os update, WiFi capabilities are completely disabled. The phone can't even search for WiFi.

  • victor110 Level 1 (0 points)

    After all this time waiting for iOS 6 and still getting Wi-Fi greyed out is, at least, disapointing AS FU**.

    Am I the only one with Wi-Fi greyed out on iOS 6?

  • Dgigman2 Level 1 (0 points)

    I will let you know. I'm in the process of updating right now.

  • Dgigman2 Level 1 (0 points)

    Before I upgraded to 6.0, I could turn on/off WiFi, even though it was unable to search or connect to WiFi...now it is completely greyed out and I can do nothing with it.

  • Joringuy Level 1 (0 points)

    I am having the same problem after I updated my phone 4S. I can't activate my wi-fi feature. It is gray.

    Apple, fix this glitch.

  • Allie-o Level 1 (0 points)

    Same here.  I've tried reset on network settings, reset on all settings, powered down, and toggled Airplane Mode.  Nothing.

  • beeswax84 Level 1 (0 points)

    I was having this problem even before I upgraded to 6 ....

    Now after upgrading, while i can access wi-fi panel... I can't toggle the on/off button because its greyed out ...

    i'm positive this cannot be hardware damage ... not all of us in different parts of the world could have fried our 4Ss ... Apple, please release an update and fix this, I can't use 3G all day and I cannot function without wi-fi on my iPhone! And also, I cannot get it exchanged for a new one!

  • Mitya Rais Level 1 (0 points)

    Hey all of u - try to turn OFF location service