8 Replies Latest reply: Jun 25, 2012 9:38 AM by andreasNYC
andreasNYC Level 1 (0 points)

I reported the problem to Apple Support via email. but their responses were unhelpful and had no new information.

The suggestion for a fee based call to Apple technical support is insulting. Why would I pay for a call to fix a problem in your portal to sell me software?

Also, it is in Apple's best interest to address this; as it stands I can not upgrade to OSX Lion because it is only delivered via the App Store!


Am I to throw my Mac Pro out of the window? Is this how Apple provides support to their loyal customers?

How long are Apple products supported these days?

When I started to use Macs (1991), they had a great reputation, because everything was backward compatible. Not anymore!

The life cycle of Macs has become very short indeed for a very expensive product.


After 21 years I may switch to PC (can't believe I am writing this). IF I can not get a Mac that can run processor and graphics intensive tasks anymore, then I have really no choice. I am not buying a two year old Mac Pro at exorbitant prices to run Autodesk Maya (for complex and very high res rendering) when I can run the software on a PC faster and at less than half the cost.


Is Apple really abandoning the professional in favor of becoming a consumer electronics company?

Short sighted!


Sorry for the rant, but have become frustrated with Apple's lack of support!

Mac Pro, Mac OS X (10.6.8)
  • Carolyn Samit Level 10 (102,820 points)



    Aside from the rant, you, "Did what was recommended"..  we have no way of knowing exactly what you have tried and exactly what the proboem is. The article you linked from is regarding the fact that the sign in sheet does not appear ???


    If that is the case, exactly what have you tried that didn't work? The only suggestion from that link is that third party software can prevent the sign in sheet from appearing and that is true.


    If you have anti virus software installed, disable that.


    Try turning off the Firewall in System Preferences > Security


    If you have an app called Little Snitch installed, that will prevent the sign in sheet from appearing.


    If you haven't done so, instaling the Mac OS X 10.6.8 Update Combo  reinstalls the App Store for you which may help. It's ok to do this even though you are already running v10.6.8. Restart your Mac after the combo is installed, try the App Store.

  • andreasNYC Level 1 (0 points)

    Thanks for your reply!

    My apologies, if I was not specific in my first post.


    I went through all the steps that are listed in the document.

    First I disabled my anti virus program

    I went through third party software and uninstalled what I thought may interfere.

         BTW, here your reply is very helpful. I had Little Snitch installed, but have long since removed it.

    After that did not work, I re-installed OS X 10.6 from my install disks and then updated to the latest version like you said using the 10.6.8 Update Combo.

    Alas, no sign in sheet.


    Are there other known apps that prevent the sign in sheet from apprearing?

    Do I have to disable my virus protection anytime I want to sign into the App Store?


    Thanks again for your comment.



  • Carolyn Samit Level 10 (102,820 points)

    First I disabled my anti virus program


    Which a/v software do you have installed?

  • andreasNYC Level 1 (0 points)

    I am using VirusBarrier X6 current with the latest virus definitions.

    Can that be an issue even when I tried to restart my system with VirusBarrier not loading on startup?




  • andreasNYC Level 1 (0 points)

    To anyone still interested, I have found a workaround to the problem.


    I used a second hard drive that is installed in my Mac Pro to install a clean version of Snow Leopard from the original install disks, then upgraded it with the 10.6.8 Update Combo.


    Starting up from this clean system I was able to log into the App Store without a problem and download the Lion Installer.


    From what I can see, it seems that I did not remove all parts of little snitch. There was a kernel extension still on the hard drive, which may have caused the problem, but I can not say that for certain.


    Thanks for reading and thanks fro trying to help!


  • Carolyn Samit Level 10 (102,820 points)

    Even if the a/v software doesn't open at startup doesn't mean it's not running.


    Am I to throw my Mac Pro out of the window? Is this how Apple provides support to their loyal customers?

    Apple is not responsible for third party software that you install on your Mac.




    edited by:  cs

  • andreasNYC Level 1 (0 points)

    Dear Carolyn,


    You are right, Apple can not be responsible for all third party software available to Mac users, right?

    But you are missing my point. Apple is not responsible for all Mac compatible software, but it is for how Mac users are supported.

         My point is, that the support Apple provides has eroded over a number of years. Paying for technical support calls, paying for premium support, Apple Care (expensive)... Yes, there are Genius Bars, if you are lucky enough to be able to have one near (not so genius sometimes as they could not solve a problem I had with my iPhone). Development support for older (legacy) products has certainly shortened.


         Look, I get it, Apple wants to make money, like all other big corporations, such as Exxon, Microsoft, Intel, and ADM (Archer Daniels Midland Co.). Selling products earns money, customer support costs money.

    A short sighted view however, as brand perception and customer loyalty are what keeps Apple's sales strong.

    Apple is in danger being lumped in with the afore-mentioned corporations. What was a cool company making amazing products with a strong philosophy is turning into what is to be expected of the world's second biggest company (by measure of stock market valuation).


    To close, would it not have been easy for Apple support to post a list of third party software suspected of causing the problem along with a step by step process to completely remove it? Maybe an update could have taken care of the problem or pointed out the culprits?

    Why not suggest the workaround that I used? Would have saved me hours of trying other solutions.

  • andreasNYC Level 1 (0 points)

    If anyone is still reading this post here is an update:


    I have removed all traces of Little snitch from my system that I can find.

    However, when I start up from my main drive I can still not sign into the appstore, same symptoms as described above.

    My workaround works though, Starting up from the drive with the clean install I can sign in without a problem.


    Good luck to everyone with the same problem!