10 Replies Latest reply: May 16, 2012 6:12 PM by loephatt
loephatt Level 1 (0 points)

I initially tried the normal  System Preferences/ Users and Groups approach, unlocked the window, entered my existing password, entered my new password twice...got this...obviously I have edited the image to remove my name...




I AM the system administrator  :-)


Recovery mode using Lion results in a very similar message, a box pops up, etc. No go.


So I try to reset the Admin password to have a new Admin login which results in the "starting a new machine" screens, etc., so I can then change MY password, etc using this...


Boot single user and enter   rm /var/db/.AppleSetupDone


But the system reports it cannot find the file or directory.


So I login as Administrator (I have this password) and using the GUI, the option to change MY password is not showing.


So I login as root (I also have this password) and using the GUI, again, there is no option to change MY password.


As I upgraded/App Store via the network I do not have a disk to boot from.


I do have Time Machine backups, so the notion of restoring Apps and personal files and folders after a complete reinstall is not that hideous, though I have better things to do like most of you. But really, isn't there a way for me to change my password using the GUI?


A bit clearly got flipped. Any gurus with an assist?


Anyone else seen this?





MacBook Pro, Mac OS X (10.7.4), cannot change my password, ever
  • royalcaribbean101 Level 1 (25 points)

    This is very interesting indeed. First, did you try to create a new Admin account and change it from there? I know you said you logged in as admin, but I'm not sure if you created a new one. Also, try booting into Recovery HD by holding option when you boot your computer (before the Apple pops up) and select the Recovery HD. There, open up Disk utility and repair disk permissions. If that still doesn't work, my only other suggestion is to do a reinstall. It could be possible that some file was corrupt after updating and it is preventing you from changing your password. Hopefully, the permission repair will do it. Sorry I couldn't be of more help, but this is really somewhat of a weird situation.

  • Topher Kessler Level 6 (9,865 points)

    Are you able to create new user accounts on the system? And do they have appropriate password settings and behavior?

  • royalcaribbean101 Level 1 (25 points)

    If I understand correctly then yes. In system preferences, go to Users & Groups and in the bottom left click the plus button (you may have to hit the lock first). From there, you can create a new user. They can change the password if it is an admin. I would probably suggest repairing permissions first since I think that may be the most logical explanation. Have you ever run it before? And if so, was it in Recovery HD?

  • loephatt Level 1 (0 points)

    royalcaribbean101 - I did establish a new Admin account, and logged in as that new Admin. No option to change MY password appears.


    I did repair Disk and also the ACLs, etc. No change.


    Topher Kessler- Yes, I can add new users - but none, with Admin privs, can change MY password. The option to do so is not appearing.


    royalcaribbean101- Yes, I did create a new user with Admin privs, no change. I repaired permissions from the Recovery mode. No change.


    Thanks all - you are all being very systematic and logical. But I've tried these paths to no avail.


    I think I have unearthed a potentially annoying bug in the way they changed things for 10.7.4 WRT Users and restoring/repairing same.




  • royalcaribbean101 Level 1 (25 points)

    This certainly is strange. One last resort I would try is to maybe go back into Recovery HD and hit Repair Disk instead. That's honestly the only other thing I can think of besides restoring.

  • Topher Kessler Level 6 (9,865 points)

    First ensure you have a backup of your system. Then try rebooting into single user mode, and then run the following commands:


    mount -uw /
    passwd USERNAME


    Change "USERNAME" to be the short name of your admin user account, and see if that allows you to both change the password and restore its functionality. You can also try this with the following command:


    dscl . -create /Users/USERNAME Password PASSWORD
  • loephatt Level 1 (0 points)

    Topher -


    this is what I get when I try this....


    ---------- snip -----------


    :/root# dscl . -create /Users/Admin Password xxxxxxx

    launchctl: Couldn't stat("/System/Library/LaunchDaemons/com.apple.DirectoryServicesLocal.plist"): No such file or directory nothing found to load

    Operation failed with error:eServerError


    ---------- snip -------------------------


    This is what I saw in previous single user attempts.



  • Linc Davis Level 10 (192,689 points)

    Back up all data. Log into another admin account. Delete the problem account without deleting the home folder. Recreate the account with the same name and the same numerical user ID, which you can do by right-clicking the account name and selecting Advanced Options...

  • loephatt Level 1 (0 points)



    Logged in as a newly created Admin - cannot do a thing. Option to delete the user (me) is grayed out. In fact all Users but the logged-in Admin are grayed out.   


    Logged in as root - I can select other users including ME, but the little minus sign is grayed out and will not allow me to delete myself and follow your instructions.






    Message was edited by: loephatt

  • loephatt Level 1 (0 points)

    Of course, in my haste I failed to unlock the little lock icon on my previous attempt. I used a new Admin account, UNLOCKED the stupid icon, and successfully changed my password.


    Of course all of my prefs, etc., are defaulted but that's a minor issue.


    Thank you to all, and especially to Linc Davis. I appreciate your advice.







    ps...can't edit my bogus reply post.


    Message was edited by: loephatt