8 Replies Latest reply: Mar 13, 2006 1:22 AM by Jamie McGregor
Jamie McGregor Level 1 Level 1 (10 points)
Hi all,

I'm sure this is covered elsewhere, but I have searched the boards and while I can find plenty of complaining about the way Mail manages attachments inline, I can't find anything on this specifically.

When I send attachments (always "Windows Friendly") they are received OK, but for every attachment sent, the receiver (usually on Windows using Outlook) receives an extra attachment called "ATTxxxxxx.htm" where xxxxxx are 6 numbers.

They're minute in size, but I have people ringing me up saying they can't open them, thinking they're important, not to mention it's a nightmare if I'm forwarding on an email with, say, 6 JPEGs, the end user receives 12 attachments, 6 of which are gobbledygook. "Oh, you're using a Mac..." they say condescendingly...!

I am using an Exchange account through IMAP in Mail. I have tried sending through different SMTP servers, but I still get the same result.

Is this usual behaviour??

Thanks.
Jamie.

Powerbook G4   Mac OS X (10.4.2)  

   
  • Allan Sampson Level 10 Level 10 (123,370 points)
    Are you using RTF for message composition and including a signature?

    Some email clients (mostly Windows Outlook) and thru an Exchange Server don't read Mail's RTF properly and I'm not sure why.

    If so, try using Plain Text instead to see if it resolves the problem.
  • Donna Smyth Level 1 Level 1 (20 points)
    Me too - although it seems somewhat random and I get fed up with having to downgrade from RT format to text only - I really don't know why Apple can't get this right - and the attachement embedding problem.
  • Jamie McGregor Level 1 Level 1 (10 points)
    I was indeed using RTF with a signature. OK, so I tried sending the mail in Plain Text with 2 attachments.

    This time, it only sent one extra attachment called ATT214002.txt. (Not 'htm').

    I suppose that's an improvement... but not really!

    Also, this attachment shows up as "mime-attachment.txt" when viewed back in Mail.

    Help!

      Mac OS X (10.4.2)  
  • Allan Sampson Level 10 Level 10 (123,370 points)
    Hello Donna.

    You are assuming this is an Apple problem but if it primarily or only occurs with recipients using Windows Outlook which seems to be the situation, this indicates it is a Microsoft/Outlook problem.

    What attachment embedding problem?
  • Allan Sampson Level 10 Level 10 (123,370 points)
    After switching to Plain Text, were the inline or viewed in place attachments above or below your signature?

    Does you signature include a graphic?
  • bneely Level 5 Level 5 (5,255 points)
    Jamie:
    Does the same thing happen if you send a message as plaintext?

    To try this, create a new message window. Then in the Format menu, choose Make Plain Text. Type a message, add attachments, send, and then ask the recipients what they see.
  • bronson Level 2 Level 2 (280 points)
    This "problem" (don't really know how to classify it) occurs when you attach a file and have text below the file (such as a signature).

    Apple Mail attaches the files inline and for some reason, Outlook has a problem going from an inline attachment back to text. Looking at the source of the email and everything looks correct.

    You have a couple of options to fix this.

    1. Make the attachment the absolute last entry in your emails. And I do mean last, no signatures, comments, even blank lines.

    2. This is really for image files, but you can place the attachments inline AND have text below the attachment, but you must ensure that it is an RTF email. I have found that even if Mail says it's an RTF message, unless there is some actual formatting in the message (font color, bold, italics, etc) then Mail will send the message as plain text even though you chose RTF. So, create a signature with some color or something like that and it should work. At least it has for me.

    I hope this helps!

    Bronson
  • Jamie McGregor Level 1 Level 1 (10 points)
    Thanks, Bronson.

    Well, after some trial and error, it seemed combining the suggestions above worked.

    I tried sending the mail Plain Text, and as noted above, I got one extra attachment total, not one extra attachment for each item as was happening before.

    However, making the attachments the final items below everything else as suggested by Bronson, on a Plain Text email solved the problem.

    Despite Bronson's fix nr 2, I couldn't get it to work with RTF format at all, regardless of where I put the attachments.

    The next question is: how then do you forward on emails you have received from other people without this happening? Can you manipulate the attchments so that they are the "last" thing on the email??

    Thanks
    Jamie.