3 Replies Latest reply: May 22, 2012 7:25 AM by remobec
remobec Level 1 (0 points)

I have just spent hours upon hours working on a video for work. I've made it on my personal computer, so no one else really knows much about it. I finally got it done and sent it to iDVD. Burnt a DVD and tried it out. The sound was all messed up. I'd detached most of the audio, deleted it, and added new audio. Not only is the original audio back, but some of the audio at the end of the movie randomly plays at the beginning.


I tried this twice and it did the same thing. Then I updated the Mac and it still did the same thing.


iMovie still plays the movie correctly.


My iDVD is 7.1.2. My iMovie is 8.0.6. My Mac is running on Mac OS X, 10.6.8.


Please help! I haven't a clue what to do. This is a time sensitive project I've just spent a long time on.

Mac Book, Mac OS X (10.5.4)
  • Bengt Wärleby Level 6 (19,450 points)



    Can be so many things


    First I would

    • Trash iMovie pref file (IMPORTANT)

    • Repair Permissions - Disk Util tool (IMPORTANT)

    • Secure a minimum of 25Gb free space on Start-Up (Mac OS) Hard Disk



    • I never use "Share to iDVD" - but "Share to Media Browser" and as Large - NOT HD or other resolutions as this too degrades the resulting DVD - it set's iMovie rendering aside and let iDVD do this - so much better


    • There is a known BUG in iDVD - when done a iDVD project - do not go back to iMovie/FinalCut to make adjustments. iDVD will notice and set of the BUG - All Chapters will start as Chapter One and more.


    • I only use .aiff Audio in my iMovie/FinalCut projects - all other are converted to this (44.1 kHz on Audio CDs and rest 48kHz 16-bit .aiff). ESPECIALLY audio from iTunes - I always burn as an Audio-CD .aiff (never .mp3) and then I use the files from this in my movies.


    My thoughts for now. Yours Bengt W

  • remobec Level 1 (0 points)

    Thanks Bengt,


    I tried to trash the iMovie pref file. After searching around a bit, I think I found where it was supposed to be, but there were just 2 iLife files (08 and 09). I trashed those, since iMovie is part of the iLife suite. Does that sound right?


    They're still in my trash if I need to pull them out, but they're: com.apple.iLife08.plist and com.apple.iLife09.plist



  • remobec Level 1 (0 points)

    OK, after more web searching, I discovered how to fix the problem. This forum has several other people with the same problem, as well as, at the end, a few people who discovered how to fix it. http://www.mac-forums.com/forums/movies-video/176174-imovie-export-sound-issue-2 .html


    For me, I adjusted the speed of a few clips so that they were at the preset iMovie values--100%, 50%, etc.