3 Replies Latest reply: Dec 5, 2012 2:54 AM by bmw666_M3
Fly_Guy Level 1 Level 1 (0 points)

Just paid for a movie on iTunes, (The Great Escape), but it won't play on my iMac or transfer to my iPad... what gives?

 

When I try to play the movie I get error: "This movie requires QuickTime, which is not supported by this version of iTunes."

When I try to move it to my iPad I get the error: "The Great Escape (1963)" was not copied to the iPad (My iPad) because it cannot be played on this iPad."

 

I have iTunes 10.6.1 (7) 64-bit on a brand new iMac 2.7 Ghz Intel Core i5 with OSX 10.7.4.

 

I'm a little ticked that I can't see a movie I just paid $9.99 for.

 

Any assistance is appreciated.


iMac, Mac OS X (10.7.3)
  • Gary Scotland Level 6 Level 6 (11,020 points)

    update Quicktime:

     

    in QuickTime Player > update

  • Fly_Guy Level 1 Level 1 (0 points)

    Gary,

     

    Thanks for your reply.

     

    I went to applications and opened Quick Time Player (Ver. 10.1). None of the Quick Time Player menu items have an option for update...

     

    I checked for system updates, and I am completely up to date... no software updates available. OSX 10.7.4

     

    Now what?

  • bmw666_M3 Level 1 Level 1 (0 points)

    i had this problem and solved it by simply rebooting my imac

     

    heres what happened to me...

     

    i updated itunes to v11, watched a few movies and then tried to add some tv shows

    i couldn't find them anywhere, i restarted itunes trying to fix this problem

    this is when i got the same error as you, i knew something wasn't right as i had just been watching videos but now NOTHING would play

     

    all i had done was exit itunes and open it again!!!!

     

    i simply rebooted my imac and videos started playing in itunes again with no quicktime error

     

    i hope this works for you