6 Replies Latest reply: May 20, 2012 10:05 AM by keighlee
keighlee Level 1 Level 1 (0 points)

it started about a week ago my phone wouldnt charge i bought a brand new usb connecter it worked fine once. it would only charge now and again or the phone had to be completely dead for it to start charging. now once my battery runs dead it says its charging but once it comes back on it stops charging and im currently stuck with 1% so my phone works for 5mins then goes dead again!!! i have recently upgraded the software to 5.1.1


iPhone 4S
  • deggie Level 9 Level 9 (50,445 points)

    Sounds like you have a bad battery or a bad dock connector. You need to get it serviced.

  • keighlee Level 1 Level 1 (0 points)

    ive only had the phone since january surely it shouldnt need a service after 4 months? ive always had a case on it so its always been fully protected ive tried charging without the case on no difference

  • deggie Level 9 Level 9 (50,445 points)

    If it had a defective battery that failed early, or a loose connection on the dock connector, then yes it could have happened and that is what warranties are for. If you have dropped it, jerked the connector from it resulting in damage, or exposed it to moisture, then that is accidental damage and it will not be covered by the warranty.

     

    Make a Genius Bar appointment at your nearest Apple Store and have it diagnosed.

  • keighlee Level 1 Level 1 (0 points)

    yeah ive booked in just now for tomorrow i hope they fix it there and then, its the second i phone ive had the first one phone i had, had a defective lock button lets hope third time lucky exists!

  • jemg1982 Level 1 Level 1 (0 points)

    Hi there

     

    Can you please let me know what they say tomorrow? Mine is doing the same thing, and it seems to be happening to lots of people. Did you install OS 5.1.1 by any chance?

     

    My phone has to be completely dead to charge, although it doesn't show the charging icon. I can't connect to iTunes or anything, it's really annoying!

     

    People keep suggesting that it's a problem with the cables (it's not as my brother's phone charges, plus mine does if it's switched off), or there's dust etc in the USB port (there's not but I cleaned it anyway), but I think otherwise as it's too much of a coincidence that so many on the various forums are experiencing it.

     

    Thanks, and I hope you get yours fixed

  • keighlee Level 1 Level 1 (0 points)

    Hi they gave me a brand new phone as they tried the charger with their phone and it worked so they new it was a fault and not something down to me. Yes it's all happened since the new software 5.1.1 :( but new phone now so hopefully all sorted x