7 Replies Latest reply: Aug 24, 2012 1:26 PM by skypilot73
DVX100Shooter Level 3 Level 3 (845 points)

For some reason my hard drive went off line for a second and then came back up and I got the Device Removed prompt on my screen but I didn't touch the hard drive or remove the cable connecting it to my laptop anyway, now my Aperture library will not open. I tried holding down CMD and Option while opening Aperture and tried to Repair database which did nothing, I also tried to Rebuild Database which did nothing. Anything else I can try? I do have a back up but not of my most recent stuff.

 

Thanks!


MacBook Pro, Mac OS X (10.5.8), 2.33 Dual Core; 1st Generation
  • DVX100Shooter Level 3 Level 3 (845 points)

    So I chose to do a rebuild. How do I know when its completed. After a while Aperture appears to have shut down so I when click on it to open, I get a message saying Aperture was in the process of rebuilding but now I need to Repair the database to bring it back to its current state! How am I to know when that is to be completed?

  • DVX100Shooter Level 3 Level 3 (845 points)

    I forgot to add in my posts, this is the message that I get when I try to open Aperture:

     

     

    Warning!

     

    There was an error opening the database for the library "/Volumes/My Backup/Aperture Library.aplibrary".

     

    I can't believe I am not getting any replies. I guess nobody has experience this before huh?

  • DVX100Shooter Level 3 Level 3 (845 points)

    Is there anything within the database that I can remove to get Aperture to open? If I right click on the Library file and click Show Package Contents I see a number of folders and files. Is there anything in there that I can move out and then try opening Aperture?

  • Frank Caggiano Level 7 Level 7 (25,715 points)

    First have you powered everything off and then back on and rebooted since the original incident? if not do that first.

     

    You;re second post is confusing, you started a rebuild but you don't know if it finished? If you're getting the rebuild interrupted message it's most likely that the rebuild didn't finish. Stopping a rebuild in the middle is never a good thing and can easily make a bad situation worst. Before trying it again backup the library then you'll need to let it run, possibly overnight depending on the size of the library.

     

    If the rebuild finishes and you still have problems try moving the plist file (~/Library/Preferences/com.apple.aperture.plist to the desktop and re-running Aperture.

     

    Another thing you can try is to start Aperture while holding the shift key to defer preview generation. If you have a corrupt image file in the library that should help.

     

    Both the plist and preview deferral are shown in Aperture 3: Troubleshooting Basics

     

    Finally make sure Aperture is running ok. Start Aperture while holding down the option key. That will bring up the library choice window. Create a new library and let Aperture run on it.

     

    I'd hold off on trying to manually rebuild the library just yet.

  • skypilot73 Level 1 Level 1 (0 points)

    Any luck I had the exact same thing happen and I am stuck with same error messages.

     

    Dan

  • DVX100Shooter Level 3 Level 3 (845 points)

    @Skypilot, I either rebuilt my library or I found my last backup that was in a vault and used that but I might be getting to different Aperture issues mixed up. I know on one ocassion I rebuilt the library and the other I used a backup that was in my vault.

  • skypilot73 Level 1 Level 1 (0 points)

    Thanks I rebuilt the database and that seemed to solve it.

     

    Thanks so much