4 Replies Latest reply: May 20, 2012 11:04 AM by John Caradimas
John Caradimas Level 1 (10 points)

I am using the latest version of Aperture and just noticed that when my pictures are imported into my home directory structure (~/Pictures/Year 2012/May/whatever) (I am using referenced masters) the permissions of the raw files (NEF) are rwxrwxrwx@.


Isn't that somewhat dangerous? I mean I do not like to have any world writeable and executable files on my system. Am I crazy or am I doing something wrong? Is there a way to change the file permissions, when importing (read: automatically) to rwxrw_ _ _ _? I hate to need to remember to do it manually every time I import some pictures to my system.


Any advise will be welcome.

  • Frank Caggiano Level 7 (25,715 points)

    How are you importiing? What version of the OS? What version of Aperture?

  • John Caradimas Level 1 (10 points)

    Lion 10.7.4, Aperture 3.2.3


    Right-click on project, select Import/Files.

    Select the card in the card reader, mark the images I want to import. Adjust where files will be stored (the folder I want the raw files to go into) and what Adjustment Presets I want. Click on Import Checked.


    I think I've managed to change the above behavior. I opened my disk in Finder, select my Pictures folder and changed Sharing and Permissions to :


    Me: Read and Write

    Staff: Read only

    Others: No access


    Then I asked for those permissions to be applied to the enclosed items. Next time I imported a picture, it had rw-r--r--


    Not perfect, I'd prefer if the world couldn't see my files at all.

  • Frank Caggiano Level 7 (25,715 points)

    Right the Aperture import just uses the permissions the files have on the card, so what you saw was normal.


    As for your concern, in OS X your home folder is pretty well locked up, No one can get to your Pictures folder so they can't se what's in it. Having the files world readable in this case really isn't much of a problem.


    I'm surprised that setting Others to no access left the read bit on, never really checked that out. If that is the case (and I have no reason to doubt  you) and this is that important to you you could chmod the files from the terminal. With a combination of Applescript and Shell script you could be able to automate the process fairly easily.



  • John Caradimas Level 1 (10 points)

    I am pretty sure that that's what happened, but today is not the best of days to test things out. Last night, I managed to throw down my 70-300mm Nikon lens, so I am at a bad mood. And I've just finished repairing the permissions of my home folder in my iMac. I still need to fix some things on my server too, so I'll check this out more thoroughly tomorrow, after I return from Nikon's rep here.


    Thanks for your assistance, greatly appreciated.