2 Replies Latest reply: Dec 5, 2012 9:13 AM by tluns23
KTGI Level 1 Level 1 (0 points)

I'm a new convert to mac from PC.  New MacBook Pro, bought two weeks ago.  I successfully twice imported AVHCD videos from the SD card of my Sony camera, but my third try I can't get iMovie 11 to even recognze the camera or SD card. 

 

The first two times, as soon as I put the SD card in the slot, iMovie opened and offered me the import option.  This time, iPhoto opens automatically, but iMovie does not, and when I manually open iMovie and select "import from camera" it only offers me the FaceTime camera. I try to select a different camera, but facetime is the only option.  As far as I can tell, I did nothing different, and I don't think I've changed any settings (honestly, I wouldn't know how).

 

I've deleted all of the still photos from the SD card, but I still get the iPhoto autoopen, and it hasn't fixed the problem.  I've also tried shutting down/restarting, and connecting directly from the camera w/ a USB cable, but no joy.  The SD card still has the "original file structure" as when it was shot.  

 

The whole reason I spent the extra $1000 for a mac was because the video editing was supposed to be better and easier to use.  I hung in there evern after discovering I can't use my last two years of stored AVCHD video anymore.  But now I can't even use the new video I shot yesterday. 

 

I am not a techie, but I gather that the answers sometimes have to do with the OS.  I'm running OS X, v. 10.7.3, 2.4 GHz intel core i5. 

 

Please help - at wit's end!


iMovie '11, Mac OS X (10.7.3)
  • EZ Jim Level 7 Level 7 (21,595 points)

    (1) Use  > Software Update... to be sure your Apple software is up to date.

     

    (2) Launch iMovie before you insert the SD card.

         Wait a few seconds for the card to be recognized.

     

    (3) Have you seen this Apple video tutorial?

     

    (4) For additional detailed help about importing: http://support.apple.com/kb/PH2114

     

    (5) You show Sony.  This article may help you: http://support.apple.com/kb/HT1793

     

    (6) You can stop iPhoto's automatic opening with this iPhoto > Preferences...

     

       xxx.png

     

     

    Message was edited by: EZ Jim

     

     

    Mac OSX 10.7.4

  • tluns23 Level 1 Level 1 (0 points)

    You may have already resolved this issue, but I found out some great information today from Sony directly.  I was having the same problem, and I was convinced iMovie (i'm using iMovie 09) couldn't import MTS files.  I was wrong iMovie does it very easily.  The problem iMovie has is when you connect your camera, most people click the "video camera" icon so they can see the videos on their camera they wish to import.  What I found is that if you haven't cleared off your video camera in some time, and have over 10 gigs of video on the camera, iMovie has a real hard time, because it has to search the camera and bring up the clips in that lower window pane.

     

    What I did was go thru the clips on my video camera that I could delete (actually watched them on the camera itself), this can be time consuming.  But, once I cleared down the content on my camera under 10 gigs, iMovie saw the information quickly.  Here's another thing I did, that also may help...instead of clicking on that little camcorder icon, use FILE, Import from Camera at the top menu bar instead.  When I did this, it started looking for my attached video camera.  From now on I will clear off my video camera more frequently so that iMovie doesn't bog down looking for possible imporatable videos on the camera.  Recommendation from Sony was keep it under 10 gigs.

     

    Hope this helps. 

     

    Tim

     

    P.S.  There is no truth to the idea that iMovie does not import MTS files.  My Sony HD Handycam takes all MTS files and iMovie has no problem with them at all.