Previous 1 2 Next 20 Replies Latest reply: May 22, 2012 12:23 PM by BDAqua
herzdamen Level 1 Level 1

I need to enable assistive devices in order to play some games in my Macbook but I cannot even find "Universal Access" in my System Preferences. Is it only available for Lions?


MacBook, Mac OS X (10.5.8)
Reply by a brody on May 21, 2012 4:37 AM Helpful

Universal Access is in each version of Mac OS X.  If you are missing yours, then it somehow got removed by accident.  If you are running 10.5, what you can do, is backup your system at least twice:

https://discussions.apple.com/docs/DOC-1992

Make sure you have enough hard disk space for an archive and install:

https://discussions.apple.com/docs/DOC-2209

And apply the combo update:

http://support.apple.com/downloads/Mac_OS_X_10_5_8_Combo_Update

If you are running any other version of Mac OS X than 10.5, the instructions are different, and we'd have to know what you are running.

Reply by Klaus1 on May 21, 2012 5:20 AM Helpful

If that doesn't do it, you will need an archive and install:

 

How to Archive & Install:

 

http://support.apple.com/kb/HT1710

 

and this also:

 

http://support.apple.com/kb/HT2196?viewlocale=en_US

All replies

  • herzdamen Level 1 Level 1

    BTW, when I go to the Speech panel in System Preferences, I see an option "To change VoiceOver settings- Open Universal Access Preferences", but then when I click on that it reads "error 2 param, item may not be installed or disabled."

  • a brody Level 9 Level 9
    expertise.classicmacos
    Classic Mac OS

    Universal Access is in each version of Mac OS X.  If you are missing yours, then it somehow got removed by accident.  If you are running 10.5, what you can do, is backup your system at least twice:

    https://discussions.apple.com/docs/DOC-1992

    Make sure you have enough hard disk space for an archive and install:

    https://discussions.apple.com/docs/DOC-2209

    And apply the combo update:

    http://support.apple.com/downloads/Mac_OS_X_10_5_8_Combo_Update

    If you are running any other version of Mac OS X than 10.5, the instructions are different, and we'd have to know what you are running.

  • herzdamen Level 1 Level 1

    I am running 10.5.8, it is a 2.13 GHz Intel Core 2 Duo Processor. And yes, I think I may have accidentally removed it when I was deleting files from my library, oops. But let me see those links and I will get back to you!

  • herzdamen Level 1 Level 1

    Unfortunately, I don't think I have made any backups (unless the Mac has made automatic ones, I am not sure) but I am now downloading the combo update. Not sure what else I can do if I have deleted the Access-files and I have no backups. :/

  • Klaus1 Level 8 Level 8

    If that doesn't do it, you will need an archive and install:

     

    How to Archive & Install:

     

    http://support.apple.com/kb/HT1710

     

    and this also:

     

    http://support.apple.com/kb/HT2196?viewlocale=en_US

  • a brody Level 9 Level 9
    expertise.classicmacos
    Classic Mac OS

    You should backup your data regardless before any Archive and Install or software install.  Read my tip on backing up.  You could end up in worse shape if there is a drive issue, or a directory issue and the Archive and Install fails.  So backup first before doing anything.

  • herzdamen Level 1 Level 1

    Thank you for your continued assistance. What I have done so far is to apply the combo update; this was successful and it seems that now my System Preferences has Universal Access installed and one more panel (on Desktop preferences, which by the way does not work, as when I click at the icon, it leads to a blank page). The weird thing lies in that these two new panels were installed in German, even though I downloaded the English version. Wut?

     

    After I did this, I enabled the assistive devices in Universal Access (or, Bedienungshilfen) and then I reloaded the game, but apparently the system does not recognize the German version because the game refuses to see that such option has been enabled.

     

    Perhaps I should run Combo again, but before I am going to back up my data as a brody wisely suggested and then reinstall.

  • BDAqua Level 10 Level 10

    "Try Disk Utility

     

    1. Insert the Mac OS X Install disc, then restart the computer while holding the C key.

    2. When your computer finishes starting up from the disc, choose Disk Utility from the Installer menu at the top of the screen. (In Mac OS X 10.4 or later, you must select your language first.)

    Important: Do not click Continue in the first screen of the Installer. If you do, you must restart from the disc again to access Disk Utility.

    3. Click the First Aid tab.

    4. Select your Mac OS X volume.

    5. Click Repair. Disk Utility checks and repairs the disk."

     

    http://docs.info.apple.com/article.html?artnum=106214

     

    Then try a Safe Boot, (holding Shift key down at bootup), run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions, reboot when it completes.

     

    (Safe boot may stay on the gray radian for a long time, let it go, it's trying to repair the Hard Drive.)

  • herzdamen Level 1 Level 1

    Like I said, the very first thing to do was to apply the combo update, so then my System Preferences looked like this: http://i47.tinypic.com/nx8ggy.png and http://i48.tinypic.com/rba9eu.png. And by the way, the Screen Saver- pane looks like this when I click the tab: http://i49.tinypic.com/1zvem3q.png

     

    So then I inserted the installation disc and through Disk Utility I first verified the drive, and then at another time, I repaired the drive. The response was that everything appeared okay in both occasions. But still, the panel was in German - and it does not even look like the usual A-sign which Universal Access sports.

     

    After that, I did precicely each step as suggested by BDAqua, and clicked to repair, and the message was that everything appeared okay, still. Then once I clicked to repair permissions, at the end I received this message: http://i50.tinypic.com/2akgw7q.png

     

    Let me add here that through System -> Library -> Preference Panes, I can actually see a file that reads:

    file://localhost/System/Library/PreferencePanes/UniversalAccessPref.prefPane/ among all other panes.

     

    I don't know what else to do, it seems that there is no problem, and yet not only is the pane downloaded in German but also it does not seem to work!

  • BDAqua Level 10 Level 10

    You can ignore the Permissions report, just needed to be done once.

     

    Do Klaus1's suggestion of an A&I.

  • herzdamen Level 1 Level 1

    Does that mean I will have to re-install Mac OS from the beginning and my current HD will be in the "previous files" archive while I also have a new drive, then?

  • BDAqua Level 10 Level 10

    It's a relatively painless Archive & Install, which gives you a new/old OS, but can preserve all your files, pics, music, settings, etc., as long as you have plenty of free disk space and no Disk corruption, and is relatively quick & painless...

     

    http://docs.info.apple.com/article.html?artnum=107120

     

    Just be sure to select Preserve Users & Settings.

     

     

    10.5 & up doesn't make a Previous Systems folder as far as I know.

  • herzdamen Level 1 Level 1

    Awright. On another note, if I upgrade to Lion, will the problem be solved? Will I have the entire system upgraded and keeping my files as it is?

  • BDAqua Level 10 Level 10

    Likely, but if you go straight to Lion/10.7.x, it requires erasing the drive, better to get the SL/10.6 Disc & Install that first.

     

    Snow Leopard/10.6.x Requirements...

     

    General requirements

       * Mac computer with an Intel processor

        * 1GB of memory (I say 4GB at least, more if you can afford it)

        * 5GB of available disk space (I say 30GB at least)

        * DVD drive for installation

        * Some features require a compatible Internet service provider; fees may apply.

        * Some features require Apple’s MobileMe service; fees and terms apply.

     

    Which apps work with Mac OS X 10.6?...

     

    http://snowleopard.wikidot.com/

    It looks like they might still have it...

     

    http://store.apple.com/us/product/MC573Z/A?fnode=MTY1NDAzOA

     

    If it's a core Duo & not a Core2Duo, then it'll only run in 32 bit mode.

     

    Lion/101.7 System requirements

        •    x86-64 processor (Macs with an Intel Core 2 Duo, Intel Core i3, Intel Core i5, Intel Core i7, or Xeon processor.)

        •    At least 2GB of memory, I say 6 GB

        •    Latest version of Mac OS X Snow Leopard (10.6.8), with the Mac App Store installed

        •    At least 4GB of disk space for downloading, I say 50 GB.

    Like Snow Leopard, Lion does not support PowerPC-based Macs (e.g., Power Macs, PowerBooks, iBooks, iMacs (G3-G5), eMacs).

    Lion also does not support 32-bit Intel Core Duo or Core Solo based Macs. Rosetta is no longer available in Lion, which means Lion no longer supports PowerPC applications.

     

    http://en.wikipedia.org/wiki/Mac_OS_X_Lion#System_requirements

     

    http://www.apple.com/macosx/how-to-buy/

     

    What applications are not compatible with Mac OS X 10.7 "Lion"?

     

    http://ow.ly/5Iz09

     

    http://roaringapps.com/apps:table

     

    Or, if you can afford to erase everything & spend $10 more than the 10.6 Disc & 10.7 from the App Store...

     

    It looks like Apple will have has Lion available on USB drives for $69...

     

    http://store.apple.com/us/product/MD256http://x704.net/bbs/viewtopic.php?f=12&t=5355&p=65083&hilit=It+looks+like+Apple+ will+have+Lion+available+on+USB+drives#p65083


Previous 1 2 Next