Previous 1 2 Next 22 Replies Latest reply: Oct 26, 2012 2:45 AM by a brody
Nicholas Goss Level 1 (10 points)

I have searched on google and found ALOT of people who have experienced this same problem, but nobody has bothered to post the soloution?


For no reason, my iMac G5 17" has suddenly started to display, what appears to be in only Finder, small black vertical lines.


Now these small black vertical lines, appear in the icon areas.


For example, the "icon" area of the mouse, that whole box area that you get to draw your groovy new mouse pics is all vertical black lines.


Also any desktop icon is covered in vertical black lines.


The "window" around Safari, has a few black lines arouned it and it makes it generally hard to read anything that is displayed through or with the help of Finder.


Surly there is a fix for this and its not the iMac just suddenly for no reason dying..??


See images attachedPicture 4.jpg

iMac G5 1.8GHz 17", Mac OS X (10.4.11), 512ram - BT - WiFi - DVD+-RW - NVIDIA-GeForce FX5200 64MB - iP
  • a brody Level 9 (65,736 points)

    First off, your machine is old enough any software updates that are available for it will only be on

    Secondly, what is the icon between the Dashboard and the Mail icon?

    Third have you tried to run the hardware test that came with your Mac?

  • Nicholas Goss Level 1 (10 points)

    First off - no the 'software update' still works fine on OS X 10.5 even on PPC mac's.


    Secondly, that 'icon' between dashboard and mail, is "TenFourFox". Its a browser for us PPC people.


    You see Safari & Firefox development stopped for PPC Mac users which is really frustrating. I am one of the lucky people who changed from PC to Mac, 3 months before Mac decided to ditch PPC and switch to Intel based processors.


    So I am left with a very powerful G5 based 64bit processing computer that works fine, but has had it's development dropped to force people like me into intel based unit's. But thats a topic for elsewhere...


    Thirdly, I have not yet run the hardwar test. I will be doing so but at the moment I do not believe that it's a hardware fault from what I have read. For example I know on one bulletin board someone had fixed this same problem by deleting the file (which at reboot will reset itself)- however that file already does not exist on my machiene so that must have been an intel based unit they were on.


    I will run hardware test tonight but I honestly dont think it's a hardware fault as the problem exists only in Finder.

  • Nicholas Goss Level 1 (10 points)

    Any ideas? Anyone seen this before?

  • a brody Level 9 (65,736 points)

    Unless you installed anything else Apple did not ship with the machine, it is doubtful this is anything other than hardware problem, even if the test comes back negative

  • Klaus1 Level 8 (47,745 points)

    TenFourFox is innocent, OK! (I use it myself).


    As only the Finder seems to be affected, I have a nagging feeling that this may be caused by a font conflict, i.e. a damaged system font.


    Have you checked that?


    Another thing. You wrote:


    For example I know on one bulletin board someone had fixed this same problem by deleting the file (which at reboot will reset itself)- however that file already does not exist on my machiene so that must have been an intel based unit they were on.


    It should definitely be on your Mac in Home/Library/Preferences, but I doubt that is relevant.


    Message was edited by: Klaus1

  • -Rotten Apple- Level 1 (45 points)

    Atleast it seems like graphic card issue. I have the same machine and I am currently battling issues with it also. In my case there was artifacts like that and much more, I got them solved by changing couple capacitors... some other issues are however still present. If it is a real GPU problem, then there is basically choises for either reball or reflow the chip or get totally new chip and then solder it back or then get a new logic board. These models however are more prone to capacitor flaws on motherboard or power supply rather than GPU solder faults.

  • Nicholas Goss Level 1 (10 points)

    Thanks Klaus1, I'll try both when I get home from work tonight.


    It's a little but frustrating to see so many people bagging my beautiful iMac just because it's PPC based. Had I bought the intel version only 3 months later people wouldn't be referring to it as "old" just because of a different CPU build...


    The PPC G5 processor was a really powerful 64 bit processor. It was a real shame when Apple dumped it. I know there was alot of software benefits in going to intel but I still personally feel that the G5 was awesome.


    By the way, for the "intel" users... TenFourFox is a replacement browser to FireFox. As Firefox stopped its PPC development of its browser, the "PPC Community" took over dev of it and as such tenfourfox was born.

  • Klaus1 Level 8 (47,745 points)

    I mostly agree with you. I bought my G5 iMac three months after they had been declared 'end of line' (and were thewrefore sold at a discount), when the first Intel iMacs came on sale. That was six years ago. I bought it to do certain specific tasks (converting 50 or so family videos to digital media including burning them to DVDs, scanning the family photo archive (goes back to 1855) of nearly 16,000 photos to create a digital archive, etc etc).


    It has continued to do all I ask, flawlessly. There are things I cannot do which I probably could do on an Intel Mac, but so what?


    But of course our G5s are 'old' in computer terms, but again, so what? My car is 9 years old and has no problems, I am 68 years old (wish I could say the same!). Reliability is what counts, not keeping up with the Jones's!

  • a brody Level 9 (65,736 points)

    I'm not bad mouthing TenFourFox, or the G5.  I just happen to know what a graphics chip issue typically looks like.  I had one with my iMac G4 which wasn't too different.  It appeared the same style only over my Realplayer window after it automatically changed resolutions on the display for me.   Apple ended up diagnosing it to be a graphics chip issue.  I got it with an older version of Google Earth on my iMac Intel Core2Duo but don't currently have the money to rule out anything else.     Thankfully I rarely use Google Earth, so I don't run into the issue that often.

  • Nicholas Goss Level 1 (10 points)

    I paid full price - $2,200 at the time, and yes I was diss appointed that 3 months later it was made redundant !

    Such is life?


    I have not yet found anything my PPC Mac can't do that an intel one can. There are work arounds or alternatives for just about everything I have come across.


    Anyway, I will post update tonight.

  • Klaus1 Level 8 (47,745 points)

    I was diss appointed that 3 months later it was made redundant !

    I prefer 'demoted'!


    Such is life?


  • Nicholas Goss Level 1 (10 points)

    This is getting really frustrating.


    I am pretty sure it's hardware now.


    When I put the install disk in, for any version the 'mouse' still has the same vertical lines on it at the install screens, which is bypassing the current operating system. Which indicates its almost 100% likley to be a hardware fault.


    However - I originally boought 2 of these iMacs.

    One was a revesion A and this one the revesion B. I sold teh rev A last year.

    I never got the original discs with the rev B (this one) but I did keep the original discs that came with the rev A whioch I bought new.


    However, when I put the 'apple hardware test' disc in and boot to it, it gives me the error "apple hardware test does not support this machiene".


    There is no answer to this on the apple website. There page on this error only states "If you are experiencing this issue, Apple Hardware Test is available on the media that came with your computer. SeeIntel-based Macs: Using Apple Hardware Test for more information."


    Only this is NOT an intel mac, and there is no resolution for this on the support website for PPC macs




    I went and downloaded the apple hardware test from the support website... it is aparently for older model iMacs.


    However when I boot into that, I get a "invalid memory access" error.... I have tested my memory and there is nothing wrong with my RAM. This seems to be a program error with the AHT you download from apple..


    Driving me nutz...see images below


  • a brody Level 9 (65,736 points)

    You can't use the installer disk from another vintage or model Mac on your Mac.  Call AppleCare for replacement installer discs if you lost them.

  • -Rotten Apple- Level 1 (45 points)

    Well it is either caps or bad solder joints. Cannot be fixed with any tests or software tricks. If it is caps, replace them, if it is solder joints, get them reflown or reballed.

Previous 1 2 Next