12 Replies Latest reply: Aug 27, 2012 3:02 PM by Riccardinho
Mike Hunter Level 1 Level 1 (0 points)

Hi

 

I think the content of this forum shows that there is clearly a problem with iPhone 4S / IOS 5.1.1 and Wi-Fi. But I have a slight variation on the theme and would appreciate any help anyone can provide, please.

 

My Setup:

 

I live in an awful house for Wi-Fi - not only is it spread-out, but it also has metal sheets laid across every floor to reflect under floor heat upwards and, of course, to kill Wi-Fi signal dead. To get decent coverage I have 1 wireless router and 3 access points all using the same SSID and password, but using different channels (separated as much as possible physically and by frequency). The four units are connected by wire (over the power lines). This setup has worked fine for several years. It still works fine for my iPhone 3G, iPad 1, iPad 3, Squeezeboxes, MacBook Air, laptop PCs etc. (I program and use this kit for testing as well as playing).

 

But...

 

The Problem:

 

The Saturday before last I bought an iPhone 4S to upgrade to (as my trusty iPhone 3G was broken (I dropped it :-( )). The iPhone 4 connects to the Wi-Fi nicely (so its not a security issue) but drops out after a few minutes and then refuses to re-connect. I am current still testing, but I believe it also drops out if I move in the house from one AP's strong area to another's. I suspect it hangs onto the weak channel and refuses to change. If I walk back to the AP that I originally connected to it re-connects.

 

I never had this problem with the iPhone 3G. I still don't (its repaired :-) ). And I am now testing by taking both phones with me as I roam about the house. Both phones are running IOS5.1.1 and the 3G works perfectly whilst the 4S drops out and throws a hissy fit.

 

The Apple Solution

 

The guys at the local Apple store are being sympathetic. So far I am onto my second phone, and I have a 'Genius' appointment in about an hour to switch to my third! Both the phones I have tried so far have behaved identically, so I am very skeptical that the third will solve the issue.

 

The good news, of course, is that after I've burnt through a couple of hundred iPhones all of which do the same thing, Apple might actually think its worth exploring the issue properly. (If you do read this Apple people I don't want to waste your iPhones/time/money any more than I do my own - I just want to be able to get to the internet on the 4S like I can on my 3G).

 

First question - does anyone know what's going on and can suggest a fix?

 

Second question - does anyone know how to tell which Wi-Fi channel your iPhone is connected to? If I could find that information I could test my theory about the roaming not working.

 

When making suggestions please remember that all my other devices work just fine, including my iPhone 3G which is physically touching the 4S that won't work. Therefore I may be a little sceptical if anyone suggests I upgrade the router (which I can't because its a Virgin one and updates automatically).

 

Thanks for any suggestions (including router upgrades).

 

Mike


iPhone 4S, iOS 5.1.1, Possibly to do with multiple APs
  • 1. Re: iphone 4S Wifi Drops and Refuses to Reconnect
    Matty12345 Level 1 Level 1 (0 points)

    ive sorta got a similiar issue

     

    well my partner does with her Iphone 4S 5.1.1 and my spare 3GS on 5.1.1

     

    Where it connects to wifi and then if phone goes to sleep or somthing along those lines it disconnectes and you have to manually retype password

     

    Have obviously reset network settings on the phone, reset security settings on router, changed router password...

     

    However wifi works ok with my 4S im on 5.0.1

     

    Thoughts?

  • 2. Re: iphone 4S Wifi Drops and Refuses to Reconnect
    Suzie Herdman Level 1 Level 1 (0 points)

    I am having the same issue on my iphone 4s on 5.1.1 and its only happened since i have updated. It used to sinc fine with my wifi through my imac but now it will connect at first but it wont let me use anything. I can see the wifi symbol but when I try to surf the net it says no connection. As I used to use my wifi connection constantly it is a major issue as now my bill will triple!

     

    I have tried all the obvious solutions and it may fix the problem for a few minutes then I will loose the connection again.

     

    I hope a solution for this will be coming soon as I have only had my iphone a couple of months and im starting to doubt my decision : (

  • 3. Re: iphone 4S Wifi Drops and Refuses to Reconnect
    tamwise72 Level 1 Level 1 (0 points)

    I too am having the very same issue. My iphone 4s was working great until the update, now it will not stay connected to wifi. My husband's 4s is working fine. I have scoured the net looking for a fix, and I've tried them all many, many times. Reset network settings, forget this network, etc. I've even restored the phone both as new and from a backup.

     

    In addition to the wifi problem, it also will not stay connected to bluetooth. I have 3 different headsets, all doing exactly the same thing. I actually tried to count how many times the bluetooth dropped yesterday. I lost count somewhere around 30.

     

    Please help! I'm pulling my hair out trying to solve this!

  • 4. Re: iphone 4S Wifi Drops and Refuses to Reconnect
    Jackie19264 Level 1 Level 1 (0 points)

    I am having the SAME problem. It is making me want an Android this is so FRUSTRATING! Here's my issue:

     

    I have an iPhone 4 with 5.1.1. It fairly recently decided to have tons of issues connecting to Wifi. The 2 places I connect to Wifi are my home and my work. At home, my phone manages to about 95% of the time find the wifi signal, but I have to go manually put in my wifi password every time I want to connect, otherwise it'll just stay on 3G. When it doesn't find the signal I have to keep refreshing it and it eventually finds it.


    At work, the wifi that EVERYONE else uses, I have the most trouble connecting to. I have to manually go into my wifi settings and find the signal. That is IF it actually finds it. About 50% of the time it just doesn't find it. Then about 40% of the time it sees it, but when I try to connect it says "Unable to join the network "SEWELL"" (that's the name of the Wifi). Then about 10% of the time I can find it and connect to it. AND then sometimes when I am finally connected it'll just kick me off in the middle of browsing and I'll go back to 3G. This happens with work and home.

     

    I have tried EVERY troubleshooting method. I reset the network settings, I soft reset the phone, I did a full restore and deleted everything and still it doesn't work. I reset it all the time trying to get it to work and it just does nothing.

     

    Any other suggestions or am I just going to have to deal with it until the Samsung Galaxy S III comes out?

     

    Do you think if I took it to an Apple store they would replace it and that might help? I know other people with iPhones (3G and 4's) and theirs work fine so I don't know how it can be the Apple 5.1.1 update?

     

    HELP APPLE!!!!

  • 5. Re: iphone 4S Wifi Drops and Refuses to Reconnect
    shaunp45 Level 1 Level 1 (0 points)

    I have the same issue.  I had my home and work wifi networks in my phone and they worked fine.  Now the little connector just spins and won't even find the networks.  I also recently updated the iOS.

  • 6. Re: iphone 4S Wifi Drops and Refuses to Reconnect
    Riccardinho Level 1 Level 1 (0 points)

    Same issue here - started a week ago. Have used iPhone together with router problem free for 2 years and nothing has changed  . Now connection drops off every 2 minutes.

  • 7. Re: iphone 4S Wifi Drops and Refuses to Reconnect
    Ktjkirk Level 1 Level 1 (0 points)

    Having the exact same problem, does make since .HELP

  • 8. Re: iphone 4S Wifi Drops and Refuses to Reconnect
    Ktjkirk Level 1 Level 1 (0 points)

    So are they suggesting hardware issues or just software?

  • 9. Re: iphone 4S Wifi Drops and Refuses to Reconnect
    Matty12345 Level 1 Level 1 (0 points)

    I ended up trying a different router and it was ok after that still weird!!!

  • 10. Re: iphone 4S Wifi Drops and Refuses to Reconnect
    Matty12345 Level 1 Level 1 (0 points)

    I had a netgear dgnd3700 and switched it with an iinet bob lite ( I'm from Australia just a no name ISP router)  wonder if it has anything to do with a particular  type of router

  • 11. Re: iphone 4S Wifi Drops and Refuses to Reconnect
    Jasper89 Level 1 Level 1 (0 points)

    I had this problem until I changed a few settings on my router. I set it to broadcast instead of hide the SSID. That helped some. Then I changed security to WPA2-PSK. That did a little better. Lastly, I changed the actual SSID name. I do not know why, but that cured me. It is flawless since them.

     

    I also found information about how most wireless routers are geared more toward Windows rather than iOS or OSX. It is too bad that I did not finr this out before I upgraded my router. The wireless N channels for both operating systems are outside of the range of my router. That is despite it being an N router. Of course Apple routers (Airport, Time Machine, etc.) do have the correct channels and are nearly automatic to connect.

  • 12. Re: iphone 4S Wifi Drops and Refuses to Reconnect
    Riccardinho Level 1 Level 1 (0 points)

    I changed my router from WPA-PSK[TKIP] + WPA2-PSK[AES] to just WPA2-PSK[AES], reset network settings on iphone, restarted both router and phone, and this seemed to do the trick.