7 Replies Latest reply: Mar 10, 2006 5:21 PM by Ronda Wilson
jwit Level 1 Level 1 (0 points)
I keep getting an error that says "your mac os x startup disk has no more space available for application memory. To avoid problems with your computer quit any application you are not using." This is now happening when I only have Safari and Mail open. Can anyone help me?

Mac OS X (10.4.5)
  • Maxit Level 4 Level 4 (3,640 points)
    We can probably help, jwit, but we need to know how large your hard drive is, how much freespace you have left on it, and how much RAM you have installed. My guess, from the message, is that you are running out of physical drive space and may not have enough RAM, so that applications are needing to access the nonexistent free drive space (virtual memory).

    Just a guess, though. Post back with more details about your set-up.

    Welcome to Discussions!
  • jwit Level 1 Level 1 (0 points)
    Capacity - 18.63, Available - 7.14, Used - 11.48

    I think the information below answer your question about RAM, but I am not totally sure
    128 MB Built-in
    512 MB SDRAM

    From what the previous owner of the computer (my boss) told me is that the memory has be upgraded as much as it can be...
  • Maxit Level 4 Level 4 (3,640 points)
    Thanks--that does help. With 7+ GB free and 640mb RAM (maximum that can be installed), one would think lack of free space wouldn't be a problem. Go to your Utilities folder and open Activity Monitor. See if there is any memory-hog application running.
  • jwit Level 1 Level 1 (0 points)
    As far as memory hogs go, here is what I found. I wasn't sure if you needed Real Memory or Virtual Memory but here is what I have as the top user of each

    kernel_task Real=45.5 virtual=637.97
    Safar Real=133.23 virtual=400.71
  • Maxit Level 4 Level 4 (3,640 points)
    Well, I'm stumped, jwit. I am wondering if there is a hidden process of some sort but I don't know how to find out. The only other thing that occurred to me is that your drive was partitioned & the bootdrive is on a partition. If you checked your hard drive capacity using Disk Utility, look at System Profiler/hardrive/ATA and check "volumes" to make sure.

    You could try starting up in "Safe Mode," which will force a directory check & disable start-up & login items among other things. It will take longer than a normal startup because of the directory check.


    Then restart normally. I'll be gone for a few days. Here's hoping another user will help you solve this.


  • jwit Level 1 Level 1 (0 points)
    Thanks for your help so far Maxit. I will try the "safe mode" reboot and see what happens.
  • Ronda Wilson Level 8 Level 8 (41,080 points)
    Once completely started up in Safe Mode, restart normally, and go to Applications/Utilities/Disk Utility. Click on the top hard drive icon in the left sidebar and note the S.M.A.R.T. status at the bottom right of the pane. What does it say?

    Select the named boot volume in the left sidebar, and repair permissions on it.