1 Reply Latest reply: May 21, 2012 8:58 PM by Niel
gshepp Level 1 Level 1 (0 points)

My MacBook is about 4 years old now- Mac OS X 10.5.8. I want to install Google Drive but it requires Mac OS X 10.6 or higher. Do i pay for a 10.6 version or do i buy a higher version and how high can i go?

MacBook, Mac OS X (10.5.8)