0 Replies Latest reply: May 24, 2012 10:28 PM by Tangentric
Tangentric Level 1 (0 points)

I'm using Mac OSX 10.6.8 on a macbook pro, copying files to a media NAS server via wifi (n), which I've done countless times before, for about 2 years.


In this last week or so, whenever I copy a file, be it 15 MB or 1.5 GB to the NAS, I've consistently been getting the error:

"The operation can’t be completed because an unexpected error occurred (error code -51)."


There's around 1 TB of free space on the NAS. Windows PCs can copy to it fine. I can still read from it fine, but copying to it is giving me a lot of trouble. I get the error message more often than not, but if I persist in trying to copy it will eventually allow me to copy whichever file I'm trying.


Size of files do no seem to be the issue.


Ive tried a suggested fix of Finder > Preferences > Sidebar > UNTICK Connected Servers ... this has not helped.


I've tried copying using PathFinder as well as Finder, both have the same issue.


I've looked into the Console messages but I'm not really sure what I'm supposed to find (bit of a mac newb for tech issues).


Could really use some help with this.. would be highly appreciative even for some good leads.


Thanks in advance!

MacBook Pro, Mac OS X (10.6.8)