0 Replies Latest reply: May 25, 2012 3:48 AM by NSong
NSong Level 1 Level 1 (0 points)

Recently, I have lost sound on my iPhone 4s unless I plug it up to some external device (such as speakers, auxillary cord to my car, headphones, etc.) It was shortly after I updated it to 5.1.1, though I'm unsure if that is the reason. From what I've read, it seems that way. Below are the "symptoms" of my iPhone's malfunction.


  • Ringtone still works when someone calls. Calls go through and speaker phone is fine. I have complete volume control then.
  • Message tones/email notifications/many app sounds/lock sounds do not sound without something in the audio jack.
  • Audio jack usually solved the problem. I was going to wait for an update by using exterior speakers and headphones, until the sound connected and disconnected randomly while connected to them. It's not detected as being disconnected for my music still plays.
  • If I leave my phone alone for awhile, sound returns but only for a short time (a minute or less) before disappearing completely.
  • Siri is working completely fine. I can hear her loud and clear.
  • If sound disappears, so does the option to change your volume on the "Now Playing" screen or the "Quick Play" on the lock screen. Also, the + and - buttons pull up the speaker icon with "ringer" over it, yet no meter below it.
  • The sound lock button above the + and - buttons is not locked, as in I do not see orange.


These are the solutions I have discovered and tried, along with any results they produced.


  • I have cleaned the audio jack and the charging slot (do not know the technical term). Returned sound for only a couple of seconds.
  • I have done a hard reset of the phone. No change.
  • I have restored my phone from a backup. Sound worked until I synced my device with my stuff. (Very unsatisfied. Stayed up all night for that.)
  • Since my memory was almost completely full, I cleared out some things I had grown tired of long ago. Freed space did nothing.


Has anyone found a solution that actually works? Is it possibly a problem with the update or is it something with my phone?

I've had this iPhone since Christmas 2011. I really hope it's not broken because I don't have the money to replace nor do I want to already.

iPhone 4S, iOS 5.1.1