3 Replies Latest reply: Nov 11, 2012 11:58 AM by andrimoll
paulfromhere Level 1 Level 1 (0 points)

iTunes is hiding my mp3 files. I imported a bunch of mp3 podcasts from my download directory and they showed up in the music subdirectory. Although they play fine as music, I wanted to move them to the podcast subdirectory. I've done this in the past successfully many times. But, this time, after I edit the "info/options" to change the type from "music" to "podcast", they disappear from the music subdirectory but do not reappear in the podcast dirctory. When I search for them in Finder, they show up in a directory within my iTunes directory: /Users/paul/Music/iTunes/iTunes Media/Podcasts/Unknown Podcast/

 

I deleted them from this directory using Finder, to start over, but now I can't even import them as music. Using cmd-o and selecting them does not even bring them into the music subdirectory. Nothing happens.

 

Any idea how to fix this.


iMac, Mac OS X (10.7.4)
  • Los Angeles Level 2 Level 2 (435 points)

    You need to change the 'Media Kind' setting.

     

    Highlight/Select the item you want to have appear in the Podcast category (thereby moving it out of the Music category) - Then select File>Get Info, or alternatively on your key board select 'Command' and the letter 'I'

     

    An info window will pop open showing details for the selected item - From the tabs at the top of this info window select 'Options.'  You'll then see 'Media Kind' (it's right under Equalizer Preset).

     

    Change the 'Media Kind' setting to Podcast.

     

    Hope this helps :-)

  • paulfromhere Level 1 Level 1 (0 points)

    Thanks, that's what I did, and now the whole library seems broken. By broken, I mean I can't add that specific mp3 into it. I think this must be a bug, and can reproduce it as follows:

     

    1. Quit iTunes.

    2. hit option key and click iTunes to start with a new library. on the popup, select Create library

    3. use default iTunes 1 name, hit save

    4. use safari to download any audio file from http://www.assemblyofbishops.org/multimedia/conversations, such as http://audio.ancientfaith.com/specials/bishopsinterviews/20_bpmatthias.mp3

    5. click the file in Finder to have it play in your new iTunes library. use pause to stop playing

    6. highlight the file in the iTunes music subdirectory and press command I to edit the info. Use the Options > Media Kind: to change from Music to Podcast. Hit OK and watch the file disappear from the music directory. Click on podcast directory and notice it is missing from there. Click on Playlists: Recently Added and it shows up there. Hit command I and verify on the Options tab that it still claims to be a podcast. Hit command Q to quit iTunes, then start iTunes. Now it is no longer in the Recently Added playlist or anywhere to be found.

    7. using Finder, browse to /Users/paul/Music/iTunes 1/iTunes Media/Podcasts/Unknown Podcast and find the missing file there.

    8. in iTunes, use command O to select the downloaded mp3 file to try to add it again. It will not add again, even as music.

    9. Using Finder, double click the file and it will play in iTunes, but once stopped, it disappears.

    10. Using Finder, remove the file from /Users/paul/Music/iTunes 1/iTunes Media/Podcasts/Unknown Podcast. Still unable to add this file into iTunes.

     

    So, is it possible to fix a library index (.itl file), or do I have to create a whole new library from scratch (probably hours of work)?

  • andrimoll Level 1 Level 1 (0 points)

    Just stumbled upon this same problem.

     

    Fortunately thought up  a quick fix: Create a new playlist and drag the files to it from the iTunes Media folder. Then you can choose Get Info on them and change their metadata, incl. the media type.

     

    Thirdly, if you still want those files in the Podcast section, make sure they have an Album set. Seems iTunes is buggy and hides items in the podcast section that lack it.