10 Replies Latest reply: Dec 19, 2013 2:53 PM by antdude
Shrinkfit Level 1 Level 1 (0 points)

For some maintenance activities I have to do a start (or re-start) holding down Command-R.  However, when I do a start (or re-start) my Apple bluetooth keyboard is acquired at the end of the bootup process.  So I can't do a 'Command-R'.  What to do?

Mac mini, Mac OS X (10.7.4), New Apple Bluetooth Keyboard
  • Linc Davis Level 10 Level 10 (164,920 points)

    It should work. Are you sure you have a recovery partition?

  • Dah•veed Level 7 Level 7 (32,495 points)
    One problem is that these boot modifiers seem not to work with Bluetooth keyboards, as many users who hold down the modifier keys immediately at startup find that the Mac boots up normally, ignoring the modifiers.  The solution is simple: wait to press the keys until you hear the startup chime, but before you see the spinning gear at boot.  This allows the Mac to load the appropriate bluetooth drivers so that it can see the keyboard, but is early enough in the boot process that the keys aren’t ignored.


    I copied this from somewhere, but I don't remember where!

  • Shrinkfit Level 1 Level 1 (0 points)



    I did check that I have a recovery partition using 'Terminal'.  It's there.

  • Shrinkfit Level 1 Level 1 (0 points)



    I found that posting too.  I tried it a few times.  I also tried the keyboard switch (hoping to acquire earlier).  For both of them ...no joy.


    Where it causes difficulty is when a new user (me) has just migrated a bunch of data over from an old PC ...but it did so in a NEW account which was password protected ...and I had no way to change that password unless I booted up with Command-R ...which doesn't work with a bluetooth keyboard.

  • Linc Davis Level 10 Level 10 (164,920 points)

    Please post the output of "diskutil list". Anonymize the volume name(s) if you wish.

  • Shrinkfit Level 1 Level 1 (0 points)

    Linc, thank you for your help.


    Here is my diskutil list:


    Jerrys-Mac-Mini:~ jdkalpin$ diskutil list


       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:      GUID_partition_scheme                        *500.1 GB   disk0

       1:                        EFI                         209.7 MB   disk0s1

       2:                  Apple_HFS Macintosh HD            499.2 GB   disk0s2

       3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

  • Linc Davis Level 10 Level 10 (164,920 points)

    That looks OK. Have you tried another keyboard, preferably a wired one?

  • Shrinkfit Level 1 Level 1 (0 points)

    Linc, not yet.


    For getting around the unwanted password ...after migration... I have a workaround for that.  I would post it for others if I knew where.


    But sooner or later I will need to use 'Command-R' and I wish I could do so with my Apple standard bluetooth keyboard.

  • Linc Davis Level 10 Level 10 (164,920 points)

    If you can't get it to work, make a "Genius" appointment at an Apple Store.

  • antdude Level 1 Level 1 (15 points)

    On my Mac Mini, with updated 10.7.5, I had the same problem. After reading this forum thread, it mentioned the Bluetooth keyboard light going out. I had to keep turning on the keyboard while holding down command+R keys and then it worked.