2 Replies Latest reply: May 27, 2012 11:30 AM by Soroush96
Soroush96 Level 1 Level 1 (0 points)

I was working on a project in xcode that an error poped saying it can't save the file, after that mac os just hanged, so I restarted it, but it couldn't get pass the apple logo, so I booted the recovery partition and tried the disk utility and it said there was a problem with the startup partition, so I tried the repair volume, but it didn't work, saying there was a write problem, so I tried to reformat it and then restore it to time machine backup, but it didn't work, so I removed the hard from my laptop and used a sata to usb enclosure and insert it to another mac and I formated the hard and reinstalled mac on it. when the hard is connected to usb I can boot from it and use it, but when I put it in the macbook it just can't boot from it. I figure there's a write problem with the serial-ATA. I live in a country, that doesn't have an apple store, so I want to fix this myself if I can, so please if anybody knows how to fix this please help.


MacBook Pro (13-inch Mid 2009), Mac OS X (10.7.4)