14 Replies Latest reply: Jul 8, 2012 2:54 PM by luba petrusha
Genalinda Level 1 Level 1 (0 points)

Hello,

I’m having problems with my iPhoto. I used to have the iLife of ’09 (which I believe is version 8.0). I recently updated my macbook pro from 10.6.8 to 10.7.2 then through Software Update I updated my mac to 10.7.4. I’m not sure if the update effected my iPhoto or not because I never checked it. I then updated my iLife to that of '11. My GarageBand and iMovie worked fine but every time I clicked on iPhoto it wouldn’t open. Instead I would get a little textbox saying:

 

“In order to open iPhoto, you need to update to the latest version.

Please run Software Update to install it now.”

 

I couldn’t even view iPhoto’s settings or anything. I knew that iPhoto had updated only because I would go to Applications then click on iPhoto’s Get info, which would tell me that I have the 9.0 version (iLife of ’11). So I proceeded to update my iPhoto through Software Update but just as it neared completion the update would stop and I would get a textbox saying:

 

“The update “iPhoto Update” can’t be installed. The update could not be expanded and may have been corrupted during downloading.  The update will be downloaded and checked again the next time that software Update runs”

 

I have tried everything I have read on iLife Troubleshooting Basics (even though it only fixes iLife '08 and '09 because I can't seem to find fixes for '11) http://support.apple.com/kb/TS3249


Any help is greatly appreciated.


iPhoto '11, Mac OS X (10.7.4)