Previous 1 2 3 4 Next 44 Replies Latest reply: Jun 5, 2012 3:46 PM by MrHoffman
MacSter2008 Level 1 Level 1 (0 points)

Help,,

Snow Leopard server continues to claim "invalid Serial number"

due to bridged ethernet.  (It is valid when I unbridge..invalid when I bridge,)

 

Apple claimed to fix this bug here

http://support.apple.com/kb/TS2959

But has not.

 

I need bridged ethernet for multiple servers within virtualbox.

 

Any ideas?


Mac Pro, Mac OS X (10.6.8), Snowleopard Server! Avoiding Lion!
  • capaho Level 4 Level 4 (3,650 points)

    Make sure your bridged network is configured properly.  You could have a DNS or security configuration problem that is preventing your server from reaching Apple's validation server.

  • MacSter2008 Level 1 Level 1 (0 points)

    Thank you for the fast reply.

    It is a fresh install of Snowleopard server 10.6 followed immediatly by all software updates to 10.6.8

    Nothing has been added.

    It lives on a Mac Pro within a virtualbox virtual machine.

    Without Ethernet bridging the IP address is 10.0.2.2 by default.. with valid serial number.

    With Ethernet bridging the IP address is more functional for networking as 192.168.1.113

    However then the serial number is reported as "invalid serial number.  Duplicate detected"

     

    The duplicate is the real, non-virtual Mac hosting the virtual mac with the same 10.6.8 Snowlep Server and serial number.  As an unlimited Licence this should not be a problem.

     

    Apple claimed to have solved this in 2009 in the link above.

    There are only 4 or 5 different options with virtualbox to add with network bridging, and I have tested them all.

    There is no DNS issue either, or any security problems.

    You think something is preventing is from reaching Apple's Validation server?

    Interesting idea.

     

    I assumed it was the exact same issue Apple had in 2009 due to the part about "duplicate detected".

    If 10.0.2.2 worked I would assume it isnt preventing the software from reaching Apple's Validation server.

    both with and without bridging allows me to go online with Safari.

    But I cannot host a web server or quicktime stream with 10.0.2.2, so I am forced to bridge.

    Only problem is that Briding invalidates the serial number and that disables all server services in the GUI.

     

    I will see if it could be something somehow blocking Apple's validation server as you suggest.

  • capaho Level 4 Level 4 (3,650 points)

    The "duplicate detected" error would suggest that it is seeing both the VM and the actual server as having the same serial number.  That might indicate either a problem with the VM configuration or an incompatibility between Virtual Box and Snow Leopard Server, or possibly that both the VM and the server have the same local IP address, which would be problematic.  You might want to check the Virtual Box forums and see if others have the same issue

     

    You might also try is setting static IP addresses in the router for the server MAC address and the VM MAC address to make sure that they are not being assigned the same DHCP IP address.

  • MrHoffman Level 6 Level 6 (13,175 points)

    You'll want to figure out why you have both 10.0.2.2 and 192.168.1.113 addresses here for the same host (and particularly where the host doesn't know about the second and separate subnet as "itself"); that's incorrect, and that's the likely trigger.    I'm guessing there's NAT here, and NAT gets ugly in general.

     

    This isn't so much a problem with Apple's serial number licensing, it's with the disparate addressing configuration combined with a NAT "device" that's also passing Ethernet multicasts.   Taken together, you're seeing exactly what is expected with that.  The OS X Server licensing is doing exactly what it should be doing.

     

    What's happening is that the network configuration error here means that OS X Server is detecting itself via a typical Ethernet multicast, and with a different NAT'd address that it doesn't recognize as its own; as being itself, via a NAT.   Other stuff that uses Ethernet multicasts, too, so protocols including Bonjour will likely be cranky within this configuration, too.  DNS, as was mentioned earlier, must also be configured for this; if you have a host with its own self-IP and visibility to a NAT'd IP visible, then DNS will get cranky.  Security, too, will get cranky when DNS is cranky.  And Open Directory, being based on DNS and IP and security, will very likely get confounded, too.

     

    You can either block the Ethernet multicasts from crossing at the NAT device (which is what a NAT firewall does), or can switch to a routed network configuration and get rid of NAT (which is what a router and IP subnet routing does).

     

    And irrespective of the rest of the discussion around licensing and multicasts, having anything in 192.168.1.0/24 is a bit messy, if you're planning on getting VPNs involved.  Using another subnet (in this case) within the 10.0.0.0/8 block would be a better choice, rather than 192.168.0.0/24 or 192.168.1.0/24 subnets.

  • MacSter2008 Level 1 Level 1 (0 points)

    @Capaho,

    The problem is not an incompatability between virtual box and Snow Leopard Server.  As that is the ONLY Mac OS that VIrtual Box supports.

     

    It also is not that they are both sharing the same IP, as the server IP is 192.168.1.104 and the Virtual Server is 192.168.1.113

     

    I will see if I can manually assign IPs as you suggest.

    I have also asked the virtual box forums as you suggest.

     

    I will report back the answer here if I get a solution.

     

    @MrHoffman

    I do not have both 10.0.2.2 and 192.168.1.113 at the same time.  Only 10.0.2.2 without bridging, and 192.etc if I switch to bridging.

    The default was a Nat setup, and with Nat (no bridging) I get the 10.0.2.2 address.


    How is it doing "exactly what it should be doing.." with an unlimited client serial number, it should be acceptable to have multiple servers with the same serial number.  I cannot see how this is not Apples error, espeshally when Apple reported this as a flaw but said they fixed it in an update.

     

    There is also the chance that I misunderstand what you are saying and you could be onto something with NAT being... a messy problem.  Is there a way to clean up NAT so that a NAT given address as 10.0.2.2 can work somehow?

     

    (I have a linksys that only works with 192.168.1.____ IPs)

     

    If using 10.0.0.0 addresses is ideal...

    How might I pull that off on a Linksys router that acceps only 192.168.1.___ for port forwarding?

  • capaho Level 4 Level 4 (3,650 points)

    Where is the bridge in your network?  Do you have a router ahead of the server in bridge mode with the server doing the local routing?  Are the server DNS settings configured correctly?  Are the server and the VM on the same subnet?

     

    By the way, "unlimited client serial number," means that the server can have unlimited clients (as opposed to 10 or 100 or unlimited the way Plesk is licensed), but it doesn't mean that you can have unlimited servers with the same license number.  If you have another installation of OS X server running in the VM with the same license number, that could be the source of the trouble.

  • capaho Level 4 Level 4 (3,650 points)

    As a further follow-up, the techinical document you referenced in your opening post refers to a problem that occurs with OS X server running with multiple network interfaces, but it is not likely relevant in cases where multiple servers are running in a VM, if that's what you are trying to accomplish.

  • MacSter2008 Level 1 Level 1 (0 points)

    I have a DSL box plugged into the wall.. and plugged into a Linksys.. which plugs into the Mac Pro.. which works perfect.

    The Mac Pro is a live web server.. all working great.

    The Mac Pro is also hosting the virtualbox and now has another server living within it.

    So there is only a "virtual" bridge between the real mac and the virtual mac within the real mac.

     

    DNS must be configured correctly for the real computer and any others on the linksys

    The Server and VM are on the same machine... If I give them the same subnext mask the VM does not connect to the internet.

     

    I didnt realize what you are saying about unlimited Client... perhaps then that is my problem.  It can see both servers and has a problem with that.

     

    Yes I am trying to run multiple VM servers... well just one within a real one for starters.

  • capaho Level 4 Level 4 (3,650 points)

    I would say that if the multiple servers are all using the same license key, then that is where your problem lies.  Unlimited clients means that a server can host services for unlimited clients, but it doesn't mean you can run multiple servers from the same key.

  • MacSter2008 Level 1 Level 1 (0 points)

    Perhaps the Multiple Servers using the same license key is the problem.

    However according to Apple I am indeed allowed to use multiple servers from the same key.

    SnowLeopard Server is the ONLY Mac OS allowed by Virtual Box because the terms of service allow for multiple servers.  Leopard, Snow Leopard and Lion all do not allow for multiples under the same key so Virtual Box blocked those to avoid law suit from Apple.

    The link http://support.apple.com/kb/TS2959 was referenced in a virtualbox artilce talking about

    "third-party virtualization software" and  "bonded Ethernet" the same issues I am having.

    While it does not say 3rd party virtualization of the same software with the same key, that is exactly the one and only legal use VirtualBox offers for Mac users.  All other Mac OSes are blocked.

    You could buy multiple serial keys I suppose but I realize that if I have unbonded Ethernet by way of NAT...

    everything is online.. and I have no errors.  I know each server can dial home to the mothership.. and neither says anything about duplicates.

    Oh the other hand.. the fact that they programmed an error message with the word "duplicate" in it suggests that everything I have read and repeated is wrong and you are right.

    I will run some more tests.

  • capaho Level 4 Level 4 (3,650 points)

    MacSter2008 wrote:

     

    Perhaps the Multiple Servers using the same license key is the problem.

    However according to Apple I am indeed allowed to use multiple servers from the same key.

     

    The article you have referred to deals with running OS X server on a machine with multiple network interfaces, as on a Mac Pro with two Ethernet NICS.  That is an entirely different issue than actually running multiple servers. 

     

    I suspect the duplicate key error message is a result of the validation server detecting multiple servers online using the same key.  You may need to contact Apple support on this and have them confirm whether or not you can run multiple servers in a VM using the same license key.  You may need a special license key apart from the one that came with the server software to do what you are attempting.

  • MacSter2008 Level 1 Level 1 (0 points)

    I will ask them tomorrow.

    Thanks

  • MrHoffman Level 6 Level 6 (13,175 points)

    You really do have more than one server, and whether OS X Server is running as a guest or as a base system?

     

    If so, you need a different license key for each. 

     

    I'm not aware of any commercially-licensed (and virtual-capable) server operating system that allows "free guests", for that matter.  This isn't particularly unique.

     

    -- other comments --

     

    Unrelated to the OS X Server licensing, and from this statement: "DNS must be configured correctly for the real computer and any others on the linksys...", you can then switch that phrasing from "must be" to "is" by launching Terminal.app and issue the following non-destructive command:

     

    sudo changeip -checkhostname

     

    That will indicate that DNS is correct and valid and no changes are required, or that there are errors and changes are required.  Invalid DNS configurations are surprisingly common, in my experience.

     

    Whether or not your Linksys allows only 192.168.1.0/24 is irrelevent to whether VPNs will operate here or not; if both ends of the VPN are in 192.168.1.0/24, then IP routing will not work, and the VPN will not be established.  As a potential option, re-flash that Linksys with DD-WRT or other such software, if your particular model allows that.  Or get an old PC with two NICs, and load and configure it with one of the various open-source firewall packages around.  Or get a server-grade (commercial) firewall.

  • capaho Level 4 Level 4 (3,650 points)

    MrHoffman wrote:

     

    You really do have more than one server, and whether OS X Server is running as a guest or as a base system?

     

    The OP appears to be confused over the issue of running a single server with multiple NICs and running multiple servers.  These issues are not related. 

     

    If he's running SLS in a VM within the original installation then he is running more than one server, thus the duplicate license error.  It is extremely unlikely that Apple allows multiple installations of its OS to be run on the same license key, and therein lies the problem.  He needs what would essentially be considered an enterprise license, and I don't know if Apple provides such a license.  I doubt that the OP's problem is a DNS issue based on the information he has provided.

Previous 1 2 3 4 Next