5 Replies Latest reply: May 28, 2012 5:09 PM by cma2006
cma2006 Level 1 Level 1 (0 points)

my comp is tellin me that my iphone can sync with itunes becuase i need itunes 10.5 or later . plz help


iPod touch