Previous 1 2 3 Next 41 Replies Latest reply: Nov 17, 2012 11:12 AM by joeyjohnson Go to original post
  • steve626 Level 4 Level 4 (1,480 points)

    Your symptoms, as others have noted, are disturbing. The partition map is what the operating system uses to find files (and pieces of files -- files are not stored contiguously on the disk). Not sure why one type of Disk Utility run finds nothing wrong and the other finds something wrong, but that's indicative of something wrong. By the way, are you using File Vault? (If so, that complicates all this to some degree.)


    I have read that running disk repair/verify from an externally booted disk or from the recovery disk is more reliable than running disk utility "in place" while booted from the disk in question. However in conjunction with your other problematic symptoms, clearly something is wrong.


    I also noted earlier that this is an ebay-purchased computer. Don't take this the wrong way, but often ebay is where people unload things that aren't working right for them. I wonder if the previous owner encountered the same issues and decided simply to sell the machine so someone else could try to deal with them ... (like you)


    Given that it is from ebay, have you checked the hardware of this Mac with the Hardware Test program that is on the recovery disk? That could be a source of the problems, hopefully not.


    I think your best bet is to make two backups (that's for redundancy) of your user folder contents. Try to make sure you can find and browse those files from the backups. Then I would obtain Disk Warrior and run it to try to fix any problems. Disk Warrior will find and fix things that Apple utilities cannot. If that works, you might be ready to go. If Disk Warrior says things are fine, that would then point to either hardware problems inside the Mac, or a damaged system installation. For the latter, you could try the latest combo update reapplying it, or a fresh installation of the OS. If that doesn't cure what you have, I'd completely reformat the disk and reinstall a fresh operating system and software that you have, and then restore your user folder from your backup(s).


    If you have file vault turned on, I'd turn if off for now until everything is working right again.


    One last thing -- when you go to Apple for test/diagnosis, they often will end up doing a complete reformat of the disk, so it's extra important to backup your files as best you can. If the partition map is broken, you may have trouble finding and backing up all your files, but I'm not totally convinced that your partitiion map is broken, you have contradictory indications.


    I think your iPhoto issues have to wait until you get a reliable system running. The iPhoto and Safari programs might be damaged, for instance, it's hard to say. Your photos are physically there, they are not lost, but the iPhoto database may be having trouble finding them. They can be re-imported into a new iPhoto Library but don't do that until your system is stable. You can see the actual photo files by right clicking on the iPhoto Library to Show Package Contents, and then you'll see some folders, the one called "Originals" has your original photo files, other folders will have changed or modified photo files. They are all there, but the database may be damaged and thus unable to locate the photo files. That can be fixed in a variety of ways, but not worth doing until yur system is fixed.

  • joeyjohnson Level 1 Level 1 (0 points)

    Steve, that was so generous of you to respond in so much detail, thanks very much.
    To answer a few of your points/questions......


    Filevault - yes I am running this.


    Ebay - yes I appreciate your point and yes of course there is always this risk, but the man I dealt with seemed extremely genuine and I went to great lengths to feel sure of that before buying. He specialises in Mac sales and was a stand up type, unlike many on Ebay. Of course that is no guarantee, but gut feeling counts for a lot for me. In addition, before purchase I checked with Apple that it is fully covered by the warranty and they confirmed it was, so whilst you could still be right that he was ditching a problem machine, I am comfortable that the machine should be supported if there is a bad hardware issue like a dodgy HD or similar.


    Hardware Test on recov disk - never heard of this?! How do I do this, and are there any particular things I should know before running it, assuming I have it! Will look shortly.



    (Side Comment - not sure if i have mentioned it before, but if i restart and hold down Option key (as some website advises) I do NOT get the boot choice prompt, it just boots up as normal. When i tried with CMD-R it did boot into recovery disk, but again just another small and strange anomoly with the machine. )


    Disk Warrior - Unfortunately I just can't afford to spend the $100 on this. At least not without knowing it will almost certainly fix my problems and let me get back to working again properly. I am just extremely broke at the mo

    (I MAY be able to borrow it off a friend if DW has a very good chance of curing my problems.)


    Further to above, before spending money like that, maybe I should list a bit more about my problems of the past in case I have not mentioned.


    I have reinstalled a fresh copy of Lion on this machine 2 or 3 times now (i forget). It has been troublesome from the start, BUT i did not think it was the machine, as my old 2008 iMac was suffering some very buggy problems too, and a friend of mine (many years experience of macs) suspected the problem lies in my data, user account data, somewhere along the line, and that I "brought" the problem over with the migration from old machine to new one. However, the last 1 or 2 times that I reloaded this 2011 iMac, I did NOT use Migration assistant, in order to avoid my friend's suggestion of bring bad data or problems over, I did it all MANUALLY. So I cloned this machines drive to external HD, reformatted internal 1TB drive, used flash disk with recovery and OSX installation file on it (made that when first got machine) and reloaded OSX from scratch. I then ran all updates until it was tip top up to date.  I then installed iWork and iLife (latest versions). And only THEN did i pull mail and settings across, but I did so manually by dragging plists, iP library, bookmarks, and loads of other stuff, including (perhaps importantly) my VMware virtual machine windowsxp.iso from clone drive. I tried to do everything as manually as possible, but I did drag and drop mailbox folders which installed my mail accounts, mail and prefs etc for example in Mail. I did this for each app.


    I then continued to get problems, just a few i can recall…


    Desktop BG pics disappear at random and put DT BG background back to the black hole Mac default pic. I use 2 ext monitors with this machine (extended desktop).


    Very slow at times. Beachball when you least expect it, and have to wait 5-10 minutes to recover, or sometimes i got impatient and used force quit and rebooted.


    Various other weird little things, Skype contacts disappearing for no reason, one or two emails disappearing from inbox without warning!


    TimeMachine Oddness! - I set up my shiny new 1.5TB Tosh drive as a dedicated time machine backup drive several months ago. The other day I entered time machine to see how far back it went, and it only went back 10 days?! WORRYING!!


    Generally very low performance compared to what I was expecting, definitely no faster than my old iMac 2008. whereas this machine should blow it away when comparing performance, we are talking about 6 times the RAM in here and a way more powerful processor?!


    Finder windows taking ages to draw contents, apps taking a while to shut down or open, etc etc etc.

    very unsettling stuff in general.


    So… I repeated tne steps above 1 or 2 more times, i.e. cloned drive, wiped (format), reinstall from recovery flash disk, pull in data by hand. same problems resume. The second time I did this, I created a new USER ACCOUNT which my mac addict friend said was essential to rule out the problem being within the user account from old machine migration.




    Back to your post…….


    "You could try the latest combo update" - what is this?


    "If that doesn't cure what you have, I'd completely reformat the disk and reinstall a fresh operating system and software that you have, and then restore your user folder from your backup(s)." - Done this before as described, but just out of interest, when you say "restore your user folder" do you mean literally just drag and drop from a clone, the user home folder?


    iPhoto - i already did a manual reimport of all my photos to a new library and so far so good. I have it all backed up elsewhere though as machine is far from stable now. I have a TimeMachine backup (not great as already mentioned) plus a clone in the firesafe. I have a lot of data so I am fairly anal about backing up, but until I get a stable and reliable system, i don't feel comfortable no matter how many I have as I just don't trust the data integrity and I am not tech enough to really feel sure of anything any more as I don't understand the underlying foundations of Mac.



    Thanks again for all your help. Maybe the above will give a better idea or indications of what might be the problem.

  • joeyjohnson Level 1 Level 1 (0 points)

    Further to last, since typing that I looked for anything like a Hardware Test in Recovery Partition (booted into it) and couldn't find any such thing. I clicked on the top menu and it said "Services>" but when I expanded that menu is said "building" greyed out and didn't show any options for services, whatever they are. (just mention in case thats a problem, I have never tried clicking on that before.


    I then booted back up as normal and tried to repair permissions and repair disk again. Permission repair found a problem which I attach a pic of....


    Screen Shot 2012-06-04 at 15.53.41.png

  • joeyjohnson Level 1 Level 1 (0 points)

    Finally I tried to repair disk on the top level volume (i never really understood which one to run repairs on!) but the result I thought worthy of a screenshot........


    Screen Shot 2012-06-04 at 15.54.31.png

  • joeyjohnson Level 1 Level 1 (0 points)

    So I think I have a few options available to me and I would be really grateful for votes from anyone reading as to what steps, and maybe in what order, i should take next......


    Buy DW and let it try to repair the disk


    Clone, Reformat and reinstall OSX, then Migrate Assistant to bring data and settings back


    Clone, Reformat and reinstall OSX, then MANUALLY move data and settings back from clone


    Ring Apple Support or Visit Apple store with my machine (I don't know what they can do but would hope they can verify hardware is all good or not)


    Thanks to all who have helped

  • joeyjohnson Level 1 Level 1 (0 points)

    Well another new error has just arrived.

    I have about 4 or 5 apps running, very light use at the moment while I decide what to do. I have iTunes open playing random tracks, and an error has just popped up which I have pictured below. I OK the message but it pops back immediately every time. Screen Shot 2012-06-04 at 16.28.56.png

  • steve626 Level 4 Level 4 (1,480 points)

    Sounds like there are many other bits of information that you just provided that may also be relevant! Very hard to try to disgnose this remotely like this. However, here are some suggestions:


    Apple Hardware Test. Please see this Apple article:  it tells how to run the Apple Hardware Tests. I think it requires booting while holding down the D key, but see the article for instructions, especially the part about Lion OS computers. My computers are running 10.6 so I don't have direct experience with this new Lion verison of the Hardware Test.

    I think you should run this test because (1) of the disk error you consistently got from Disk Utility and (2) something like a bad memory chip or other hardware issue could easily explain all your symptoms. I'd run the extended hardware tests, especially for memory. It can take hours.


    When you reformatted your disk, did you do it writing zeros throughout (might take many hours on a 1 TB drive) in order to identify and map out any bad blocks? (Grasping here, but a bad block or two could cause odd symptoms.)


    Holding down Option when booting might not provide you with the choice of boot disks because of having File Vault turned on. File Vault can be prone to file or disk corruption, more so than computers not using File Vault. I'd turn off File Vault for now (and maybe forever).


    Have you tried booting into Safe Mode and then trying to use your computer (some things won't be enabled in Safe Mode) to see if the various symptoms go away? If they do go away, that might point to a problematic extension that you have installed. Even an odd or corrupted font, for instance. 


    Keep in mind that your painstakingly careful migrations by hand may have inadvertently brought over a problematic extension or preference file from an old corrupted system, which then could have corrupted your newly installed system.


    Have you created a new user and seen if the new, "blank" user encounters the problems you saw with Safari, iTunes, etc.? Again, if you have a damagedd disk or memory chip, all users would see these things, even in safe mode.


    As for Time Machine, your system logs (you can view them in Console) show what happened with Time Machine. Have you tried just manually starting a new Time Machine backup and seeing how it goes?


    Disk Warrior can fix partition map problems that Apple Disk Utility cannot fix. I have seen this in person so I know it is true. If you can't afford to get it, then I guess that's that, but it might be the only way to resolve your issue (although it's hard to tell exactly what your issue[s] is/are right now).


    I think reading stories like this is why I avoid ebay for relatively new computers. Why would someone sell a good, working, relatively new and up to date computer on ebay? It's good that you have the warranty still, but you still have to deal with the situation, which is a big hassle generally. If you can't afford tools like Disk Warrior, I'd take it in to the Apple people to examine and test (back up your files first).

  • steve626 Level 4 Level 4 (1,480 points)

    A few more things:


    Your permissions repair item looks innocuous to me.


    You mentioned earlier that you upgraded the RAM to 12 GB. Did you do this yourself? Where did the RAM come from? Are you mixing different types or sizes of RAM? Any details on how that went? Faulty or mismatched RAM (just one stick even) could easily cause all your symptoms. Maybe that's not the issue, but did you have these symptoms before the RAM upgrade?


    Another question: how did you reinstall the operating system when you did that?


    All your issues could stem from one cause. On the other hand, I am worried you have more than one issue, e.g. RAM problem plus hard disk problem plus ... Makes it harder to resolve.

  • BDAqua Level 10 Level 10 (121,175 points)

      permErr                       = -54,  /*permissions error (on file open)*/

  • joeyjohnson Level 1 Level 1 (0 points)

    BD - sorry, not sure if your message got cut off there?




    Apple Hardware Test - Thanks very much for this. I didn't think there would be a way to run a full hardware test without going to Apple store which is a real pain for me. Will run that (full extended test) and report back if it tells me I have a lemon for a HD


    Reformat zeros? - No, I don't think so. I just did a partition I think. To be honest I can't completely remember now, I get so confused as I have had problems for over a year now and have done so many refreshes, installs, formats etc when I include my last 6 months with old iMac. Pretty sure I didn't do the zeros thing, assuming I did reformat at all.


    Filevault - Hmm, never knew this can cause problems. I do take data security quite seriously and my friend suggested I use it since it is there. Will turn it off for now at least and see if anything changes.


    Safemode - haven't tried this yet no. You also mention a fresh user account. My friend has suggested this to me and I "sort of" tried it, in fact I tried again today but gave up after a few minutes. The problem I have is that any new user account has nothing installed, its like a new mac. My emails aren't in there, bookmarks etc. So I can't see how I can give it a real test without loading up all my data and apps, but being so short of time, if I could make the time for that, I feel like just wiping the effing thing and installing OSX again! Which leads me to a big question…. Can i set up a new user account and use migration assistant to bring data from TimeMachine backup into the new account so I can at least work the machine properly in that new user account and see if the problems go away?



    TimeMachine - system logs - to be honest I would not have a clue what to look for and there is no way to know when something went wrong, i just set up ™ and left it to do its business, only noticing recently that it only had 10 days of backups on it when it had been set up and backing up for months.


    DiskWarrior - if its that good, I may do my best to find a way to get it, obviously once other things done first, such as hardware tests and possibly a fresh install of OS



    RAM - yes i did this myself. I got the RAM from Crucial, exact proper spec and brand new, and fitted according to Apple instructions (easy even for me!)

    And yes, this machine didn't seem to be running very well once i installed all my apps and data. I thought it must be a RAM issue since installing VMware Fusion and Windows in a VM on here, so went and upgraded the RAM after noticing speed issues and reliability problems.


    How did I reinstall OS - from a flash drive with the OSX Lion installer on it, using recovery partition I think too, but avoiding the long download wait thanks to having an installer file saved from the time before when i let it download into recovery partition


    Finally, I have an IDEA - I still have my old iMac 24". It is nowhere near as powerful, but my wife uses it currently just for mail and ebaying etc. (HA HA HA HA, my spell checker just corrected "ebaying" to "Obeying" - ha ha ha that tickled me, it must be a Victorian spell checker, there is no obedience round here except for my jack russel :D) - sorry back to the point…. I could clone my old iMac internal (still running leopard) to a spare external drive, so her machine is backed up, then I could clone THIS machine's internal to external and then onto the internal of the old iMac, then just use that (slowly and patiently!) while I take this one to Apple. It might be a good test, surely if the problem here is hardware, the disk repair errors wouldn't happen if i do it on old machine). Might try that. Will wait in case someone shouts "NOOOO" first!



    Thanks again

  • joeyjohnson Level 1 Level 1 (0 points)

    Well... I did all I could to run apple hardware test, to no avail. I follow instructions in that article to a T, but if hold D down when booting nothing at all happens, it just takes a bit longer to reach login screen. Tried several times including with my recovery flash drve plugged in before giving up. I also booted with CMD-R to get into recovery mode, and had a good look around there, but no hardware test options anywhere.


    How very strange; after failing to find AHT, I turned off Filevault last night before going to bed as it said it woiuld take 6-8 hours to do it.

    Came back to desk this morning and it had completed. I then ran Repair Disk again from Disk Utility and it worked fine this time, no errors at all and says partition map is fine. I took a screenshot, and it shows the error last time i tried above this mornings successful repair.


    This machine was slow and troublesome before I began using Filevault so i dont think that is the cause of my problems but could certainly have been making them worse.


    Screen Shot 2012-06-05 at 10.52.33.png

  • joeyjohnson Level 1 Level 1 (0 points)

    Well this machine is no better. Apple replace the motherboard and hard drive, then said there is nothing more they can do, despite it still being under warranty?!

    It has just crashed again. Working away and bang, black screen and powered down all by itself. It did a report when it came back up (THANKFULLY it did come back up this tijme, usually i have to restore from TM about every 1-2 weeks when it does this). I have pasted the message below, and really hope someone with more brains than me can spot some idea of what the heck is wrong with this lemon


    Thanks to all of you who have tried to help. Not a fan of Apple any more, which is saying something for me.


    Interval Since Last Panic Report:  1895763 sec

    Panics Since Last Report:          1

    Anonymous UUID:                    11018C3C-B78D-02D1-2A8E-B6979B1BD484


    Sat Nov 17 18:33:40 2012

    panic(cpu 3 caller 0xffffff7f8c845eb8): "sfree on invalid allocation at 0x106ee"@/SourceCache/Sandbox/Sandbox-220/src/kext/smalloc.c:216

    Backtrace (CPU 3), Frame : Return Address

    0xffffff816cde3570 : 0xffffff800c21d626

    0xffffff816cde35e0 : 0xffffff7f8c845eb8

    0xffffff816cde3610 : 0xffffff7f8c83baa6

    0xffffff816cde3640 : 0xffffff7f8c83bb4e

    0xffffff816cde3660 : 0xffffff7f8c846401

    0xffffff816cde3680 : 0xffffff7f8c84071d

    0xffffff816cde36a0 : 0xffffff7f8c84053f

    0xffffff816cde36e0 : 0xffffff800c6840f1

    0xffffff816cde3710 : 0xffffff800c6841f2

    0xffffff816cde3730 : 0xffffff800c5465f6

    0xffffff816cde3760 : 0xffffff800c544f6d

    0xffffff816cde3780 : 0xffffff800c2e076c

    0xffffff816cde37d0 : 0xffffff800c2f4f7c

    0xffffff816cde3b30 : 0xffffff800c540d3a

    0xffffff816cde3b90 : 0xffffff800c2f54cb

    0xffffff816cde3be0 : 0xffffff800c309cb0

    0xffffff816cde3c20 : 0xffffff800c305a90

    0xffffff816cde3da0 : 0xffffff800c2fe40c

    0xffffff816cde3f60 : 0xffffff800c5e1533

    0xffffff816cde3fb0 : 0xffffff800c2cea1d

          Kernel Extensions in backtrace:

   [327C619E-5CC2-311F-8B0C-F9D508BFD5B0]@0xffffff 7f8c83b000->0xffffff7f8c83efff

   [BFFEC437-6820-3CDD-882F-346EAC151352]@0xfffff f7f8c83f000->0xffffff7f8c84ffff

                dependency:[327C619E-5CC2-311F-8B0C-F9D508BFD5B0]@0xffff ff7f8c83b000


    BSD process name corresponding to current thread: GoogleSoftwareUp


    Mac OS version:



    Kernel version:

    Darwin Kernel Version 12.2.0: Sat Aug 25 00:48:52 PDT 2012; root:xnu-2050.18.24~1/RELEASE_X86_64

    Kernel UUID: 69A5853F-375A-3EF4-9247-478FD0247333

    Kernel slide:     0x000000000c000000

    Kernel text base: 0xffffff800c200000

    System model name: iMac12,2 (Mac-942B59F58194171B)


    System uptime in nanoseconds: 84614378472626

    last loaded kext at 67227206936607:          4.1.22 (addr 0xffffff7f8e5b0000, size 16384)

    last unloaded kext at 67330357975549:          4.1.22 (addr 0xffffff7f8e5b0000, size 12288)

    loaded kexts:

    com.parallels.kext.prl_vnic          7.0 15107.796624

    com.parallels.kext.prl_netbridge          7.0 15107.796624

    com.parallels.kext.prl_hid_hook          7.0 15107.796624

    com.parallels.kext.prl_hypervisor          7.0 15107.796624

    net.telestream.driver.TelestreamAudio          1.0.5

    com.parallels.kext.prl_usb_connect          7.0 15107.796624

    at.obdev.nke.LittleSnitch          2.5.3          1.8          1.8          1.9.5d0          75.15          1.60          100.12.69          122          2.3.1f2          1.0.0d1          4.0.9f33          2.3.1f2          3.5.10          4.0.9f33          3.0          7.0.0          8.0.0          3.2.11          1.0.0          1.6.0          170.2.3          1.0.33          8.0.0          8.0.0          2.0.2d0          1.0.0          1.0.0          3.5.1          3.1.0          404          1.0.0d1          1.0.0d1          34          2.2.2          5.2.5          3.2.5b3          600.70.23          4.9.6          2.4.1          5.4.0          1.6.1          1.6          1.5          1.7          1.9          1.6          1.6          196.0.0          4.0.39          2          196.0.0          1.8          4.0.9f33          235.28          2.3.1f2          1.8.9fc10          1.6          86.0.3          10.0.6          4.0.9f33          4.0.9f33          1.0          2.2.5          1.1.8          1.1.8          1.0.0          1.0.10d0          2.3.1f2          2.3.1f2          3.2.11          1.0.4          1.0.10d0          3.1.4d2          19.0.26          2.3.5          8.0.0          8.0.0          2.3.5          5.2.0d16          165.5          165.5          1.8.5          1.8.5          1.8.5          1.2.5          5.2.5          3.5.1          1.7          1.7.1          1.7.1          2.5.0          3.5.1          3.5.0          3.5.1          5.2.5          5.2.5          1.6.0          2.1.1          5.2.5          1.0.2b1          500.15          3.0          4.5.5          2.2.1          5.4.0          1.6.1          1.8.0          1.1          220          1.0.0d1          7          344          1.8          28.21          1.6          2.7.2          1.4          1.0

    Model: iMac12,2, BootROM IM121.0047.B1E, 4 processors, Intel Core i5, 3.1 GHz, 12 GB, SMC 1.72f2

    Graphics: AMD Radeon HD 6970M, AMD Radeon HD 6970M, PCIe, 1024 MB

    Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1333 MHz, 0x859B, 0x435435313236344243313333392E4D313646

    Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1333 MHz, 0x859B, 0x435435313236344243313333392E4D313646

    Memory Module: BANK 0/DIMM1, 2 GB, DDR3, 1333 MHz, 0x02FE, 0x45424A3231554538424655302D444A2D4620

    Memory Module: BANK 1/DIMM1, 2 GB, DDR3, 1333 MHz, 0x02FE, 0x45424A3231554538424655302D444A2D4620

    AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x9A), Atheros 9380:

    Bluetooth: Version 4.0.9f33 10885, 2 service, 18 devices, 1 incoming serial ports

    Network Service: Wi-Fi, AirPort, en1

    Serial ATA Device: ST31000528AS, 1 TB

    Serial ATA Device: OPTIARC DVD RW AD-5690H

    USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x850b, 0xfa200000 / 3

    USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfa100000 / 2

    USB Device: USB2.0 Hub, 0x05e3  (Genesys Logic, Inc.), 0x0608, 0xfa130000 / 5

    USB Device: USB2.0 Hub, 0x05e3  (Genesys Logic, Inc.), 0x0608, 0xfa134000 / 8

    USB Device: USB 3.5"-HDD, 0x0930  (Toshiba Corporation), 0x0b09, 0xfa133000 / 7

    USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0xfa110000 / 4

    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8215, 0xfa111000 / 6

    USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfd100000 / 2

    USB Device: Keyboard Hub, apple_vendor_id, 0x1006, 0xfd130000 / 4

    USB Device: Apple Keyboard, apple_vendor_id, 0x0250, 0xfd132000 / 5

    USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0xfd110000 / 3

Previous 1 2 3 Next