2 Replies Latest reply: Jun 22, 2013 7:32 AM by daBowmore
islander70 Level 1 Level 1 (0 points)

Hello all,

 

I had setup the VPN service using L2TP on our Leopard Server a month or so ago and everything was working perfectly. Just last week, it stopped working without any changes to the server or the clients. We have three clients that had been connecting, and all three are now unable to connect. For the record, they are a Lion MPB, Leopard MPB and a Snow Leopard iMac.

 

We have a static IP and business class internet service through Comcast and none of the needed ports are supposed to be blocked.

 

Using netstat, I've checked for the ports to be open on the server, and 500, 1701, and 4500 are all open for UDP4 (1723 is open on TCP also). I have these ports forwarded to the server in our Comcast Business Gateway modem/router. I've deleted and re-added those rules while trying to troubleshoot the issue. I've also tried placing the server in the DMZ.

 

While watching the VPN logs while talking to a co-worker trying to connect from his home, nothing happened at all as if there wasn't any connection at all. No negotionations or errors. Nothing at all.

 

I've tried removing the service from the server and re-adding it  to no avail.

 

I'm confused and frustrated as to why it was working and now it isn't and I'm also a bit stuck on what to even try next. I don't know what I can do to verify everything is OK with the server other than looking at the settings in Server Admin and checking that the ports appear in the list provided by netstat.

 

Any suggestions would be greatly appreciated.

 

Thank you.


Xserve, Mac OS X (10.5.8)
  • 1. Re: Help troubleshooting VPN using L2TP
    islander70 Level 1 Level 1 (0 points)

    I forgot to mention that I also get no reponse, or anything in the server logs if I try to connect to the VPN directly on the local network.

     

    I also have ESP an GRE forwarded to the server from the router.

  • 2. Re: Help troubleshooting VPN using L2TP
    daBowmore Level 1 Level 1 (0 points)

    I had similar problem, suddenly I could not connect to our VPN server on OS X server at home. No matter if i was connecting in- or outside of our home network, the result was same = no connection.

     

    Server's VPN service logs did not show even a failed attempt. Totally silent. Only when I changed to l2tp+pptp on server and changed clients profile to pptp i saw the failed login on VPN service's logs as i should.

     

    For me the solution was to change the l2tp shared secret on server and of course on the clients too (iPhones, iPads)

     

    Now it works again. Weird. Maybe some update caused a certain shared key to fail the l2tp service totally?