6 Replies Latest reply: Dec 28, 2012 3:00 AM by HiroMurdoch
2130Slovak Level 1 (0 points)

For some unknown reason, my Apple ID Password does not work when trying to down load IBooks, Nook books, or new Apps.  Everything else seems to work.  Any suggestions out their???


iPad 2
  • My voice is my password Level 2 (270 points)

    just a thought, but maybe its not the right password or account name.  check to make sure your account name doesnt have a typo in it, mine did the first time i had .net instead of .com.  go to the app store and sign out of your account and retype everything.  also test on your computer in itunes to make sure it works there.  if its still not working, try resetting it at iforgot.apple.com

     

    -mvimp

  • Johnathan Burger Level 6 (15,877 points)

    Nook app is from Barnes and nobles-it is a link to their store.

    It does not use your Apple account-it uses whatever account you set up with Barnes and nobles.

  • 2130Slovak Level 1 (0 points)

    I appreciate the info and realize that the Nook App is not related to my Apple account but this too has stopped working.  My situation first started with the Nook App not down loading and then has now spread to my IBook and new app downloads.  I have checked into my ITunes account and the ID and password are correct  and at times when I am asked to submit my Apple password such as setting up this Apple Support Community the ID and password work.  My problem seems to be just with trying to use my ID and password when wanting to download new books or apps.  I can go into the IBook, Nook, and App stores and seemingly download an item but when clicking on the new book or app nothing happens and I get a message that states it can not get into the ITunes store and it wants me to either try again or cancel.  This message appears usually ten minutes after I have tried to make a purchase.  At other times when I attempt to download a book or app I lose the screen and the IPad goes into the opening screen.  Short of redoing my Apple account or deleting an app and attempting to reload the app (but this won't work because the App store won't load new apps) I don't have a clue what to do.

  • Daniel Ebeck Level 4 (1,660 points)

    Restart your iPad by holding the Sleep & Home buttons until it reboots. Ignore the red slider.

  • Daniel Ebeck Level 4 (1,660 points)

    Can you download apps via iTunes on your computer? If you can't, this indicates a problem with your iTMS account, for which you will need to contact Apple.

  • HiroMurdoch Level 1 (0 points)

    I'm having the same problem on my iPod 4g that I got 3 days ago. It was working fine until now. I have 70 cents after buying stuff. But what I'm trying to get is free. I can log onto game network. Any advice please?