14 Replies Latest reply: Jun 17, 2012 8:22 AM by Gary P
Gary P Level 4 (1,395 points)

I am posting this in the Mac Pro forum because I am not seeing this issue on my my Macbook Pro, and therefore think it may be machine-specific. Since upgrading my Mac OS to Lion, the first keystroke is often rejected by the password field on the login screen. The field accepts the keystroke initially, but then "refreshes" and blanks out. This causes a lot of login errors, and I have to retype my password. It only happens when first logging in, never on the second entry of my password. Also, it happens equally often whether logging in on a cold boot, or when logging back in after logging out. Additionally, it doesn't happen every single time, although it happens a lot. My Lion system is an upgrade/install, and I often wonder if a clean install would fix this. I also wonder if anyone else has seen this issue.

Mac Pro, Mac OS X (10.7.4), 8 x 2.8 GHz 10 GB RAM, Radeon 4870
  • Linc Davis Level 10 (192,206 points)

    Please read this whole message before doing anything.


    This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.


    The purpose of this exercise is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login. Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:


    1. Be sure your Mac is shut down.
    2. Press the power button.
    3. Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    4. Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).


    *Note: If FileVault is enabled under Mac OS X 10.7 or later, you can’t boot in safe mode.


    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.


    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.


    Test while in safe mode. Same problem(s)?


    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of the test.

  • Gary P Level 4 (1,395 points)

    OK. I have no aftermarket expansion cards. I do have the Apple OEM ATI Radeon HD 4870 graphics card upgrade, which replaced the stock ATI Radeon 2600 XT after it failed very prematurely (premature failure was common with those cards, it turns out). I disconnected 2 wired peripherals; my Logitech webcam, and my Wacom tablet. I did not disconnect my Linksys E1200 wireless router. Booted into Safe Mode. I was unable to reproduce the problem. Unfortunately, when I reconnected the webcam and rebooted, and then when I added the tablet & rebooted again, I was also unable to reproduce the issue. So things are inconclusive at this time. I'll need to wait for the issue to reappear.

  • Linc Davis Level 10 (192,206 points)

    Safe booting forces certain system caches to be rebuilt, and sometimes that's all it takes to solve a strange problem.

  • Gary P Level 4 (1,395 points)

    I certainly hope so. Thank you! I will post back if the issue resurfaces.

  • Gary P Level 4 (1,395 points)

    A couple of days later: I have since observed the issue a couple of times. It has not gone away.

  • Linc Davis Level 10 (192,206 points)

    Please read this whole message before doing anything.


    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.


    Third-party system modifications are a common cause of usability problems. By a “system modification,” I mean software that affects the operation of other software — potentially for the worse. The following procedure will help identify which such modifications you've installed. Don’t be alarmed by the complexity of these instructions — they’re easy to carry out and won’t change anything on your Mac.


    These steps are to be taken while booted in “normal” mode, not in safe mode. If you’re now running in safe mode, reboot as usual before continuing.


    Below are instructions to enter some UNIX shell commands. The commands are harmless, but they must be entered exactly as given in order to work. If you have doubts about the safety of the procedure suggested here, search this site for other discussions in which it’s been followed without any report of ill effects.


    Some of the commands will line-wrap or scroll in your browser, but each one is really just a single line, all of which must be selected. You can accomplish this easily by triple-clicking anywhere in the line. The whole line will highlight, and you can then either copy or drag it. The headings “Step 1” and so on are not part of the commands.


    Note: If you have more than one user account, Step 2 must be taken as an administrator. Ordinarily that would be the user created automatically when you booted the system for the first time. The other steps should be taken as the user who has the problem, if different. Most personal Macs have only one user, and in that case this paragraph doesn’t apply.


    Launch the Terminal application in any of the following ways:


    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    ☞ If you’re running Mac OS X 10.7 or later, open LaunchPad. Click Utilities, then Terminal in the page that opens.


    When you launch Terminal, a text window will open with a line already in it, ending either in a dollar sign (“$”) or a percent sign (“%”). If you get the percent sign, enter “sh” (without the quotes) and press return. You should then get a new line ending in a dollar sign.


    Step 1


    Copy or drag — do not type — the line below into the Terminal window, then press return:


    kextstat -kl | awk '!/com\.apple/{printf "%s %s\n", $6, $7}'


    Post the lines of output (if any) that appear below what you just entered (the text, please, not a screenshot.) You can omit the final line ending in “$”.


    Step 2


    Repeat with this line:


    sudo launchctl list | sed 1d | awk '!/0x|com\.(apple|openssh|vix)|edu\.mit|org\.(amavis|apache|cups|isc|ntp|postfix|x)/{print $3}'


    This time, you'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. You don't need to post the warning.


    Note: If you don’t have a login password, you’ll need to set one before taking this step. If that’s not possible, skip to the next step.


    Step 3


    launchctl list | sed 1d | awk '!/0x|com\.apple|edu\.mit|org\.(x|openbsd)/{print $3}'


    Step 4


    ls -A /e*/mach* {,/}L*/{Ad,Compon,Ex,Fram,In,Keyb,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Spo,Sta}* L*/Fonts 2> /dev/null


    Important: If you synchronize with a MobileMe account, your me.com email address may appear in the output of the above command. If so, anonymize it before posting.


    Step 5


    osascript -e 'tell application "System Events" to get name of every login item' 2> /dev/null


    Remember, steps 1-5 are all drag-and-drop or copy-and-paste, whichever you prefer — no typing, except your password. Also remember to post the output.


    You can then quit Terminal.

  • Gary P Level 4 (1,395 points)

    OK, here you go:


    Last login: Fri Jun  1 08:36:30 on console

    You have new mail.

    gary-ps-mac-pro:~ xxxxxxx$ kextstat -kl | awk '!/com\.apple/{printf "%s %s\n", $6, $7}'

    gary-ps-mac-pro:~ xxxxxxx$

    gary-ps-mac-pro:~ xxxxxxx$ sudo launchctl list | sed 1d | awk '!/0x|com\.(apple|openssh|vix)|edu\.mit|org\.(amavis|apache|cups|isc|ntp|postfi x|x)/{print $3}'








    gary-ps-mac-pro:~ xxxxxxx$ launchctl list | sed 1d | awk '!/0x|com\.apple|edu\.mit|org\.(x|openbsd)/{print $3}'








    gary-ps-mac-pro:~ xxxxxxx$

    gary-ps-mac-pro:~ xxxxxxx$ ls -A /e*/mach* {,/}L*/{Ad,Compon,Ex,Fram,In,Keyb,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Spo,Sta} * L*/Fonts 2> /dev/null








    AEProfiling.framework                    HPServicesInterface.framework

    AERegistration.framework          HPSmartPrint.framework

    Adobe AIR.framework                    MacFUSE.framework

    AudioMixEngine.framework          NyxAudioAnalysis.framework

    FAProActivation.framework          PluginManager.framework

    FAProClassicSupport.framework          SU2VW.framework

    FAProCommon.framework                    SketchUpReader.framework

    FAProDB.framework                    TSLicense.framework

    FAProImporter.framework                    WacomMultiTouch.framework

    FAProPluginSupport.framework          XRiteDevice.framework

    FAProReporter.framework                    iLifeFaceRecognition.framework

    FAProScriptingKit.framework          iLifeKit.framework

    FAProSharing.framework                    iLifePageLayout.framework

    HPDeviceModel.framework                    iLifeSQLAccess.framework

    HPPml.framework                              iLifeSlideshow.framework



    /Library/Input Methods:







    /Library/Internet Plug-Ins:

    .DS_Store                              QuickTime Plugin.plugin

    AdobePDFViewer.plugin                    Silverlight.plugin

    Flash Player.plugin                    WacomNetscape.plugin

    Flip4Mac WMV Plugin.plugin          WacomTabletPlugin.plugin

    Google Earth Web Plug-in.plugin          flashplayer.xpt

    JavaAppletPlugin.plugin                    iPhotoPhotocast.plugin

    Quartz Composer.webplugin          nsIQTScriptablePlugin.xpt



    /Library/Keyboard Layouts:




    com.adobe.AAM.Updater-1.0.plist                    net.culater.SIMBL.Agent.plist

    com.google.keystone.agent.plist                    org.glimmerblocker.updater.plist





    com.adobe.SwitchBoard.plist                    com.bombich.ccc.plist

    com.adobe.versioncueCS3.plist                    com.google.keystone.daemon.plist

    com.apple.remotepairtool.plist                    com.wdc.drivemanagerservice.plist

    com.barebones.authd.plist                    org.glimmerblocker.proxy.plist




    Flash Player.prefPane          GlimmerBlocker.prefPane          VersionCueCS3.prefPane

    Flip4Mac WMV.prefPane          LazyMouse.prefPane          WacomTablet.prefPane




    com.barebones.authd          com.bombich.ccc




    GBQLGenerator.qlgenerator          iWork.qlgenerator




    AppleIntermediateCodec.component          Flip4Mac WMV Advanced.component

    AppleMPEG2Codec.component                    Flip4Mac WMV Export.component

    FLV.component                                        Flip4Mac WMV Import.component




    Adobe Unit Types.osax          SIMBL.osax




    GBSpotlightImporter.mdimporter          Microsoft Office.mdimporter

    LogicPro.mdimporter                    iWork.mdimporter













    com.adobe.SwitchBoard.monitor.plist          com.adobe.versioncueCS3.monitor.plist



    Library/Address Book Plug-Ins:

    PushDialer.bundle          SkypeABDialer.bundle          SkypeABSMS.bundle




    .DS_Store                                        DictumBold

    Anonymous Pro B.ttf                              Envy Code R Bold.ttf

    Anonymous Pro BI.ttf                              Envy Code R Italic.ttf

    Anonymous Pro I.ttf                              Envy Code R VS Italic-as-bold.ttf

    Anonymous Pro.ttf                              Envy Code R VS.ttf

    BickhamScriptPro Bold.otf                    Envy Code R.ttf

    BickhamScriptPro Regular.otf                    Existence Light.TTF

    BickhamScriptPro Semibold.otf                    Existence Light.otf

    BitstreamVeraSansMono Bold.TTF                    Inconsolata.otf

    BitstreamVeraSansMono BoldOb.TTF          Momo.ttf

    BitstreamVeraSansMono Oblique.TTF          PaletteD

    BitstreamVeraSansMono Roman.TTF                    PanicSans.dfont

    BocaRatICG                                        PeignBol

    BocaRatICGSol                                        PeignDem

    BocaRatonICG                                        PeignLig

    BocaRatonICG Solid                              Peignot Bold

    BriosoPro Poster                              Peignot Demi

    BroadwayBT                                        Peignot Light

    Cornet Regular                                        PrettyBaby

    DejaVuSans-Bold.ttf                              ProFont

    DejaVuSans-BoldOblique.ttf                    Sansation Bold.TTF

    DejaVuSans-Oblique.ttf                              Sansation Light.TTF

    DejaVuSans.ttf                                        Sansation Regular.TTF

    DejaVuSansCondensed-Bold.ttf                    SansuDemBol

    DejaVuSansCondensed-BoldOblique.ttf          SansuReg

    DejaVuSansCondensed-Oblique.ttf                    SansuUltLig

    DejaVuSansCondensed.ttf                              Sansumi DemiBold

    DejaVuSansMono-Bold.ttf                              Sansumi Regular

    DejaVuSansMono-BoldOblique.ttf                    Sansumi UltraLight

    DejaVuSansMono-Oblique.ttf                    Scriptina.TTF

    DejaVuSansMono.ttf                              ShellAllBTReg

    DejaVuSerif-Bold.ttf                              ShellAllScr

    DejaVuSerif-BoldItalic.ttf                    ShellAndScr

    DejaVuSerif-Italic.ttf                              ShellVolScr

    DejaVuSerif.ttf                                        Shelley

    DejaVuSerifCondensed-Bold.ttf                    ShelleyAllegro BT

    DejaVuSerifCondensed-BoldItalic.ttf          monof55.ttf

    DejaVuSerifCondensed-Italic.ttf                    monof56.ttf




    Library/Input Methods:




    Library/Internet Plug-Ins:

    ClickToFlash.webplugin                    Google Earth Web Plug-in.plugin



    Library/Keyboard Layouts:






    com.apple.AddressBook.ScheduledSync.PHXCardDAVSource.0B091450-D849-4697-B6F4-CAA 7840EAB38.plist








    .DS_Store                              MouseLocator.prefPane

    Launchpad-Control.prefPane          Perian.prefPane

    MenuMeters.prefPane                    PushDialer.prefPane




    BrushViewQL.qlgenerator          Folder.qlgenerator




    AC3MovieImport.component          Perian.component







    Dial Number on iPhone.workflow                    Special Characters Menu.workflow

    gary-ps-mac-pro:~ xxxxxxx$ osascript -e 'tell application "System Events" to get name of every login item' 2> /dev/null

    Window Tidy, Growl, FontAgent Activator, MouseLocatorAgent, AdobeResourceSynchronizer, OpenDNS Updater, Caffeine, TinyAlarm, LazyMouseBG, ColorSnapper, Zoom It, Dropbox

    gary-ps-mac-pro:~ xxxxxxx$

  • Linc Davis Level 10 (192,206 points)

    Please read this whole message carefully, especially the warnings, before doing anything.


    The changes to your configuration suggested here should be considered provisional; they may not solve your problem, or they may remove functionality that you find useful. If a third-party system modification that you want to keep is causing the problem, seek help from its developer.


    WARNING: Back up all data now if you haven’t already done so. Before proceeding, you must be sure you can restore your system to its present state, even if it becomes unbootable. If you’re not sure you can do that, STOP — DON’T CHANGE ANYTHING. If you’re dissatisfied with the results of the procedure suggested below, restore from your backup. I will not be responsible for the consequences, and I will not help, if you ignore this warning.


    You should either remove or update the following system modification(s), if an update is available from the developer:




    and definitely remove at least the following:



    † SIMBL


    Whatever you remove must be removed completely, and (unless otherwise specified in this message) the only way to do that is to use the uninstallation tool, if any, provided by the third-party developer, or to follow his instructions. In some cases it may be necessary to re-download or even reinstall the software in order to get rid of it. I can't be more specific, because I don't install such things myself. Please do your own research.


    Here are some general guidelines to get you started. Suppose you want to remove something called “BrickYourMac.” First, consult the product's Help menu, if there is one, for instructions. Finding none there, look on the developer's website, say www.brickyourmac.com. (That may not be the actual name of the site; if necessary, search the web for the product name.) If you don’t find anything on the website or in your search, email the developer. While you're waiting for a response, download BrickYourMac.dmg and open it. There may be an application in there such as “Uninstall BrickYourMac.” If not, open “BrickYourMac.pkg” and look for an Uninstall button.


    Again, please don't ask me to do this research for you. You can do it better than I can, because I haven't installed the product and I may not even know what it is.


    If you can’t remove software in any other way, you’ll have to erase your boot volume and perform a clean reinstallation of the Mac OS. Never install any third-party software unless you're sure you know how to uninstall it; otherwise you may create problems that are very hard to solve.


    WARNING: Trying to remove complex system modifications by hunting for files by name often will not work and may make the problem worse.


    I recommend that you never reinstall the modifications marked with a dagger (†) above, if any. If your problem is resolved after uninstalling all the above modifications and rebooting, but you still want to use some of those not marked with a dagger, you can experiment with putting them back, one at a time, testing carefully after each step. Keep in mind that system modifications may be incompatible with each other or with future Mac OS updates, so it may not be clear which one is at fault.


    Uninstall SIMBL as follows.


    Select Go ▹ Go to Folder… from the Finder menu bar, then enter the following text in the box that opens:




    A folder will open. From that folder, delete the items listed below (some may be absent.) You may be prompted for your administrator login password.


    Application Support/SIMBL





    Log out and log back in.


    Make sure you never reinstall SIMBL. It’s likely to come bundled with another third-party system modfication that depends on it. If you want trouble-free computing, avoid software that makes miraculous changes to other software, especially built-in applications. The only real exception to that rule is Safari extensions, which are mostly safe, and are easy to get rid of when they don’t work. SIMBL and its dependents are not Safari extensions.


    If you still have problems after making the suggested changes and rebooting, post again. Remember: if you don’t like the results of this procedure, you can undo it by restoring from the last backup you made before you started.

  • Gary P Level 4 (1,395 points)

    Thanks. Yes, I saw on the web that SIMBL is a bad idea. I forget why I installed it. I guess I'll find out when whatever it was supporting stops working. As for LazyMouse, I have only had trouble with it once, in many long years of using it. That issue was fixed by an update. I will delete SIMBL immediately, and use the system a few days to see if the issue is solved. I will never reinstall it. I'll wait a bit on LazyMouse, but it sounds like you are recommending against it. I'll post back with results.

  • Grant Bennet-Alder Level 9 (56,466 points)

    1password has also caused some trouble, especially if you are not on the correct version.

  • Gary P Level 4 (1,395 points)

    Isn't there some confusion with 1Password versions? I seem to recall they split it when they moved to the App Store. I may have the non App Store version. I'll have to check. There was a lot of complaining from people not wanting to buy it all over again so soon.

  • Gary P Level 4 (1,395 points)

    SIMBL got installed along with Safari Cookies, a cookie manager that lives in Safari's preferences area. I uninstalled it and, so far, it looks like the issue is gone. Will reconfirm in case anyone is interested.

  • Gary P Level 4 (1,395 points)

    3 days later. I am going to call this problem solved. The issue has not reappeared. Thank you, Linc Davis!

  • Gary P Level 4 (1,395 points)

    10 days later, the issue has returned. I guess LazyMouse is next for the chopping block. Darn, I like LazyMouse.