4 Replies Latest reply: Jun 17, 2012 11:34 AM by noderaser
Teshup Level 1 (0 points)



I got a problem with OS X 10.5.8 (I guess)


The situation is;

I got an older iMac, G5 with OS X 10.3.9, where I have a printer connected.


I want to print from my iMac Intel Core 2 Duo with OS X 10.5.8,

so I got through all the steps for printer sharing (and I am quite shure I did it all right, because accidently I found out printing from my iBook in the same network was not eaven as difficult as thinking about it. I just klicked on printing (in Word), seleceted my printer and without any other configuration it just worked.)

But from the Intel Mac it doesn't, it don't eaven will find the printer, also file sharing works fine, so there must be a connection.


Oh, on my iBook I use OS X 10.4.11.

  • BDAqua Level 10 (122,202 points)

    Does only the G5 have Printer Sharing enabled?


    On the 10.5.8 Mac, System Preferences>Fax & Print, click on the little plus icon, next window click on More Printers, does it show under any of the possibilities there?

  • Teshup Level 1 (0 points)



    No, on the Intel Mac I enabled it also on System -> sharing printer sharing.jpg

    I also tried to add it in the Fax & Print tab, but I could not find it there, also I just tried any option:


    On the frist (IPP) I get a list with the drivers where I did select my printer but if I klick on it it doesn't take it over to the selection field. I don't know what to fill in the other fields:add printer ipp.jpg


    With the option Line Printer Daemon I get no other option to choose and still don't know what fo type in the address or name field.


    With the last option;  HP Jetdirect - Socket I got the same problem.


    I thought I should install the driver and loaded and installed it from the Cannon web site. But that didn't help and I also don't know if it worked, because I also installed the program CD-Lable print, and if I open this I get still the message that the programm can not start because there is no "from the software supportet printer installed":

    Labelprint error.jpg


    Well, thatÄs it so far.

    Thank you for your help.

  • BDAqua Level 10 (122,202 points)

    Printer Sharing should only be enabled on the computer actually having the printer connected to it physically, in the past you had to even reboot after turning it off or it'd only look to itself for the shared printer.


    I don't think IP will work for a USB printer, but it may if you check System Profiler>Hardware>Printers & get something like this...


    URI:          usb://Brother/HL-4070CDW%20series


    After installing drivers on this one did you Repair Permissions & reboot?

  • noderaser Level 1 (0 points)

    If the printer is shared from the host machine, you should be able to find it under the "Default" tab of the add printer window. It should show up as a "Bonjour Shared" printer. Also, as an FYI, your G5 iMac is fully capable of running 10.5, unless there is some specific reason for running 10.3 on it.