Previous 1 2 3 4 Next 53 Replies Latest reply: Nov 9, 2015 10:28 AM by Reid Monroe Go to original post Branched to a new discussion.
  • samofsam Level 1 Level 1

    This fixed my problem, thanks! The problem widget was "Red Alarm Clock". To delete it I had to access the second Library widget folder as detailed here-

  • smiff Level 1 Level 1

    Well, I tried most of these solutions and nothing worked. But I just accidentally hit Command-Q and what do you know - no re-launch!


    If I quit when no music is playing - relaunch every time.


    Well, it's a sort of solution.

  • TopDeadCenter Level 1 Level 1

    Fixed.  I had to manually quit the "I Love Stars" app that I had just updated.  Never had a problem before.

  • smiff Level 1 Level 1

    Genius! Works for me. Shame, as "I Love Stars" is a great app.

  • Leenaxio Level 1 Level 1

    I had the same problem too. I just renamed iTunes to Music, and the problem went away.

  • strangelove1 Level 1 Level 1

    I did nothing and my problem went away... and then came back for one session... and then went away... and it hasn't come back.  (I was having the problem where my headphone was causing iTunes to start.)

  • smiff Level 1 Level 1

    "I Love Stars" has just been updated again, and no longer causes iTunes to relaunch.

  • Clissold Level 1 Level 1

    I now have this problem. No idea how or why it started. Just restarted once and there it was, the zombie iTunes.


    I run 10.6.8

  • rickthurmond Level 1 Level 1

    I'm convinced that the headphone jack is what is causing iTunes to start by itself!  I have headphones for my iPhone.  The plug has four contacts on it.  There is a set of buttons on the headphones that allows me to start and stop music.  If I plug that headphone into the MacBook and press the buttons I can start up iTunes.  The plug for my Soundsticks has only three contacts, so it is shorting the third and fourth contacts together.  Wiggling the plug (or just an unstable connection) simulates pressing the buttons.

  • therealhershey Level 1 Level 1

    SOLUTION for me was to disable BlueTooth.


    I picked up a Vizio soundbar on Black Friday that has BT. My MBP automaticly connects and defaults sound output to it from anywhere within 33 feet in the house. iTunes had been refusing to stay shut... I uninstalled it with AppCleaner, went through all of my startup items, removing each one individually in between restarts, trying to track down which one might be causing it ZombieTunes. After uninstall iTunes, I'd get a window that asking where iTunes was located; it didn't seem to be tied to anything, besides, maybe Finder (no other apps running). Finally found this thread after some additional Googling and disabled BT, restarted, and everything is back to normal. I think it'd stay normal if OS X didn't set the Vizio SB to the default output as soon as it connected to it... Kind of ****** me off that there doesn't seem a way to keep it from doing this (there's always Opt+Click sound icon in the menubar, but still).

  • OneZuckAtATime Level 1 Level 1

    This is what resolved my issue!!!  That stupid red clock widget was the root of all evil!

    Thanks man, you just helped me fix something that was slowly draining my life years due to excessive stress caused by continuous cursing at apple... 

  • vlad_djkax Level 1 Level 1

    Guys, I think this may be the solution. Simple, but this worked for me:


  • aaronwest Level 1 Level 1

    I'm a programmer/engineer and have been working professionally in the technology space for 14 years. So I'm probably one of the more technical folks browsing this forum. I've read through this entire thread and there are a lot of solutions mentioned. One will work for one person and another won't.


    I think there are several things at play with this issue and there are likely several different solutions depending individual machines and how they are used. The ideas and solutions around checking recent installs (like the alarm/lock dashboard widgets) are great ideas and seem to have worked for folks.


    I started having this same problem today and I'm on a two month old Macbook Pro and have never, not once launched iTunes. This is my work laptop and I use streaming apps for music. So I was baffled at why iTunes would start launching on its own.


    The first thing I did - before reading the forums - was checking my user account (Login Items) in System Preferences to see if iTunes was listed. Sure enough it was. I removed that quickly. I then went to my Music folder and deleted the iTunes directories (and sometimes iPod directory) which showed up after iTunes launched the first time. Then I kept working.


    About 5 minutes later iTunes launched again. I use a keyboard app called LaunchBar so I started wondering if I had inadverently pressed a keyboard shortcut to play a song (even though I have no iTunes library) or something to that effect. I just kept closing iTunes after launched 2-3 times over a 45 minute period. And all the while I'd remove the Login Item if it showed up in System Preferences / Users & Groups.


    Then I Googled the issue and as usual with Apple problems I wound up browsing these forums.


    When I got to the comment where someone mentioned removing headphones from the computer causing the problem I kind of laughed a little. I thought that was certainly possible but probably very much an edge case. Then I looked down at my desk. Today I had done something I'd never done. I had my Sol Republic Jax headphones plugged into my Macbook Pro and routed beneath my keyboard. The keyboard was placed on sticky note pads to give the headphone cable a little room to move around. To get everything working comfortably I had moved the keyboard around some and shuffled the headphone cable around some too. All while the headphones weren't fitted in my ears.


    I also saw in this thread where someone mentioned the headphone buttons integrated into the cord of some models including Apple and Sol Republic. I started wondering if I had inadvertently mashed the "next track" button on my Sol Repulic Jax headphones. I had since unplugged them from my laptop so to test I plugged them back in and then pressed the "next track" button. Sure enough, iTunes launched.


    After checking System Preferences again and removing all the iTunes/iPod stuff from my Music folder I clicked the "next track" button a second time. And a second time iTunes launched.


    Since today is the only day I've had this automatic (or zombie as one called it) iTunes launching problem, and the only thing different I've done is how I have physically used my desk, I think the headphone button was my issue. If for some reason this isn't the case I will certainly report back.

  • rickthurmond Level 1 Level 1

    If you have a chance, unplug the headphone for a period of time and see whether iTunes ever starts without the headphone plugged in (or powered speakers for that matter). I think the headphone jack is overly sensitive to electrical noise from anything plugged into it.

  • Twelvebears Level 1 Level 1

    I've had the 'Zombie' issue on my MacMini for month, and had been trying to ignore it, but it was bugging me to say the least. I may have been the Bluetooth thing, but as I have to have it on to be able to use it, not an option as a solution.


    The option which does seemed to have worked for me, with no visable issues, was to deleted the iTunes Helper app within the iTunes app itself. iTunes still seems to function just fine and has no issues seeing and connecting with iDevices. The only thing it won't do now is to open automatically if I connect an iPad, iPhone etc. However, as I basically never do this and it doesn't open itself the rest of the time, that is just fine by me.


    Frankly, I wouldn't have minded the auto-opening 'bug' (and let's face it, something this annoying IS a bug Apple) so much, if it wasn't for the face that having opened, iTunes then wouldn't respond which meant you couldn't even use it if you wanted to!


    Anyway, seems top have been solved for now, however I'm expecting to have to repeat my fix with the next release, as this will probably reinstall the unhelpful helper again