14 Replies Latest reply: Dec 18, 2013 9:25 AM by Ben McC
pavel.pola Level 1 (0 points)

keyboard.png


iMac, Mac OS X (10.7.4)
  • X423424X Level 6 (14,215 points)

    Keyboard shortcuts --  the tab to the right of the one you have in your picture above.

     

    You can click the area where the key definitions are to edit the command key setting.  Below is a post I made for another keyboard shortcuts related question illustrating the editiable command key area I am talking about.

     

    screenshot_8.png

     

    Note I clicked on the key editing area to highlight it.  I can delete what's there or enter a new key sequence to change it.

  • pavel.pola Level 1 (0 points)

    I'm sorry, but you don't understand me. There is a article from Apple (http://support.apple.com/kb/HT3399?viewlocale=en_US&locale=en_US) with a procedure to change the behaviour of all "standard" multimedia and functional keys (like display brightness, volume control, iTunes control, etc.).

     

    For example: when I press F8, iTunes will stop/start playing. When I press F10, the volume is muted. And I want to have these functions accessible only when pressing Fn + F8 or Fn + F10. Above mentioned procedure says: Go to Keyboard preferences and Enable "Use all F1, F2, etc. keys as standard function keys.". But there is no "Use all F1, F2, etc. keys as standard function keys." option in Keyboard preferences any more so I cannot enable it.

  • X423424X Level 6 (14,215 points)

    You can add your own, or override an applications predefined ones using the Keyboard Shortcuts.  Select Application Shortcuts on the left and Add your own under All Applications on the right.  If there's a menu item in the application with the exact same name you define to be overridden it will use yours.  If you cannot do it there then you cannot change the ones in the application.

     

    Note there are applications like QuicKeys and Keyboard Maestro that may let you do it but I am not sure.

     

    Also, maybe it's because I don't use an apple keyboard but I don't see any of those keys you mention, i.e., F8, F10, etc.  F10 in my system is the Expose "Applications window".

  • R C-R Level 6 (17,400 points)

    Your system info says you are running Mac OS X (10.7.4), which is Lion. This is the Snow Leopard (OS X 10.6) forum. The KBase article you mentioned says it is for OS versions 10.4 through 10.6. I'm not sure it applies to Lion.

     

    Running 10.6.8, this is what I see in the Keyboard System Preference Keyboard tab:

    keyboard system preference.PNG

     

    I'm using a full sized, wired Apple aluminum keyboard. The options may be different for another keyboard, but as you can see the option to use the F keys as standard function keys is the first of two with this setup. Your single option seems different from either of mine, possibly because the option is elsewhere in Lion's system preferences.

  • pavel.pola Level 1 (0 points)

    Hi, thank you for your answer. I have 10.7.4. on MacBook Pro with Apple Wired keyboard and I can see this option. At home I use Logitech K750i Solar Wireless for Apple keyboard and I don't see this option. So maybe the problem is caused by keyboard driver. Thank you for your patience and sorry for disturbing Snow Leopards... :-))))

  • Roger Wilmut1 Level 9 (75,054 points)

    This is only going to work if your keyboard has an fn key - many don't.

  • Roger Wilmut1 Level 9 (75,054 points)

    I can't see whether that has a function key or not. If it does I suppose it's here:

     

    solar.jpg

     

    or the key below it, but I can't read them. If it's there I can't say why you're not seeing the checkbox. Perhaps it is as you say a driver issue if Logitek have a custom one.

  • pavel.pola Level 1 (0 points)

    Be sure this keyboard has a Fn key. I'm using it a lot and it is disturbing so I want to change this default behaviour. I need to try experimenting with another driver or keyboard to have it working. Thanks again for your patience... :-)

  • R C-R Level 6 (17,400 points)

    You may just be looking in the wrong place. According to this Logitech support article, you should be able to change the F key behavior in the Logitech Control Center, which should be in the "Other" system preferences section.

     

    EDIT: the Logitech Control Center download page is http://www.logitech.com/en-us/434/9869. It appears that earlier versions did not support the F key inversion option, so make sure you have the latest version, compatible with both 10.6 & 10.7.

  • pavel.pola Level 1 (0 points)

    Wow, thank you for your answer. I'm sure I don't have this Logitech Control Center so I have to investigate a little bit further. But this seems to be a very good clue.

  • useEvil Level 1 (0 points)

    I have the same keyboard (mac version, white keyboard) and I have the same problem.  I had to use the Logitech Control Center softerware to change the Fn key setting.  My problem is that the lotigitech driver is not compatible with the SteerMouse driver.  I had to uninstall after I made the change.  Oddly enough, I also have the PC version of this soloar keyboard (black keyboard) and I have no such problems with the driver and that Fn option is available in the System Preferences.

  • NikTv Level 1 (0 points)

    Logitech exposed this in their own configuration:Screen Shot 2013-06-21 at 12.10.15 AM.png

  • Ben McC Level 1 (0 points)

    I had this problem with the Matias One Keyboard (FK301MI) and solved it.

     

    Plug in an Apple keyboard IN ADDITION TO your keyboard.

     

    The check box for "Use all F1, F2, etc. keys as standard function keys" will reappear.

     

    Check the box, unplug the Apple keyboard, and your keyboard will work just fine.