10 Replies Latest reply: Oct 7, 2012 8:48 AM by nckswtc1
atimoshenko Level 1 (0 points)

So I'm trying to do a clean boot camp install of Windows 8 Release Preview (released yesterday) and am running into the infamous "Select CD-ROM Boot Type" error at the start of the process. I am almost 100% sure that this problem only ever used to creep up when trying to install a 64-bit version of Windows on a 64-bit capable Mac with a 64-bit EFI (roughly Mid-2007 – Mid-2008 models).

 

My machine is a late-2007 MacBook (so I've run into this problem before), but I have long ago learnt to just instal the 32-bit versions (for instance, windows 8 consumer preview installed just fine), and this is what I'm doing now.

 

Has anyone else encountered this with the new Release Preview? Any ideas on how to solve it? I remember with Win 7 there was an option to faf around with the Windows DVD install image and remove/bypass that prompt, but I no longer seem to be able to track down a guide for that on Google.

 

Any ideas would be much appreciated!


MacBook, Mac OS X (10.7.4)
  • The hatter Level 9 (60,930 points)

    You could have just used the Windows 8 Setup program to download and do clean install, no need to boot off DVD, assuming you had and still have a functional Windfows to boot into.

  • atimoshenko Level 1 (0 points)

    Thanks @The hatter, but no luck – I wiped by CP before restarting the Boot Camp setup process.

     

    Some googling did allow me to re-find the solution I remembered (for Windows 7 64-bit, but it's now just as necessary for Windows 8 RP 32-bit). It's quite simple (modifying the ISO a little bit), but it does require access to a Windows machine beforehand.

     

    The instructions are here: http://www.fluxbox.co.uk/2009/08/26/windows-7-64-bit-onto-your-mac-select-cd-rom -boot-type/

     

    And the OSCDIMG.EXE (possibly updated for Windows 8 RP) file referenced in the instructions can be downloaded directly from Microsoft here: https://www.microsoft.com/en-us/download/details.aspx?id=29929

  • The hatter Level 9 (60,930 points)

    My guess was that Windows 8 is requiring UEFI even for 32-bit versions whereas before it was 64-bit.

     

    If you didn't have OS X you could use MBR but the rule is, If you have GPT (which OS X uses and requires) then you must have and use UEFI.  And UEFI support was added to Vista SP1 64-bit.

     

    Some people load Windows in a VM and make changes to the ISO and DVD from there.

     

    And it is us with older pre-2008 and some 2008-9 Macs that have 64-bit processor but did not get the newer UEFI ROM.

     

    So your fix will be useful for those and needs to be sticky and a bookmark reference.

  • jpapin Level 1 (0 points)

    I tried installing Windows 7 through BootCamp, but keep getting the dsame error message.  I can't get the DVD disc out.  Nothing on the keyboard will work.  How can i get the disc out so I can try to install the 32 bit version? 

  • jpapin Level 1 (0 points)

    I found the answer.  I searched before I asked.  Sorry about the question.

  • wtb3 Level 1 (0 points)

    please help me! i have the same problem what was your answer!

  • atimoshenko Level 1 (0 points)

    wtb3, are you able to get to the OS selection menu by holding down Option right after the boot chime? If so, you should be able to eject the disk from there (or, at least, boot back into OSX). In my experience with Boot Camp I've never not had that work, so if it does not for you, I hope someone else here can help.

  • scottoh Level 1 (0 points)

    Thanks for the help, this is the same problem I have come across while trying to install the 64 bit release preview. I hope it's ok to bump this thread.

     

    The instructions within that link (in atimoshenko's second post) says to:

     

    "Move the ISO into the c:\windows7iso and unzip the contents (into the same directory) with MagicISO"

     

    I was wondering if there was any way around this? First I don't know how to unzip with MagicISO, and second, it looks like you have to buy the full version to use a file bigger than 300 MB. I tried extracting it using winzip but the ISO file in the dvd folder isn't recognized as a bootable device.

     

    Thanks to anyone who can help!

  • atimoshenko Level 1 (0 points)

    I should have read the instructions more creafully before linking to them – the recommendation to use MagicISO is silly. Use WinRAR if you are already on a Windows machine ( http://www.rarlab.com ) or TheUnarchiver ( http://itunes.apple.com/us/app/the-unarchiver/id425424353 ) in OSX and just transfer the decompressed ISO via thumbdrive. Certainly don't buy anything. Good luck!

  • nckswtc1 Level 1 (0 points)

    When I use The Unarchiver, it simply generates a README.TXT with the following content:

     

    This disc contains a "UDF" file system and requires an operating system

    that supports the ISO-13346 "UDF" file system specification.

     

     

    Any idea what I can do? I'm using a mid-2007 iMac with Mountain Lion.

     

    Thanks!