6 Replies Latest reply: Jun 4, 2012 10:27 PM by MacKyver
MacKyver Level 1 (5 points)

All the presets I add to Aperture disapper after I close the app and launch it again, such as Metadata Views, new Adjustment presets, import/export presets, folder naming etc. It's not designed this way, right?


I tried dragging Aperture to Trash and reinstall again, same thing.


I checked online, the preset files are supposed to be saved into /Library/Application support/Aperture/ but it's all empty on my machine.


What else can I try?

  • léonie Level 10 (85,025 points)

    All the presets I add to Aperture disapper after I close the app and launch it again,

    How do you "close the app"? With a "Quit" or with a "Force Quit"?


    This looks like you have a permission problem and Aperture is not able to save the changes. Do at least the images persist, that you import?

    You are not by any chance working from a guest account without priveleges, are you?


    What is your Aperture version and MacOS X version?


    I checked online, the preset files are supposed to be saved into /Library/Application support/Aperture/ but it's all empty on my machine.

    The presets you set are suppose to be in your Home folder/Library/Application support/Aperture/


    Is this empty as well?





  • MacKyver Level 1 (5 points)

    Hey there, thanks for the troubleshooting.


    1. Yes by "closing the app" I mean "Exiting" completely and even rebooting before relaunching the app again, same problems.


    2. I have also launched "Disk Utility" to do a permission repair, same issues persist.


    3. Aperture has been updated to latest 3.2.4. OSX is 10.7.4


    4. Yes, the folder where the presets are supposed to be are all empty no matter how many times I save different presets, none of them is saved!!! urghh...

  • léonie Level 10 (85,025 points)

    Can you save presets, when you lauch Aperture from a different account? Do you have a second user account on your mac? If not, create one from the "Users & Groups" System Preference.


    If you can save presets and preferences from a different account, I'd suggest to repair the permissions on your system volume. using Disk Utility.

  • MacKyver Level 1 (5 points)

    already did "repair permission" on system volume as stated in my post above under #2, still the same problem persists.


    Any other ideas?

  • léonie Level 10 (85,025 points)

    Have you actually looked at the permissions in your User Library?


    You should be the owner of all your library files and have read/write priveleges for the files, and execute for the folders.


    Listing the "Applications Support" folder in the Terminal with the following command should show something similar to this:


    %  ls -l ~/Library/Application\ Support

    total 368

    drwx------    13 dreschle  staff     442 Jun  2 04:07 AddressBook

    drwxr-xr-x    27 dreschle  staff     918 Nov 29  2011 Adobe

    drwxr-xr-x    18 dreschle  admin     612 Jun  1 07:47 Aperture

    drwxr-xr-x     3 dreschle  staff     102 May 21  2008 Aquamacs Emacs

    drwxr-xr-x     3 dreschle  staff     102 Jul 23  2009 ArcSoft

    drwxr-xr-x     3 dreschle  staff     102 May  6  2009 ArtRage 2

    drwxr-xr-x     9 dreschle  staff     306 Dec 30 17:45 Audio Hijack Pro

    drwxr-xr-x     5 dreschle  staff     170 May  9 00:47 Automator

    drwxr-xr-x     9 dreschle  staff     306 Feb  7 20:36 Backup

    drwxr-xr-x     4 dreschle  admin     136 Nov 13  2010 Bento

    drwxr-xr-x    15 dreschle  staff     510 Jan 22 10:41 BibDesk


    the codes "xrwx" show that the item is a library (d) and the owner (columns 2,3,4) has write, read, and execute priveleges.


    and listing the contents of the Application support folder:


    % ls -l ~/Library/Application\ Support/Aperture

    total 672

    -rw-r--r--   1 dreschle  admin  165656 Feb  5 09:43 Adjustment Chain Presets.plist

    drwxr-xr-x  13 dreschle  admin     442 Mar 27 01:23 Adjustment Preset Brushing

    -rw-r--r--   1 dreschle  admin    1111 Apr  6 16:10 AdjustmentPresets.plist

    drwxr-xr-x   4 dreschle  admin     136 May 26 10:04 Command Sets

    -rw-r--r--   1 dreschle  admin   46072 May  5 16:00 Export Presets.plist

    -rw-r--r--   1 dreschle  admin    2629 May 30 18:42 FileFolderPresets.plist

    -rw-r--r--   1 dreschle  admin    4021 May 30 18:42 FileNamingPresets.plist

    -rw-r--r--   1 dreschle  admin    1008 May 30 16:10 Import Presets.plist

    -rw-r--r--   1 dreschle  admin    8218 Apr  9 06:49 Metadata Presets.plist

    -rw-r--r--   1 dreschle  admin   28855 Jun  1 07:47 MetadataSets.plist

    drwxr-xr-x   4 dreschle  staff     136 Apr 28 13:59 Plug-Ins

    -rw-r--r--   1 dreschle  admin   15020 Apr 29 19:17 PrintPresets.plist

    -rw-r--r--   1 dreschle  admin    1107 Apr  6 16:10 Raw Decode Presets.plist

    -rw-r--r--   1 dreschle  admin   24687 May 30 18:31 Slideshow Presets.plist

    drwxr-xr-x   9 dreschle  admin     306 Apr 15 23:27 WatermarkImages

    -rw-r--r--   1 dreschle  admin   14453 Apr 13 19:43 Web Export Presets.plist


    What are the priveleges in your user library? You are saying that the Aperture seting don't exist, but do the other folders on the path to ~/Library/Application\ Support/Aperture exist, and what are the protection codes (drwx) for the folders along the access path?

  • MacKyver Level 1 (5 points)

    thanks for the terminal commands, yes, I think this is the "root" cause of the problem, unlike the "admin" permission on your Aperture folder, I only get "staff" status on the Aperture folder in ~/Library/Application Support, as shown here:


    drwxr-xr-x+   3 root  staff   102 17 Jul  2010 Aperture


    I went into "Get Info" and added "admin" with Privilege of "Read & Write" to the custom access under "Sharing & Permissions" and now it works!


    Screen Shot 2012-06-04 at 10.24.44 PM.png


    Why did Aperture do this to me to begin with?