5 Replies Latest reply: Oct 18, 2015 7:13 PM by AgentReem
tiburonsteve Level 1 (0 points)

There's an event in my iPhone 4s calendar that I can't edit or delete.  There is no edit button in the upper right as there is for other events.  Also, there's a line that says "Accepted" followed by my name.  When I look at my iCloud calendar on my PC, the event isn't there.  Even after synching my phone, it doesn's appear on my PC.  When I go to iTunes>info>calendar it says that no calendar application is recognized and that my calendar is synched by iCloud.  I don't know how this event got into my iPhone calendar--it wasn't something I accepted from an email (it's a doctor apppointment) but I would appreciate advice about how to get it out.


iPhone 4S
  • jamesbwheeler Level 1 (0 points)

    I had the same problem. I use gmail to sync calendars on my iPhone 5.  I also had settings/iCloud/Calendars marked "on."  I accepted a calendar invite by someone who uses Outlook on a PC.  The event was then cancelled by the person after the meeting was no longer required. I deleted it from my google calendar, but it kept showing up as an event in my iPhone.  To solve the problem I marked settings/iCloud/Calendars to "off" Then I deleted the calendar in iCal that showed up as "work." This was the only appointment that was on that calendar.


    I have found challenges with syncing with PC Outlook users, and I usually end up creating my own events and rejecting thier calendar invites with an explanation that I have added it to my personal schedule.

  • Pjhsp Level 1 (0 points)

    I am a complete dum dum regarding the inner workings and hidden mechanisms of any electronic item; but I did stumble upon a very simple fix. Go to the day of the item you wish to delete. Tap "calanders" then tap "edit". Press Add Calendar. Assign it a name like Garbage or something more clever. Then go back to the appointment you wish to eradicate. Tap it then tap "edit" in upper right hand corner. There will be an entry "Calendar". Tap it and you will have choices, including the Calander you just named. Tap that name then tap "done"; the "done" again.  Now press the date in the upper left hand corner. Now press "Calenders" again and then press "edit". Tap on your newly created Calendar which now includes that insidious appointment. At the bottom in RED letters you can "delete calendar". Press that. It will say, are you sure you want to delete this calendar?  All events associated with the calendar will also be deleted. So press "delete calendar" again and voila the appointment is permanently deleted along with your newly created Calander!

    (Iphone 4s)

  • rosebill4558 Level 1 (0 points)

    I did essentially what you suggested and it appears to have worked. Ingenious.

  • Paula246 Level 1 (0 points)

    I tried your instructions but when I go back to the entry I want to delete I can't change that for the calendar either.  It is as if the edit function as completely disappeared since I updated my 4s to 8.1.1 a week ago and  I just updated to 8.1.2 today and it still does not work.  I have to edit my calendar on my MacPro and then sync.  I know I will be double booked on an apt. or I will miss an apt before this is all over.  Not good.  Help somebody

  • AgentReem Level 1 (0 points)

    I figured it out. So you highlight the event and go to EDIT, then DELETE. It doesn't give you the option like other appointments from the appointment, but it does allow you to delete it by having to go through that extra step... but easier than many steps like above. :-)