Previous 1 2 Next 16 Replies Latest reply: Oct 4, 2012 1:38 PM by ellebea
leonafan Level 1 Level 1

Help please?

My iMessage displays my email address and not my mob number, I've tried turning it off and on via settings but it doesn't make any difference

  • Malignance Level 4 Level 4
    expertise.iphone
    iPhone

    Try this:

     

    Settings>Messages>Recieved At>Caller ID

     

    Then select which one you want displayed.

  • leonafan Level 1 Level 1

    It's set to my mobile number

  • Rever3nce Level 1 Level 1

    If the other person using imessage has their settings to display their email, then on your end , it will still show the email and not the telephone number.

  • leonafan Level 1 Level 1

    The strange thing is its everybody's that shows my email address

  • Malignance Level 4 Level 4
    expertise.iphone
    iPhone

    To be clear, it only shows your email when YOU send message as if it's sending from your email?

  • Rever3nce Level 1 Level 1

    Try turning imessage "off" and then back on?

     

    Also try doing a reset. That may just clear things up.

  • Malignance Level 4 Level 4
    expertise.iphone
    iPhone

    Verify your phone number is registered with apple, if it is not iMessage will use your email as default. Do this by viewing your apple ID by going:

     

    Settings>Messages>Receive At>Apple ID: your mail here

     

    select View Account and enter your password. Scroll down to Security Info and click the details button, this will open Safari, enter your Apple ID and password.


    When the page loads you will see, on the left side, an option for Phone Numbers, select it and verify that your number is there and correct.

     

    You can then sign out at the top right hand corner of the screen. Go back to Settings>Messages and turn iMessage off and the back on. iMessage should send from your mobile number.

  • leonafan Level 1 Level 1

    Just tried this, still shows email address? And tried turning off and on and all settings show my mobile number. When I send the message everyone else sees my email address, when they message back I get the name linked in contacts to that mobile number

  • katherinealicefield Level 1 Level 1

    I have the same problem as leonafan but I've tried doing all of the above and it still uses my email instead of my mobile number, even though I have selected my mobile number in settings. Any ideas on how to solve it?

  • Melis2012 Level 1 Level 1

    I'm having the same issues, and to top that off it sometimes sends texts to my e-mail now??

    I did all the same things everyone else has suggested, and it still happens with some contacts.

     

    One thing i would suggest that did fix the problem with some contacts is to tell the person you are messaging to delete your conversation (at both ends, so you need to delete the convo too) and start a new one... that did fix it mostly for me,

     

    That being said, i still do get texts to my email :S  Does anyone have a suggestion for that?

  • leonafan Level 1 Level 1

    I'm still having the issue, the caller id is my phone number but shows at other end as email address

  • Melis2012 Level 1 Level 1

    Try it out with one friend, delete your conversation with them and ask them to do the same... Then ask them to start new conversation with u and send a txt to your cell #.

  • Nikkid76 Level 1 Level 1

    I have exactly the Sam symptoms on my iPhone but none of the solutions seem to work. Has everybody fixed their problem now?

  • santamarianovella Level 1 Level 1

    Hi all.

     

    Thought I'd post a solution since I've been having the same problem and could not find the answer here. Think I figured it out.

     

    I had logged into iMessage from my iPad using my email address, but iMessages from my iPhone were also showing up as coming from my email address. I figured it was an issue with having iMessage activated on my iPad, but deleting everything, logging out from iMessage on the iPad, hard restarting, etc did not fix the issue.

     

    Choosing Caller ID in Settings didn't work for me. Could not delete my email address. Then I realized that even though I had never logged in to iMessage from my phone, I had to log out from it. I just tapped my email address at the top of the Messages screen, chose "Log out from iMessage" and my Caller ID immediately switched back to my phone number.

     

    If you've logged into iMessage using your email at any time on any device, this may solve your issue.

     

    Cheers!

Previous 1 2 Next