7 Replies Latest reply: Jun 4, 2012 8:04 PM by rjpett
rjpett Level 1 Level 1 (0 points)

I have a 10 month old imac running lion.  we have 4 users set up.  From 3 of the 4 profiles, when photos (jpegs) are downloaded, they appear in our shared iphoto library as thumbnails, but cannot be opened by any user, even from the profile used when downloaded.


iMac, Mac OS X (10.7.4)
  • RRFS Level 5 Level 5 (4,490 points)

    The one user that can open the pictures is that where the Library is located? Have you enabled sharing in iPhoto Preferences for all the Users? When the disabled users start iPhoto with the "Option" key held can they select theLibrary that is functioning?

  • rjpett Level 1 Level 1 (0 points)

    RRFS thanks for the reply.  Photo sharing is enabled in all profiles.

     

    When we purchased the mac, we jumped from a pc to it, and my photo library was brought over into iphoto.  Then we set up the other 3 users (my wife and 2 kids).  Those users couldn't see my library, and the Apple store assisted in making the single iphoto library 'shared'   As I understand it, there is only one library, and it is the same one initially established.  When one of the other users logs in and opens iphoto, it opens that same library.

     

    All users can see all the photos in it, but if one of the other users downloads a camera or ipod while logged in under their profile, the images show up in the library (as thumbnails) but when you click to open they default to a gray image with an exclamation point.  No error message or anything - just won't open.

  • rjpett Level 1 Level 1 (0 points)

    I have tried each profile with the option key held - there are 'libraries' there for each user, but they are empty and the default is the shared library.

     

    Any thoughts ?

  • RRFS Level 5 Level 5 (4,490 points)

    Try a "Rebuild" of the Library for the disabled users.

     

    iPhoto Rebuild

     

    http://support.apple.com/kb/HT2638

  • rjpett Level 1 Level 1 (0 points)

    Rebuild didn't do the trick  tried the apple store and spent three hours with the genius guys also  Bought an external and copied the entire photo library to it, and that didnt work either - disaster , really

  • Terence Devlin Level 10 Level 10 (129,440 points)

    the images show up in the library (as thumbnails) but when you click to open they default to a gray image with an exclamation point.

     

    The ! turns up when iPhoto loses the connection between the thumbnail in the iPhoto Window and the file it represents.

     

    Option 1

    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Choose to Rebuild iPhoto Library Database from automatic backup.

     

    If that fails:

     

    Option 2

    Download iPhoto Library Manager and use its rebuild function. This will create a new library based on data in the albumdata.xml file. Not everything will be brought over - no slideshows, books or calendars, for instance - but it should get all your albums and keywords back.

     

    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one. .

     

    Regards

     

    TD

  • rjpett Level 1 Level 1 (0 points)

    Terence - Thanks again.  I have created a copy of the library on an external, and I have tried to rebuild the original library as you suggest - rebuild went fine, but - no luck - same result for my son's downloads - can see the thumbnail but opening resuts in black screen / exclaimation point. 

     

    Regrettibly I think this is a software glitch in iPhoto and with the mac and thus my frustration evident in my other post.  The mac has permission restrictions built into multiple user profile setups, and the software will nevertheless seem to download, but doesn't really do so from a user profile which doesn't have permissions. (i.e. anyone other than the 'owner' of the library)

     

    It seems Apple recommends to avoid this to use an external, which is not permission protected.    See http://support.apple.com/kb/HT1198 

     

    Again, wish I'd been told this or found this 10 months ago when I went to set this up , not now after my son lost 400 images.

     

    With 'genius bar' assistance, I even examined all the master jpegs inside the iPhoto package.  The missing images simply don't seem to have downloaded, despite seeing the thumbnails.

     

    I'm just sayin' .....doesn't seem right to me.