1 2 3 Previous Next 31 Replies Latest reply: Nov 30, 2012 7:38 PM by TiredNGrouchy
garygladstone Level 1 Level 1 (5 points)

Hello, All:

 

After Lion upgrade I cannot get my  remote access program (Timbuktu) to show my desktop to remote users. The sleeping screen (not the hard drive) is set for "Wake for network access" and all other settings are checked and appropriate including an update to the newest Timbuktu 8.8.3.

 

The screen wakes from keyboard or trackball activity but not for incoming access.

 

Note: The remote user sees the frame for the desktop in Timbuktu but is shows a sleeping (dark) screen. The file and clipboard exchanges still work but the screen ignores the instruction to wake.

 

Access worked perfectly with Timbuktu until three weeks ago. Then it just sleeps like a teenager on Saturday morning unless tapped on the shoulder by a parent. Call-ins don't get answered.  ;-)

 

Any ideas would be dearly appreciated.

 

 

Thanks


iMac, Mac OS X (10.7.4)
  • 1. Re: Lion Won't Wake For Incoming Network Access
    Linc Davis Level 10 Level 10 (118,480 points)
  • 2. Re: Lion Won't Wake For Incoming Network Access
    garygladstone Level 1 Level 1 (5 points)

    Many thanks for the info on WakeOnLan. I did a look-around at comments and found that it's pretty good at what it does. All the comments were pre-Lion and  one reviewer says it didn't work with Lion.

     

    I'm willingto try it if it doesn't cause changes in any other settings and can be uninstalled cleanly of it doesn't work. Do you know if this is the case?

     

    Trouble is, I'm a low-tech guy and horrible at troubleshooting anything.

     

    ---GG

  • 3. Re: Lion Won't Wake For Incoming Network Access
    Linc Davis Level 10 Level 10 (118,480 points)

    It won't change anything. You don't even have to install it. Just drag it to the Trash if you don't want it.

  • 4. Re: Lion Won't Wake For Incoming Network Access
    garygladstone Level 1 Level 1 (5 points)

    After researching this issue I have discovered that a number of remote access software suppliers have had this problem AFTER the upgrade from Lion 10.7.3 to 10.7.4. That recent upgrade has something in it which corrupts the screen sleep settings for future wake-up activations.

     

    That is, once I have set my screen sleep to xx minutes before sleep activation, it will wake only on the first attempt from a remote user AND after that connection, the screen will sleep again as set BUT will never wake again when contacted from a remote user.

     

    Apple has offered many solutions, all aimed at other functions and settings. After 90 minutes on the phone with Apple, trying all of their suggestions, nothing worked.

     

    Then, after contacting a remote desktop developed and being told that their research indicated the fault is in the Lion 10.7.4 upgrade and that Apple as indicated to them that they will not be addressing the quirk in the future.

     

     

    The workaround appears to be this:

     

    Set screen sleep preferences to "Never Sleep" and use a screen saver to dim the screen leaving the computer open to receiving remote entry. It works. I chose the darkest, most minimal scree saver which starts after my setting of three minutes. It wakes when remote access is attempted.

     

    The software developers are trying to find a way to fix this because Apple says they aren't going to make changes to address the upgrade-induced glitch.

     

    Timbuktu (Motorola) is my software and they don't know what the solution is and are offering simple re-install solutions, which of course, don't do anything to address the issue.

     

    One other company, GoToMyPC has their engineers working on a solution for their software to address this issue.

     

    I'm finished being the commando on this issue and hope someone will advise Motorola that they are not addressing this issue with their current level of understanding of the problem.

     

    Good luck

     

     

    ---Gary

  • 5. Re: Lion Won't Wake For Incoming Network Access
    John iSight Level 1 Level 1 (0 points)

    Sorry Guys but WakeOnLan DOES NOT do the job with 10.7.4

     

    at least, it does not wake the Screen, which is the issue we all have with 10.7.4 and Timbuktu 8.8.3.

    I tried may different setup over our Lan with 5 mac all running 10.7.4 and WakeOnLan.

     

    I had to set Screen to never sleep and Computer to never Sleep, then set Screen Saver Black screen with time after 5 minutes

    this works fine, until Timbuktu is fixed or Apple address the issue in a next OS update.

  • 6. Re: Lion Won't Wake For Incoming Network Access
    ZeddybearCA Level 1 Level 1 (5 points)

    Too bad Apple didn't discuss with other software manufacturers before they made the screen wake change in 10.7.4. I use Timbuktu and have been burned by this. Anyone notice that Apple updated their Apple Remote Desktop software at the same time? I agree that the solution is to have the screen never to go to sleep and just use a screen saver. However, I have computers that sit idle for days and I hate the thought of all those screens being on. There *is* a way to remotely wake up a screen with 10.7.4, but you need to meet the following requirements:

     

    1. You must know the public IP Address (or DNS name) of the target computer. (DynDNS has a free service available for up to 2 hosts on dynamic IP Addresses)

    2. If you are using a NAT router, there must be a rule to allow TCP/IP on an external port number of your choice to port 22 of the target computer.

    3. Remote Login must be turned on in the Sharing pane of the System Preferences of the target computer and accessible by your user account. It must be an Admin account.

     

    If you can fulfill the above, then you can SSH with the Terminal into the target computer:

    SSH -p [external port number] username@hostname_or_IP_Address

     

    This command will wake the screen:

    sudo pmset -a displaysleep 0

     

    When you are finished working on the computer, you can open the Energy Saver pane of the System Preferences and change the sleep setting from the now Never back to the preferred interval. Or issue the command with the Terminal:

    sudo pmset -a displaysleep [time in minutes]

     

    Hope this helps someone.

  • 7. Re: Lion Won't Wake For Incoming Network Access
    John iSight Level 1 Level 1 (0 points)

    Thank you for the above work Around. FYI

     

    - Timbuktu Develloper, told me they expect Apple to fix it, if they don't , TB team will have to do it themselves.

    So there is a solution on the way, ...... few months !

  • 8. Re: Lion Won't Wake For Incoming Network Access
    garygladstone Level 1 Level 1 (5 points)

    Thanks for the suggestions.

     

    I have  subscribed to  DynDNS for years as a hedge against our frequent power outages and subsequent IP changes while I’m on the road

     

    This issue has nothing to do with that.  It has nothing to do (I’m told by T-2 and other developers) with port forwarding. It has everything to do with screen waking.

     

    When it comes to the terminal and making settings changes after every session, I just am not willing to do that. I own the proper software. I am not skilled enough to become an engineer just in case I need to grab a file or recipe off my desktop machine at home while visiting a friend. That’s a deal-breaker.

     

    The Screen Saver works just fine with a black screen and it wakes just as it did before Lion ate the wake-up service.

     

    Lord knows what will happen when Mountain Lion gets a hold of T-2.

     

    --GG



  • 9. Re: Lion Won't Wake For Incoming Network Access
    ZeddybearCA Level 1 Level 1 (5 points)

    Gary,

     

    I see your point exactly. I agree the issue has nothing to do with hostnames or port forwarding. I can appreciate your reluctance to change settings after every session. I posted the above as a rather clunky work around I found for using Timbuktu connecting to a Mac with 10.7.4 when the display was asleep.

     

    My beef is with Apple. They made a change to the wake up routine of the display and didn't give developers notice or time to revise their products, not to mention the legitimate users of those products. When 10.7.4 was released, there was also an update to Apple Remote Desktop Client 3.5.3. No doubt one of the changes was to revise the way the display was wakened on a remote Mac. ARD has no problem with a sleeping display. It is wakened as soon as contact is made.

     

    I actually like the fact that after putting the display to sleep via a Hotspot in 10.7.4, after 5 seconds a mouse movement will not wake the display. I keep my keyboard and mouse on a sliding drawer and sometimes sliding the drawer in after putting the display to sleep, there would be a small movement of the mouse; waking the screen. That annoyance hardly ever happens now.

     

    I doubt very much Apple will revert the system change and developers will need to fall in line with revisions of their products. Unfortunately, in my experience that's the way Apple does business.

     

    –ZB

  • 10. Re: Lion Won't Wake For Incoming Network Access
    garygladstone Level 1 Level 1 (5 points)

    I must admit that I don’t really know exactly what we are trying to protect by sleeping or darkening our screens.

     

    I remember that with a CRT there was ‘burn-in” to worry about.

     

    With a LCD, it’s not clear what the concern is from a mechanical point of view.

     

    Electricity costs aside, what are we hoping to accomplish by sleeping, dimming or “saving” our screens?

     

    Why isn’t a full black “screen saver” as good as screen sleep?

     

    I am using that workaround and it seems just fine to me but I don’t really know what’s being “saved.”

     

    As far as my limited understanding is concerned, I’m protected just as well with the workaround which allows remote access to Lion.

     

    I’d like to hear from anybody who can explain the “why” of screen sleep and screen saving.

     

    Do the desktop and laptop screens require the same level of management?

     

     

    Thanks.

     

    --GG


  • 11. Re: Lion Won't Wake For Incoming Network Access
    ZeddybearCA Level 1 Level 1 (5 points)

    I think we're straying from the original topic of this post, but here goes.

     

    From Wikipedia:

     

    "For LCDs, burn-in develops in some cases because pixels permanently lose their ability to return to their relaxed state after a continued static usage profile. In more typical usage profiles this image persistence in LCD is only transient."

     

    I prefer to have a display "sleep." This will put an energy-compliant display in a very low state of power consumption. If a display is using a black screen saver, it will continue to use the normal amount of power and produce heat. In these eco-conscious times, I'm very aware of the power consumed and the heat produced from a display. It's bad enough that a Mac cannot be put to sleep for remote access.

     

    Regards,

     

    ZB

     

    p.s. Please, no discussions about the accuracy of Wikipedia articles.

  • 12. Re: Lion Won't Wake For Incoming Network Access
    LEOinDC Level 1 Level 1 (55 points)

    On an LCD-based display, the backlight never turns off with a screen saver. Backlighting is turned off with screen sleep.

     

    There is a product called BlackenedPixels from b-l-a-c-k-o-p.com.

    From their website: "BlackenedPixels is a variation of the "basic black" screensaver concept. Not only does it turn your screen black, but it also powers down all the displays to keep the room cool and dark."

    MacUpdate reports the product this way: "BlackenedPixels is an improved version of the "black screen" ScreenSaver.  In addition to making your displays black, BlackenedPixels also trims the brightness control all the way down, allowing applications to run normally, but without the power consumption (and heat etc) normally associated with screensaver operation."

     

    However, it doesn't work under Lion.

     

    An alternative workaround for the Timbuktu/Lion wake screen glitch is to set screen sleep to never, set Screen Saver to never, and set screen brightness to zero. This way the backlight is turned off as well.

     

  • 13. Re: Lion Won't Wake For Incoming Network Access
    LEOinDC Level 1 Level 1 (55 points)

    Additionally, bumping the mouse, trackball or keyboard won't wake the screen and outwardly the computer appears to be powered off.

     

    A quick press on the keyboard brightness key and you're back in business.

  • 14. Re: Lion Won't Wake For Incoming Network Access
    vascularnerd Level 1 Level 1 (0 points)

    Hi Gary, Driven mad by no wake on Timbuktu Pro.  Solution was log in with Logmein which wakes computer then log out and sign in with Timbuktu Pro before computer sleeps again.  Usually use Timbuktu as much faster than Logmein.

1 2 3 Previous Next