1 2 Previous Next 23 Replies Latest reply: Oct 15, 2013 3:01 PM by ore69
sessionsnw Level 1 Level 1 (0 points)

Hello,

 

I recently purchased a imac from a guy who said that the early 2008 Imac 3.06Ghz only needed a new harddrive as he pulled his old harddrive to put into his new imac. When I installed a brand new WD 1.5Tb harddrive the computer would boot to apple screen then freeze after about 20 seconds. I ran in verbose script (command +v) and here is the action where it freezes. All new harddrives I have installed lion on before I placed into computer because computer would feeze if try to start in cd mode. 

 

SMC: smcreadkeyaction Error: smcreaddata8 failed for key MOTP (kSMCKeynotfound)

 

At first I thought it was the new harddrive so I replaced with another new harddrive and I still have the same error message. I took to the apple store to talk to the "Genius'" and they said it was the harddrive. So far I have replaced the imac with 3 new WD green 1.5 TB harddrives new out of the box drives and keep running into the same problem. This is starting to look more like a serious problem and hoping someone can help with some info. All other boot script looks fine. I am starting to think i got sold a imac with a bad logic board.

 

Here is the full error script

 

 

Waiting for DSMOS

SMC:: smcreadkeyaction Error: smcreaddata8 failed for key $num (kSMCKeynotfound)

SMC: smcreadkeyaction Error $Num kSMCKeynotfound (0x84) fkeyhashtable = 0x0

Previous shutdown cause:3

SMC:: smcinitHelper ERROR: MMIO regmap == NULL -fall back to old smc mode

NVDANV50HAL loaded and registered

Authresults for 00:22:75:6e:5f:68

Airport: rsn handshake complete en1

DSMOS has arrived

SMC: smcreadkeyaction Error: smcreaddata8 failed for key MOTP (kSMCKeynotfound)

 

Thanks in advance.


iMac, Mac OS X (10.7.4), 3.06Ghz 4gb Ram 24" early 2008 8,1
  • 1. Re: SMC: smcreadkeyaction Error
    BDAqua Level 10 Level 10 (116,480 points)

    What Mac was this installed from, sounds like it failed looking for something that might be on a different model... or is this maybe a Filevault install, since the only reference I can find for MTOP is password related...

     

    http://en.blog.guylhem.net/

     

    Do you have another Mac around with Firewire that you can boot into Target Mode, then boot this one using the Option key & see if it can boot from the t mode Mac's drive?

  • 2. Re: SMC: smcreadkeyaction Error
    sessionsnw Level 1 Level 1 (0 points)

    Tried that. I can see the Macintosh and Windows Partition on my Macbook Pro. Tried running Macintosh and same freezing occured at apple logo. I cannot check the boot command error in T MODE but I imagine it is for the same reason. Just for kicks I tried running the Windows Partition and error message "non bootable item please insert disk and press any key to continue". I know this works because of the bootcamp instalation that I use every day. I also I have install from Snow Leopard on a harddrive that was tried without success. Currently I am trying to use Lion. I installed this Lion from my macbook pro to the new hardrive and then installed into Imac. The reason is because when trying to intall from disk onto Imac, computer freezes at apple logo. If I have to install directly on the imac, any suggestions of how to do so?

  • 3. Re: SMC: smcreadkeyaction Error
    BDAqua Level 10 Level 10 (116,480 points)

    Put the MBP in t Mode with the iMac install Disc in the MBP, boot the iMac using Option key & wait for the Install Disc in the MBP to show up as a boot choice.

     

    Are you sure it's not a Green drive problem?

  • 4. Re: SMC: smcreadkeyaction Error
    sessionsnw Level 1 Level 1 (0 points)

    I have tried that before, but just to double check I tried that again. No Joy. I tried this process with a Seagate F series, still same error. I was able to (command-v) each process to watch the boot progress and it still errors out and freezes at the same point. Disk, External, Internal, T link, error keeps occuring at the same time within the boot/startup process. Everytime I get the dreaded apple spinning wheel freeze. I do not know what to do. Any other suggestions?

  • 5. Re: SMC: smcreadkeyaction Error
    BDAqua Level 10 Level 10 (116,480 points)

    Hmmm, what is the 2z691-****-A number on the Install Disc you used?

  • 6. Re: SMC: smcreadkeyaction Error
    sessionsnw Level 1 Level 1 (0 points)

    I am attaching a picture of the startup commands. Maybe I am totally missing something.

     

    /___sbsstatic___/migration-images/185/18547727-1.jpg

  • 7. Re: SMC: smcreadkeyaction Error
    sessionsnw Level 1 Level 1 (0 points)

    Great questions. Its a burned disk because Lion you have to download. I made a install disk from the lion download. I do not know where the disk install # would be at?

  • 8. Re: SMC: smcreadkeyaction Error
    BDAqua Level 10 Level 10 (116,480 points)

    Oh yeah, Lion has no such thing.

     

    Do you have a 10.6 Install disc to try? Twice the OS of 10.7 BTW.

     

    If you put this one in t mode And try to boot the other Mac off this FW Disk, does it work?

     

    Note, I'd ever use a "Green" drive as a boot drive, especially a Seagate.

  • 9. Re: SMC: smcreadkeyaction Error
    Silegue Level 1 Level 1 (15 points)

    Quick Question,

     

    Did you try resetting the SMC as it seems to have a trouble reading it ?

     

    I'll give you the link on how to do it

     

    http://support.apple.com/kb/HT3964

  • 10. Re: SMC: smcreadkeyaction Error
    sessionsnw Level 1 Level 1 (0 points)

    Kick me when I am down BDAqua!... SMC reset by unplugging... wating 15 seconds... plugging back in, yes that has been done way too many times to no success.

  • 11. Re: SMC: smcreadkeyaction Error
    sessionsnw Level 1 Level 1 (0 points)

    Anyone have any other suggestions?

  • 12. Re: SMC: smcreadkeyaction Error
    dztsys Level 1 Level 1 (0 points)

    hey there sessionsnw,

     

    you burned a torrent os x right?

  • 13. Re: SMC: smcreadkeyaction Error
    lylehm Level 1 Level 1 (0 points)

    Did the selling include the original OS X install DVD?

     

    Try running a long hardware test.

     

    http://support.apple.com/kb/HT1883

     

    Your original suspicion of a bad logic board may be spot on. Even with the boot from DVD failure you indicated, it might still be possible to load AHT.

     

    If you're unsure if the optical drive is functioning, you should be able to confirm it's working by inserting known good media and starting the errant iMac in Target mode - the DVD should appear on the connected host system.

     

    Sorry to hear you got a lemon. I wonder if the seller jacked it up when he removed the drive.

     

    Best of luck.

  • 14. Re: SMC: smcreadkeyaction Error
    sessionsnw Level 1 Level 1 (0 points)

    No this is not a torrent download. This lion install is from the ap store that I burned to disk. Several post will explain how to do this with lion. I have also tried it now with snow leopard with no luck.

1 2 Previous Next