9 Replies Latest reply: Jun 24, 2012 7:57 PM by javatoid
steveod1 Level 1 Level 1 (0 points)

My iMac loses it's wireless connection repeatedly. The only solution seems to be deleteing the wireless network from the Network Preferences, and then deleting the network password from Keychain. But I have to do this five or six times nightly. Help!


iMac, Mac OS X (10.5.1)
  • RRFS Level 5 Level 5 (4,490 points)

    If as your profile shows you are still at 10.5.1 use this combo update

    Mac OS X 10.5.8 Combo Update

    It may resolve your issue.

  • steveod1 Level 1 Level 1 (0 points)

    No, sorry. Need to update the profile. I'm using 10.7.1.

  • RRFS Level 5 Level 5 (4,490 points)

    Softwre Update would bring you up to 10.7.4 and there have been updates involving WiFi. Also here are some links to potential fixes:

    Troubleshooting wi-fi issues

     

    https://discussions.apple.com/docs/DOC-3421

     

    WiFi update 10.7.3

    http://support.apple.com/kb/DL1501

     

    Apple DNS Servers:

    208.67.222.222

    208.67.220.220

     

    Wireless Improvements

    Move the Base Station If interference is particularly bad in one part of your house or office, move the base station to another location. But this can be tricky if your AirPort base station has to connect to the broadband feed coming into the house and that feed happens to enter at a particularly interference-prone spot.

    Use the 5GHz Band Compared with the 2.4GHz band, the 5GHz band is practically empty. The newest AirPort Extreme Base Station is one of the few Wi-Fi base stations designed for home use that work in that 5GHz band. All of Apple’s Core 2 Duo laptops and iMacs (except the discontinued 17-inch 1.87GHz model) can also use the 5GHz band; with the build-to-order wireless option, so can the Mac Pro.

    To switch to the 5GHz band, launch AirPort Utility, select your base station, and switch to Manual Setup. Click on the AirPort button and select the Wireless tab. Select 802.11n Only (5 GHz) from the Radio Mode pop-up menu. Click on the Wireless Options button and select Use Wide Channels. Click on Update to restart the base station.

    Currently, no Mac-compatible adapters enable you to use the 5GHz band in older Macs or with older versions of OS X.

    These Firmware updates may or may not apply to your system, but may help with your particular problem.

    http://support.apple.com/kb/index?page=search&src=support_site.home.search&local e=en_US&q=keyboard%20firmware%20update

  • javatoid Level 3 Level 3 (670 points)

    I'm also having this problem. Currently I'm running 10.7.4, but it's been happening since Lion. I restart my iMac about 5 times a day just to re-establish a wireless connection.

     

    Note: Normally, my wi-fi icon shows about 20 networks in range. However, once I've lost the connection, it does not detect any at all.

     

    (I frequently need to restart for other reasons too: Failure to wake from sleep, frozen dock, loss of all Bluetooth connections, etc. All told, I need to restart this thing about 7 times every day. Remember when Macs just worked? I miss those days.)

  • javatoid Level 3 Level 3 (670 points)

    Additional note: My iPhone and iPad are also connected to the same network and do not lose their connections. I also have a crappy Dell running Windows 7 (for work) connected to the same network, and it has never lost its connection either. The problem is only with the iMac since upgrading to Lion.

  • steveod1 Level 1 Level 1 (0 points)

    Only solution for me, eventually, was to reload Lion from scratch. Did this at the Genius Bar, so that it didn't take all night this time.

  • RRFS Level 5 Level 5 (4,490 points)

    For some users deleting the network then reacquireing your network so settings are reset, then deleting any network not used in your preferred list and your system is at the top, unchecking "ask to join networks" and finally turning iPv6 off or setting to "local xxx" in your TCP/IP panel. Then Apply.

  • javatoid Level 3 Level 3 (670 points)

    RRFS wrote:

    ...

    To switch to the 5GHz band, launch AirPort Utility, select your base station, and switch to Manual Setup. Click on the AirPort button and select the Wireless tab. Select 802.11n Only (5 GHz) from the Radio Mode pop-up menu. Click on the Wireless Options button and select Use Wide Channels. Click on Update to restart the base station.

    ...

     

    I'm using Airport Utility 6.1 with Time Capsule, and my only options for Radio Mode are:

    • 802.11a/n - 802.11b/g/n (Automatic)
    • 802.11a/n - 802.11b/g
    • 802.11a - 802.11b/g

     

    I also don't see any option for "Use Wide Channels."

     

    I've tried all the other suggestions, and nothing has worked.

  • javatoid Level 3 Level 3 (670 points)

    Also tried creating a separate 5 GHz network, but that's far worse. My iMac can't hold on to that connection for more than 15 minutes at a time.