10 Replies Latest reply: Nov 5, 2014 8:35 PM by mfuller52654
alavata4 Level 1 Level 1 (0 points)

I clicked on File, Add to Library, and then when i choose the song, it doesn't go into iTunes


iPod touch (4th generation)
  • wiclee Level 5 Level 5 (6,950 points)

    Go to iTunes menu EDIT > PREFERENCES > ADVANCED Tab

    you may find iTunes Media file Location box is blank(sometimes this happens after an update).

     

    iTunes Media Folder.jpg

     

    If that is the case, click the change button and link it to your iTunes Media Folder as follows:

    Win 7 C:\Users\<username>\Music\iTunes\iTunes Media

    WinXP C:\Documents and Settings\<username>\My Documents\My Music\iTunes\iTunes Media

     

    However,if your Media Folder is not missing from the Advanced tab, proceed to repair your QuickTime:

    Control Panel >

    Add n Remove Progrms(XP)

    Programs n Features(Win7/Vista)

    highlight QuickTime, click CHANGE then REPAIR

    Restart Computer.

  • ed2345 Level 7 Level 7 (21,535 points)

    alavata4 wrote:

     

    I clicked on File, Add to Library, and then when i choose the song, it doesn't go into iTunes

    Find the file icon.  Right-click it and choose Open With > iTunes.

     

    If the file is compatible with iTunes, it will be added to your library and will start playing.

     

    If the file is not compatible, iTunes will "error silently," i.e. do nothing.

     

    Try it and tell us which case you get.  If it is the second, provide details about the song file.

  • Ellebellexox Level 1 Level 1 (0 points)

    Ugh I'm having the same issue... Very frustrating i have tried nearly everything.

    My files are all MPEG layer 3 audio (mp3)

    HELP!!

  • 19jaykors96 Level 1 Level 1 (0 points)

    I tried the right click and open with itunes option after having converted all my mp3's to .aac and iTunes didnt recognize them

  • turingtest2 Level 9 Level 9 (58,330 points)

    Perhaps these are permissions problems...

     

    Right-click on your main iTunes folder and click Properties, then go to the Security tab and click Advanced. If necessary grant your account and system full control to this folder, subfolders and files, then tick the option to replace permissions on child objects which will repair permissions throughout the library. This is the XP dialog but Windows 7 shouldn't be too different.

     

    AdvSecurity.png

     

    tt2

  • thomasinmla Level 1 Level 1 (0 points)

    I had this problem, simply quit iTunes and when re opened I was able to import the files

  • Bite Of The Apple Level 1 Level 1 (0 points)

    I had this problem just this morning. iTunes would not import folders or files.

    I fixed it by going to: Edit > Preferences > Advanced then ticked the box that says "Copy files to iTunes media folder when adding to library".

     

    I have to say I much preferred iTunes BEFORE this "update"

  • ChrisMeeks Level 1 Level 1 (0 points)

    I have this problem, trid to drag and drop songs in to the music folder and tried to add file to library but it doesn't import. When I right click on the song and ask it to play in iTunes it plays fine.

     

    I've checked and the media folder link is ok and I've repaired Quicktime but still not working.

     

    Help please

  • KyuzoMugenUndPanzer Level 1 Level 1 (0 points)

    I fixed this problem by simply changing compatibility (Windows 7).

    Set compatibility mode for Windows7.

    Then set the program to run in Administrator mode.

    This fixed the problem for me easily. I do not know much about Mac's though, I haven't fiddled around with it much.

  • mfuller52654 Level 1 Level 1 (10 points)

    In my case I had exported a file from Soundtrack Pro 3.0.1. I had to select Stereo 1,2 on the sub-mix before it could be imported into iTunes.

     

    Soundtrack ProScreenSnapz001.png