Previous 1 2 3 4 5 6 Next 85 Replies Latest reply: Sep 19, 2015 8:53 PM by ruscle1 Go to original post
  • lollypop852 Level 1 (0 points)

    thats what i did ...

  • spencercw Level 1 (0 points)

    Worked for me on 2013 rMBP with Mavericks.  Thanks.

  • screamingmeanie Level 1 (0 points)

    Turning the mute "on" before shutting down or restarting TOTALLY works perfectly for me too!.  No changing any settings, nothing!  Too simple and what a bummer that I've put up with this for 6+ years.


    Message was edited by: screamingmeanie

  • Kwales66 Level 1 (10 points)

    I use a small app called Startupsound - which allows you to control the volume or mute ( Works for Mt Lion not sure about Mavericks )

  • guymarb Level 1 (0 points)

    I keep earbuds plugged into the jack. Hit the mute button on the keyboard. (not necessary to hold during startup)


    Startup Mavericks.... no startup sound.


    Lot simpler than messing around with Terminal or third party software.


    (Computer is a Macbook Pro. No idea if this works on all models)

  • Wizard_Magic_Spell Level 1 (40 points)

    Darksouljp's tip worked for me. Interestingly,MuteCon has not added itself to Login Items (and I have not manually added it),yet it still silences that dreadful Mac noise at every restart. Brilliant!

  • Ruairelie Level 1 (0 points)

    For anyone interested, here is my step by step to turning off the default startup sound.  This builds on Hippomormor's posts back in October, filling in the gaps for basic users such as myself and adding a bit of context.  The context may not be perfect, but I'm running Mavericks 10.9.2 and this works.


    open terminal



    sudo vim /Library/Scripts/

    this creates a script file in a vim (editor) instance


    press ‘i’ this will allow you to enter or ‘insert’ text




    osascript -e 'set Volume with output muted'


    the first line means run this script in bash.  'bash' is a shell.  A shell is a program that takes your commands from the keyboard and gives them to the operating system to perform.

    the second line says “run the following statement 'set Volume with output muted’”.

    Applescript adopts a plain English approach and this string mutes the volume.  To unmute, which we’ll have to do below, the statement will change to ‘set Volume without output muted’.  I guess the plain English approach only goes so far.


    press ‘Esc’. This gets you out of the ‘insert text’ mode in the vim editor


    hold ‘Shift’ and press the 'z' key twice.  This gets you out of the vim editor and back into Terminal



    sudo nano /Library/Scripts/

    this creates  a file in the nano editor.  why use a different editor?  not sure.


    in your nano instance, type


    osascript -e 'set volume without output muted'


    - Press ‘control + x’ then ‘y’ then ‘enter/return’

    ‘control + x’ is the Exit command in the nano editor, ‘y’ for “Yes, please” and ‘enter/return’ to save it to the default chosen file (the one you’ve been editing)


    You’re back in Terminal


    sudo chmod u+x /Library/Scripts/

    press ‘enter’

    you’ll be asked to enter your administrator password


    then type

    sudo chmod u+x /Library/Scripts/

    I was not asked for another password


    then type

    sudo defaults write LogoutHook /Library/Scripts/

    press ‘enter’

    this tells the computer to run the mute-on script when logging out


    then type

    sudo defaults write LoginHook /Library/Scripts/

    press ‘enter’

    this tells the computer to run the mute-off script when logging in


    Close your Terminal window and restart your computer a couple of times and enjoy the silence.


    Hopefully this helps and works for you too.

  • FILIK Level 1 (0 points)

    Actually there is not a perminent solution for turning-off startup chime without third-part apps or writing some commands in terminal.


    If you do not want to use 3rd part apps and change some operation system files you have have two options;


    1. Press the mute key just before shutting computer down

    2. Hold the mute key while turning computer on.

  • Csound1 Level 8 (46,335 points)

    imicanada wrote:



    I have checked previous discussions. I think it ought to be user's choice to use it or not.

    It's not, if you feel like hacking your Mac to get rid of it Google for solutions, use at your owm risk.

  • cerene Level 2 (175 points)

    Remember people, Mac just works!

  • Csound1 Level 8 (46,335 points)

    cerene wrote:


    Remember people, Mac just works!

    Not if you are foolish enough to hack them,

  • LJLaValle Level 1 (0 points)

    A lot of steps, but worked!  I'm not comfortable with installing apps that do this for you, and was looking for a script instead.


    The nano script editor thing got me confused as I was reading your process, but was back on track when the nano editor popped up for me to see after typing the said line code.


    I'm running 10.7.5 on a late model 2006 imac.


    Thanks for the info!

  • Level 1 (0 points)

    the more I read this forums,the more fun i have... a sound to tell you critical things? really? what century is this? people are supposed to have evolved, and know how to read stuff. give a **** message, telling what is wrong, not a sound! who remembers sounds codes, multiple keyboard shortcuts an terminal commands? 21st century ...MG..

  • Csound1 Level 8 (46,335 points)

    You had to revive a 2 year old thread just so you could complain?


    Thanks for your contribution

  • humonster Level 1 (0 points)

    Hippomormor, could you help me please? After I have made the changes you mentioned I still have the startup sound but now my computer is totally mute:-) I mean no sound at all. Any suggestion how I set it back? My timeline is off so that is not an option.

    Thanks in advance!