Previous 1 2 3 4 5 Next 129 Replies Latest reply: Nov 21, 2015 10:05 AM by essandess Go to original post Branched to a new discussion.
  • essandess Level 1 (15 points)

    Welcome to UNIX sysadmin. It's probably X11 related. Are you running XQuartz? (Add XQuartz to your login items.) Try these troubleshooting steps:


    # X11 DISPLAY (bash) -- first user instance is :0, second is :1, and so on

    export DISPLAY=:0.0


    # X windows works?



    # wine works?

    sudo port install winetricks



    # try launching some non-clippy DOS program

    wine ~/.wine/dosdevices/c\:/windows/system32/wordpad.exe


    If these basic things don't work, Comskip won't work either. If they do, check your ETV logs in ~/Library/Logs. Google any error messages for any of these steps.

  • Ste88 Level 1 (0 points)

    Thank you!


    X windows was working fine, but my wine was not. I installed winetricks and ran winetricks -v (verbose) and found an identical problem here:


    I also found a similar fix - removing and recreating my .wine directory in my home directory and re-running winetricks. Wine automatically sets up your new .wine directory and everything - awesome!


    I tried comskip from the command line, identical to the command I pasted before and it is now busy analyzing the show I selected! Next, I'll try and get everything automated with, etc. I don't see why it won't work now.


    Thanks again,


  • Ste88 Level 1 (0 points)

    Yep, now WINE is installed properly, the automation works too. It's beautiful.


    Since EyeTV's 10-foot user interface is pretty dreadful and I use the AppleTV as my main media hub I use EyeTV's export feature routinely. The lack of a decent commercial skip (even 30 seconds forward!) was frustrating and this makes my evenings a lot more pleasant!


    Thank you.


    All the best,

  • essandess Level 1 (15 points)

    Glad that it's working so well. I haven't tested this against an Apple TV setup and I expected it to work across various configurations, so it's nice to hear that it does.


    And I know what you mean about EyeTV's UI!


    But I really like their iPad app, and use it turn iOS devices into satellite TVs. The last feature missing from this commercial skipping setup is to have the EyeTV app use the mp4 chapters in its streming, the way iTunes sharing works.


    If you find this code useful, the only thing I ask in return is to contact Elgato and make this feature request for their EyeTV app.  Here's my request:



    Dear Elgato,


    This is a feature request for your iOS EyeTV app.


    Would you please allow navigation using the embedded chapter markings in h.264 files, similarily to the functionality in iTunes Sharing?

  • chriser Level 1 (0 points)

    I believe that I've been properly following your steps for Moutain Lion, but I can't get ETVComskip to install. I've installed Xcode, Xquartz, and Macports and I've run "sudo port selfupdate" After that I get these two issues:


    1. When I run "sudo port install wine-devel" I get these error messages: "Warning: The Command Line Tools for Xcode don't appear to be installed; most ports will likely fail to build. Warning: See for more information.

    --->  Computing dependencies for wine-develError: Unable to execute port: can't read "build.cmd": Failed to locate 'make' in path: '/opt/local/bin:/opt/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin' or at its MacPorts configuration time location, did you move it?


    2. When I run "Install ETVComskip" from the "ETVComskip-2.0.2-10.6" dmg I get the following pop-up error: "The operation couldn't be completed. (OSStatus error 100030.)"


    Thanks for your help!



  • essandess Level 1 (15 points)

    Apparently Apple in its wisdom has removed basic command line executables from the latest Xcode rev. To troubleshoot general issues like this, just google the problem. In this case, "Xcode command line tools" leads to: So install the latest and try again. I don't know about your ETVComskip error—just make sure that you're using an admin account to install and if the problems persist after some reasonable sanity checks and googling, submit a ticket at the ETVComskip google code web page.

  • directtotim Level 1 (0 points)


    I was wondering how you made this process work automatically:

    Record -> Transcode -> Mark Commercials [ -> Export to iTunes]

  • bebopbillybobeep Level 1 (0 points)

    I've followed the discussion so far and installed everything, but I am getting this error:

    Screen Shot 2013-01-15 at 10.18.21 PM.png

    Any clues?

  • bebopbillybobeep Level 1 (0 points)

    I shoud mention that all of these files exist. I'm wondering if there is a permissions error?

    I have two hard drives. One, a SSD, has the OS on it and the other, a HDD, has the User folders. Comskipper is installed on the OS drive in /LibraryApplication Support/, but my EyeTV recordings are stored in my user folder on the other drive.


    ls -l /Library/Application\ Support/ETVComskip/ objc/
    -rw-r--r--@ 1 Jim  macports  659852 May 26  2010 /Library/Application Support/ETVComskip/ objc/
    ls -l /usr/lib/libobjc.A.dylib
    -rwxr-xr-x  1 root  wheel  2486784 Nov  4 01:05 /usr/lib/libobjc.A.dylib
  • essandess Level 1 (15 points)

    This has to do with some Python version error on your system. It's tricky to troubleshoot unless your sitting at your box, but I'll give some background and a few pointers. ETVComskip comes with its very own Python executable, so you shouldn't even be seeing this error. Emphasis on "should." The upside should be that ETVComskip is robust to changes in Apple and Macports Python versions. I don't know why or if ETVComskip's Python should be calling the system library in /usr/lib.


    Googling the error ("symbol not found" objc_sync_notify), shows that others have similar issues in Lion <>, though ETVComskip ran fine for me when I used Lion.


    I'd suggest these actions:


    0. Software update, and consider installing the apparently more robust Mountain Lion (though Lion should work fine with ETVComskip).

    1. Reinstall ETVComskip from scratch.

    2. Try the command line call


    /Library/Application\ Support/ETVComskip/


    That runs ETVComskip's python. Does that work?


    4. Spend a little time searching for a fix online, googling error messages.

    5. If you just can't get ETVComskip to run, post an issue on its google code page.

  • essandess Level 1 (15 points)

    Wait, it looks like you've installed an obsolete version of ETVComskip -- you should have python2.6 down in the guts, not 2.5. Here's what I see on my system:


    $ ls -l /Library/Application\ Support/ETVComskip/

    total 0

    drwxr-xr-x@ 6 essandess  staff  204 Jun  1  2010 python2.6


    Download and Reinstall the latest ETVComskip and try again.

  • bebopbillybobeep Level 1 (0 points)

    Ahh, yes...

    You are correct... Don't know how I missed that...

    Anyway, I downloaded and installed the latest version. I have to still test it and apply your improvements, but I don't get the error any longer.

    And FWIW, I am using 10.8 Mountain Lion...



  • rickfromwoodbury Level 1 (0 points)



    What do you mean in your instructions:


    Edit the file ./ to use WINE to run comskip.exe nicely. Grep for these changes:


    What does one do to Grep?



  • essandess Level 1 (15 points)

    What does one do to Grep?



    It means to use the FInd function of whichever text editor you're using to search for a string.

  • essandess Level 1 (15 points)

    I've released version 1.0rc2 with improvements for both functionality and performance. The latest version handles commercial skipping for EyeTV exports to the directory ~/Movies as well as to iTunes, uses the multi-threading capabilities of the latest releases of comskip, and improves the reliability of commercial skipping on older boxes (like my own) during back-to-back recordings.


    Here's the new help string and changes. Edit to suite your particular configuration.




    1. Go donate to Eric Kaashoek's website

       and download his latest HD-capable Comskip software from


    2. Install Xcode from the App Store, the latest Xcode Command Line Tools from, and Macports from

       For Mountain Lion, install Xquartz.


    3. Install ETVComskip from


    4. Install Kaashoek's comskip files within the directory

          /Library/Application\ Support/ETVComskip/comskip

       Make sure that the ownership/group/permissions are set exactly the same

       as the original ./comskip directory and files.


    5. Download this zip file and check that your iTunes TV Shows directory

       matches this setting at the beginning of ./

          iTunes_TV_Shows = '~/Music/iTunes Media/TV Shows'

       Edit ./ to match this, then run these commands as a sudoer:


    # Necessary Macports

    sudo port selfupdate

    sudo port install wine-devel mp4v2


    # Move these five files into their correct locations

    sudo install -B .orig -b -m 0644 ./comskip.ini /Library/Application\ Support/ETVComskip/comskip/comskip.ini

    sudo install -B .orig -b -m 0644 ./ /Library/Application\ Support/ETVComskip/

    sudo install -B .orig -b -m 0644 ./RecordingStarted.scpt /Library/Application\ Support/EyeTV/Scripts/TriggeredScripts/RecordingStarted.scpt

    sudo install -B .orig -b -m 0644 ./RecordingDone.scpt /Library/Application\ Support/EyeTV/Scripts/TriggeredScripts/RecordingDone.scpt

    sudo install -B .orig -b -m 0644 ./ExportDone.scpt /Library/Application\ Support/EyeTV/Scripts/TriggeredScripts/ExportDone.scpt


    comskip.ini (this is for my old dual-core -- change to how many cores you wish to use)


    thread_count=2                          ; multi-threaded processing




    -- EyeTV ExportDone script to use ComSkip to mark commercials in exports to iTunes and ~/Movies, and save exported file inode numbers as the text file filename.exported_inodes.txt for synchronization with


    -- 2013-01-29 1.0rc2: Handle exports to ~/Movies; Fix issues with multiple exports: extend iTunes delay, modify IsFileOpen to ignore Spotlight indexing, and use creation date

Previous 1 2 3 4 5 Next