Previous 1 2 3 Next 35 Replies Latest reply: Apr 20, 2016 4:59 AM by zanuski Go to original post
  • carali Level 1 Level 1

    Thank you, this solved my problem.

  • MeatyMcDoobert Level 1 Level 1

    Thank you dcperin1! Secure emptying of the Trash didn't work for me, but your terminal command did the trick

  • reybo Level 1 Level 1

    I got it when upgrading to OS X 10.6.8. JPEGs sent in email refused to be trashed.  The Secure Empty worked here and choosing that setting permanently also worked. I think.

  • Pendus Level 1 Level 1

    Thank you for your assist with the Terminal command.  That helped a lot!

  • ~ruud Level 1 Level 1

    The problem is caused by the "automatic termination" feature that Apple introduced in OSX Lion. The idea is that after an application is unused for a period of time, it will automatically "hibernate" to free up resources for other tasks. However, hibernated apps don't free up all resources (it keeps items in te trash locked) which means you cannot empty the trash. At the same time, these applications don't show as running on the Dock...

     

    I found that the inability to empty the trash is usually caused by a hibernated instance of the "Preview" application. It doesn't show as running in the Dock, but it does show running in the "Force Quit" screen (command-option-power or "Force Quit" in the apple menu). Terminating preview will release the items in the Trash. The only way i have found to solve this, is to disable the "automatic termination" feature. The result is that running applications won't disappear from the Dock, which means you can easily quit them from there (of course the real issue is that preview should release closed files, but this defect has been present since Mac OSX Leopard and has since never been solved...)


    To disable automatic termination, go to the terminal window and enter

     

    defaults write -g NSDisableAutomaticTermination -bool yes

     

    After this command, applications that are running, will show in the Dock. Which means you can easily see it's running in the Dock and quit it from there.

     

    To revert to the default behavior, go to Terminal again and enter

     

    defaults delete NSDisableAutomaticTermination

     

    This will enable the "automatic termination" feature again. Hope this helps!

  • NN2RL Level 1 Level 1
    expertise.icloud
    iCloud

    This makes total sense to me now. Thank you!!!

  • zanspiler Level 1 Level 1

    Thanks a lot!

  • Wolffender Level 1 Level 1

    Hey there! I tried this method for deleting this annoying bug w AppLocale not deleting and it worked! Thanks a ton ^w^ Guess I should take down my question now that it's been answered already here~

  • Butterbean123 Level 1 Level 1

    Bruce,

     

    Thanks, this worked!

  • sultanofhazard Level 1 Level 1

    Thank you!!!!

  • jen57 Level 1 Level 1

    ABSOLUTELY WORKS!!!!!  Thank you.  Ever so much better than trying to do the terminal commands. 

  • LorraineW418 Level 1 Level 1

    THIS WAS THE EASIEST WAY TO SOLVE THE ISSUE!!!

  • jlebomba Level 1 Level 1

    This worked perfectly. Thank you.

  • JoA59 Level 1 Level 1

    Closing terminal application did not work for me, because in my case,terminal had not been left open.  But what did work was to select each file individually and choose to "delete immediately'.  The files then deleted and I did not get the error message about them being open.  It was the easiest way to do it.

  • Pharming Level 1 Level 1

    Yes! Worked perfectly.  Other posts didn't help.  Thank you I thought there was something corrupt about the file.