Skip navigation

Option and C keys won't work after startup

1535 Views 7 Replies Latest reply: Jun 9, 2012 10:07 AM by sunnyjohn RSS
sunnyjohn Level 1 Level 1 (0 points)
Currently Being Moderated
Jun 6, 2012 2:56 PM

I have a Mac Mini running 10.7.4 via an LG E2250V monitor and a Logitech wireless keyboard and mouse. I am unable to get the option key to bring up the disk screen, or the C key to run an external disk after startup. I have scanned the forums and tried the following:

- used a wired keyboard and mouse

- run disk utility

- unplugged everything from the ports except the keyboard and disk drive

- zapped the PRAM

- run in safe mode

I shut down the Mini, wait ten seconds, start up and hold the option key down immediately after the chime. The hard drive runs down after about a minute and the fan goes berserk. I've tried keeping the option key down for ten minutes. Nothing. I've done the same with the C key. The EDD accepts Drive Genius 3 disk which run for about a minute, then stops, after which the hard drive stops and the fan goes berserk. Again, I've held on for ten minutes. Nothing. In all other espects the Mini, screen and keyboard works perfectly. I really would like the ability to run an external disk, for example, to use DG3. Any ideas?

Mac mini (Mid 2011), Mac OS X (10.7.3)
  • BDAqua Level 10 Level 10 (114,670 points)
    Currently Being Moderated
    Jun 7, 2012 11:47 AM (in response to sunnyjohn)

    Hi John, not sure but try this...

     

    Intel-based Macs: Resetting the System Management Controller (SMC)...

     

    http://support.apple.com/kb/HT3964

     

    SMC is the System Management Controller that handles Sleep, Wake, & other things!

  • BDAqua Level 10 Level 10 (114,670 points)
    Currently Being Moderated
    Jun 7, 2012 2:46 PM (in response to sunnyjohn)

    Wow, that's strange that it works on one & not the other!???

     

    Not sure where to go from here.

  • ds store Level 7 Level 7 (30,305 points)
    Currently Being Moderated
    Jun 7, 2012 6:56 PM (in response to sunnyjohn)

    sunnyjohn wrote:


    and my wired keyboard is a mac board but it is now ten years old

     

    Get a more recent wired keyboard or try one in the Apple Store would be the next move I guess.

     

    Didn't set a firmware password right?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.