Previous 1 2 Next 23 Replies Latest reply: Aug 11, 2012 5:03 PM by Pondini
cricket484 Level 1 Level 1 (0 points)

Over the past 10 days, the average duration of my Time Machine backups has gone from 1 minute to :42-:45 minutes. There's been no significant shift in my computing behavior during that time. To fix, I've tried nearly everything recommended in Pondini's terrific site -- can you see something that I've overlooked?

 

* iMac8,1 4GB, running OS X 10.6.8

* TM drive: Seagate GoFlex 1TB, 30 days old, was freshly formatted and 100% dedicated to TM; have tested both Firewire and USB; 356GB used

* Fusion virtual machines excluded from TM via Preferences

* no virus program running

 

Review of backupd items in system.log shows, after the first few weeks of speedy TM backups, a gradual decay -- can't pinpoint a cliff (that could be blamed on an installation, etc.) And there's no other TM-related messages ("deep traversal," etc) in the log. When I watch Activity Monitor during a TM cycle, I see low CPU usage by TM, and slow read/write speeds for disk activity.

 

Yes, I have:

* repaired permissions (frequently)

* done disk verify and repair on both internal and TM drives (nothing found)

* set drives to "no sleep"

* disabled Spotlight

* relaunched Finder (and, of course, rebooted the whole system)

* tested in Safe Mode (no improvement)

* run daily/weekly/monthly maintenance scripts and purged caches, using Cocktail (Ironically, it got dramatically worse yesterday after I did this!)

 

No, I have not yet reformatted the TM drive, nor reinstalled 10.6.8. Am I forgetting something else?

 

thx


iMac, Mac OS X (10.6.8)
  • steve626 Level 4 Level 4 (1,475 points)

    Can you post the lines from your system log that are equivalent to the ones I inserted below from my latest backup?

     

    Jun  6 19:50:12 imac /System/Library/CoreServices/backupd[1153]: Starting standard backup

    Jun  6 19:50:20 imac /System/Library/CoreServices/backupd[1153]: Backing up to: /Volumes/233.8 Maxtor/Backups.backupdb

    Jun  6 19:50:21 imac /System/Library/CoreServices/backupd[1153]: No pre-backup thinning needed: 394.5 MB requested (including padding), 148.38 GB available

    Jun  6 19:50:34 imac /System/Library/CoreServices/backupd[1153]: Copied 1089 files (1.2 MB) from volume Macintosh HD.

    Jun  6 19:50:35 imac /System/Library/CoreServices/backupd[1153]: Starting post-backup thinning

    Jun  6 19:50:36 imac /System/Library/CoreServices/backupd[1153]: Deleted backup /Volumes/233.8 Maxtor/Backups.backupdb/Imac/2012-05-07-193834: 148.38 GB now available

    Jun  6 19:50:37 imac /System/Library/CoreServices/backupd[1153]: Deleted backup /Volumes/233.8 Maxtor/Backups.backupdb/Imac/2012-06-04-203220: 148.38 GB now available

    Jun  6 19:50:37 imac /System/Library/CoreServices/backupd[1153]: Post-back up thinning complete: 2 expired backups removed

    Jun  6 19:50:38 imac /System/Library/CoreServices/backupd[1153]: Backup completed successfully.

     

    Of particular interest would be where the large amount of time got spent in your case? Such as pre backup thinning, time spent actually copying, and/or post backup thinning. Also, how much actually got copied? My backup above took only a few seconds, but only a small amount was being backed up. On my other computers, I see much longer times as the TM backup disk gets closer to full or when it has to sort through things to do lots of post backup thinning.

     

    One thing to do is verify or repair both your disks via Disk Utility or Disk Warrior. A file catalog problem can slow things down a lot, although I doubt you have this problem.

  • cricket484 Level 1 Level 1 (0 points)

    Thanks. Here you go:

     

    Jun  6 20:16:25 myname-imac-2 com.apple.backupd[564]: Starting standard backup

    Jun  6 20:16:25 myname-imac-2 com.apple.backupd[564]: Backing up to: /Volumes/iMac Time Machine/Backups.backupdb

    Jun  6 20:18:22 myname-imac-2 com.apple.backupd[564]: No pre-backup thinning needed: 955.3 MB requested (including padding), 599.07 GB available

    Jun  6 20:34:34 myname-imac-2 com.apple.backupd[564]: Copied 32012 files (150 KB) from volume Macintosh HD.

    Jun  6 20:36:58 myname-imac-2 com.apple.backupd[564]: No pre-backup thinning needed: 955.4 MB requested (including padding), 598.97 GB available

    Jun  6 20:52:42 myname-imac-2 com.apple.backupd[564]: Copied 18467 files (409 KB) from volume Macintosh HD.

    Jun  6 20:56:01 myname-imac-2 com.apple.backupd[564]: Starting post-backup thinning

    Jun  6 20:59:48 myname-imac-2 com.apple.backupd[564]: Deleted backup /Volumes/iMac Time Machine/Backups.backupdb/myname’s iMac/2012-06-05-200133: 599.07 GB now available

    Jun  6 20:59:48 myname-imac-2 com.apple.backupd[564]: Post-back up thinning complete: 1 expired backups removed

    Jun  6 20:59:49 myname-imac-2 com.apple.backupd[564]: Backup completed successfully.

     

    Lots of time spent in the copying, and seems like a lot in the post-backup thinning.

     

    I have done disk repair via Disk Utility, thanks. No help.  Other ideas?

  • steve626 Level 4 Level 4 (1,475 points)

    Did you check both the source and destination disks with Disk Utility? (I'll assume yes.)

     

    Have a look at this

     

    http://Pondini.org/TM/D2.html

     

    and this

     

    http://Pondini.org/TM/D8.html

     

    for lists of conditions that can cause trouble. Virtual machines are known to be problematic, although you say you excluded your virtual machine. You seem to be backing up many many small files, could that come from the virtual machine even if you exclude the big file(s).

     

    Are you running any anti-virus software? Or disk protection software that runs in the background (such as the kind Tech Tool Pro provides)? These background programs, unless told to exclude the backup disk, might slow down the backups.

     

    I'm curious is Time Machine can run when you do a Safe Boot. If it can, then you might try that, as the Safe Boot disables most extensions. If the Time Machine backup goes fast, then that gives you a clue to look at your background processes or extensions that might have been disabled by the Safe Boot.

  • cricket484 Level 1 Level 1 (0 points)

    Thanks for all these suggestions.  Yes, I did check both source and destination disks. Nope, no anti-virus or disk software in the background. I've been through the Pondini D2 and D8 checklists -- the only thing I haven't tried yet is reinstalling Snow Leopard combo.

     

    I agree, it's a mystery, the umber of small files.  When I look at the backup using Time Tracker, I see most of it consumed by Safari history.plist.  There's nowhere near the "thousands" of files that the system log would suggest. And there's no evidence of virtual machines or Lightroom or other hogs.

     

    Time Machine *can* run in Safe Boot, but not without a lot of protests about attributes in the logfile, and it takes just as long. So I'm still stumped.

     

    I've turned TM off for now -- with only 10 minutes elapsing between the finish of one backup and the start of the next, I have trouble creating anything for it to chew on!

  • ds store Level 7 Level 7 (30,320 points)

    Use a Cabon Copy Cloner clone, then you can schedule it how and when you wish.

     

    Plus it's option key bootable in case your boot drive dies you can use that right away.

     

    Most commonly used backup methods

  • Craig Patton Level 1 Level 1 (5 points)

    I've noticed the same slow back-ups (though not as bad as yours) and have been through Pondini's tips with no success. The last straw I grasped was running applejack (fantastic command line utility) from a single user start up. Running applejack in "auto" mode will bring the Time Macine back-ups down from 12 minutes to a blistering 20 seconds.  However, in my case at least, it won't stay there.  After a week or so the back-ups start creeping up and get to 10 or 15 minutes again.  Haven't been able to find a permanent solution.  Would much appreciate any help.

  • iPille Level 1 Level 1 (0 points)

    Hi there

     

     

     

    The same problem here:

     

    17.07.12 17:17:17          com.apple.backupd[12749]          Starting standard backup

     

    *means: com.apple.backupd[12749]

     

    17.07.12 17:17:17          *          Starting standard backup

    17.07.12 17:17:17          *          Backing up to: /Volumes/TIME MACHINE/Backups.backupdb

    17.07.12 17:17:48          *          No pre-backup thinning needed: 703.6 MB requested

                                                      (including padding), 1.37 TB available

    17.07.12 17:22:43          *          Copied 34006 files (639 bytes) from volume DATEN.

    17.07.12 17:23:54          *          No pre-backup thinning needed: 704.0 MB requested

                                                      (including padding),1.37 TB available

    17.07.12 17:27:14          *          Copied 10482 files (639 bytes) from volume DATEN.

    17.07.12 17:29:47          *          Starting post-backup thinning

    17.07.12 17:33:29          *          Deleted backup /Volumes/TIME MACHINE/Backups.backupdb/

                                                      pmg5/2012-07-03-121520: 1.37 TB now available

    17.07.12 17:37:05          *          Deleted backup /Volumes/TIME MACHINE/Backups.backupdb/

                                                       pmg5/2012-07-03-114951: 1.37 TB now available

    17.07.12 17:37:05          *          Post-back up thinning complete: 2 expired backups removed

    17.07.12 17:37:06          *          Backup completed successfully.

     

     

    Many years everything with TimeMachine was fine. No problems, no effort. Works quiet and effectiv in the background.

     

    2 months ago I recognised first changes. TM needs long and longer. Thousands of files - big number with low volume - TM copied to my external HDD. "Preparation" and "reworking"  take a long time.

     

    I controlled the backup with TimeTracker - a much smaller number of files was listed.

     

    I read other threads:

     

    https://discussions.apple.com/thread/3144862?start=15&tstart=0

     

     

    and jump to Pandinis website. No success with this.

     

     

     

    So long

     

    iPille

  • Pondini Level 8 Level 8 (38,715 points)

    We've seen a small number of folks on 10.6.8 with slow backups and very large numbers of files reported.  After trying all the other fixes, it appeared to be a problem with their installations of OSX.

     

    Some of them reported fixing it by installing the 10.6.8 "combo" update, per Installing the ''combo'' update and/or Reinstalling OSX.  If that didn't help, installing a fresh version of OSX (that won't disturb anything else), per the same article, often did.

     

    A very few reported that didn't help; but reinstalling OSX again, then only going back to 10.6.7, instead of 10.6.8, did.

  • iPille Level 1 Level 1 (0 points)

    Hello Pondini,

     

    thank you for your advice. I'll try "combo" update today or at the weekend and give later a feedback.

     

    Bye iPille

  • iPille Level 1 Level 1 (0 points)

    Here we are:

     

    Installing the "combo" update 10.6.8 was not enough.

     

    Today in the afternoon I've installed a fresh OS X and after that only the "combo" update 10.6.7.

     

    TM works perfectly no:

     

    20.07.12 22:01:34 *          Starting standard backup

    20.07.12 22:01:34 *          Backing up to: /Volumes/TIME MACHINE/Backups.backupdb

    20.07.12 22:01:34 *          Detected system migration from: /Volumes/SIK BOOT

    20.07.12 22:01:34 *          Event store UUIDs don't match for volume: DATEN

    20.07.12 22:01:34 *          Node requires deep traversal:/Volumes/DATEN

                                                reason:must scan subdirs|new event db|

    20.07.12 22:02:18 *          No pre-backup thinning needed: 797.8 MB requested

                                                (including padding), 1.37 TB available

    20.07.12 22:02:53 *          Copied 3443 files (31.1 MB) from volume DATEN.

    20.07.12 22:02:53 *          No pre-backup thinning needed: 760.5 MB requested

                                                (including padding), 1.37 TB available

    20.07.12 22:02:53 *          Waiting for index to be ready (100)

    20.07.12 22:02:58 *          Copied 465 files (28 bytes) from volume DATEN.

    20.07.12 22:03:01 *          Starting post-backup thinning

    20.07.12 22:03:01 *          No post-back up thinning needed: no expired backups exist

    20.07.12 22:03:01 *          Backup completed successfully.

     

    * = com.apple.backupd[431]

     

     

     

    At 20.07.12 22:02:58 many files with small volume, but much better then before.

     

     

    Thank you for your help 

     

    Greetings from Germany

     

    Bye iPille

  • Pondini Level 8 Level 8 (38,715 points)

    iPille wrote:

    . . .

    At 20.07.12 22:02:58 many files with small volume, but much better then before.

    Yay! 

     

    Those many files seem to count metadata (extended attributes, some creation/modification dates, and possibly permissions and ACLs, separately).  The counts are always high, just not ridiculous as you were seeing before.

     

    I do need to warn you about one nasty bug that wasn't fixed until 10.6.8; if you run Verify Disk on your internal HD, that will prevent TM from finding anything to back up.  But it will report a completed backup!  Fortunately, a Restart will fix it.  See the 3rd item in #D5 of Time Machine - Troubleshooting.

  • iPille Level 1 Level 1 (0 points)

    OK, the latest TM backup has only lasted 15 s. Nice!!!

     

    Almost 500 files.

     

    Thank you for your advice on this bug.

     

     

    Bye iPille

  • Pondini Level 8 Level 8 (38,715 points)

    iPille wrote:

     

    OK, the latest TM backup has only lasted 15 s. Nice!!!

    Great!

     

    Glad it helped you; it doesn't seem to work for eveyone.

     

    Another of Time Machine's many mysteries . . . .

  • Craig Patton Level 1 Level 1 (5 points)

    As I mentioned earlier, running AppleJack on the main drive really accelerates TM backups (ecxept for the very first one after AppleJack which takes quite a while), but seemed a temporary fix.  It appears that the third time was the charm.  Since running AppleJack for the third time, backups are staying in the 20 sec to 1 minute range and the file count is much lower (no more of the 18000 files, 600KB stuff). Keeping my fingers crossed. Would love to hear ideas on why AppleJack helps.

     

    Craig

     

    Hardware Overview:

     

      Model Name:          iMac

      Model Identifier:          iMac8,1

      Processor Name:          Intel Core 2 Duo

      Processor Speed:          3.06 GHz

      Number Of Processors:          1

      Total Number Of Cores:          2

      L2 Cache:          6 MB

      Memory:          4 GB

      Bus Speed:          1.07 GHz

      Boot ROM Version:          IM81.00C1.B00

      SMC Version (system):          1.30f1

     

    System Software Overview:

     

      System Version:          Mac OS X 10.6.8 (10K549)

      Kernel Version:          Darwin 10.8.0

      Boot Volume:          Ext 500

      Boot Mode:          Normal

      Secure Virtual Memory:          Enabled

      64-bit Kernel and Extensions:          No

      Time since boot:          6 days 21:10

Previous 1 2 Next