Skip navigation

Unable to Connect to wifi problem - Solved for me

15908 Views 9 Replies Latest reply: Oct 29, 2013 8:32 AM by Uzair 98 RSS
Jindokae Level 1 Level 1 (5 points)
Currently Being Moderated
Jun 7, 2012 10:57 AM

Since updating to 5.1.1 on my iPad 3, I've been plagued with "Unable to Connect" (UtC) messages on my home wifi network.  I tried the "forget the connection" workaround but it always came back.

 

I fixed the problem permanently by allocating DHCP reservations for the iPad.  What I found out is that it was trying to request the same IP it last had time (via DHCP), and when it was sent a DHCPNACK from the router it just quit trying and flashed the  UtC message.  It was tryng to take an IP that it had at one time but was now assigned to another device.   It should have been able to get the next available IP but for some reason it didn't do that.  Looks like a bug to me.

 

If you keep gettng the "Unable to Connect" message for no apparent reason, try setting up a reserved IP address for your iPad that lies outside the range of addresses your router gives out automatically.  That should prevent any conflicts with other devices.

iPad, iOS 5.1.1
  • Texas Mac Man Level 8 Level 8 (44,245 points)
    Currently Being Moderated
    Jun 7, 2012 2:36 PM (in response to Jindokae)

    Thanks for posting. May help other users with the same problem.

     

     Cheers, Tom

  • Krin-Kran Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 7, 2012 4:17 PM (in response to Jindokae)

    Hi Jindokae,

     

    I've had the same problem and have been driving myself up the wall trying to resolve it. A few days ago, I unplugged my modem and wireless router when moving around some furniture. When I plugged them back in, my MacBook connected to the internet again with a simple restart, but my iPad and iPod are recognizing and joining the wireless network, but are not connecting when I try to connect through Safari, email etc. I get the message "Safair cannot open the page because it is not connected to the internet."

     

    I reset the network settings. I restarted both devices. I did the "forget this network" route. I even erased all content and settings on my iPhone- nothing worked. I reset the router- again, it didn't work. Tried Airplane mode- which has worked for some others on the forum, but unfortunately not for me.

     

    I'm not much of a computer person, so I'm hoping you can enlighten me on the steps involved in your solution. How do I go about setting up a reserved IP address for the iPad? Is this through the router?

     

    Thanks for your help!

  • dmrdsm Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 7, 2012 5:55 PM (in response to Jindokae)

    I have had problems for one week. Did everything Apple recommends and about everthing else I read. 

     

    Have been to the GB three times at the Apple Store.  Today, I have come home with a different IPAD, fully wiped out, and not backed up with any info from the Cloud.  So started from scratch  (two TV's, 2 phones, laptop, desktop, all work fine...and so did the IPAD since lauch)

     

    Still not working.  I have no idea of how to do what you say to do, but guess I'll have to figure it out and give a try.

     

    (This replacement IPAD, they swear is new, although when I look up the serial number it's a production week 5 where mine was a production week 10.  So I'm wonder if it is refurbished)

     

    I assume every router is different, so you're not able to give us anymore tips, but if you can, that would be great.  Thank you.

  • Krin-Kran Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 8, 2012 7:59 AM (in response to Jindokae)

    Thanks so much for taking the time to help me with this. I will give it a go, although, I'm afraid my router is a little outdated. I was looking into it and the last firmware available for it was posted in 2007- lol! Hopefully I can get some instructions on-line that pertain to this ancient model.

     

    Thanks again Jondokae!

  • dmrdsm Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 8, 2012 6:27 PM (in response to Jindokae)

    Thank you for taking the time to provide more details.  Will have to find the time to try this out.

     

    You'd think the Genius Bar people and Apple would take the extra time to figure this out and post something other than the routine  stuff they have posted for the past two years.    I wonder how many people like myself they give a new iPad to when they didn't even need to.  I went back to the store within 3 hours to get my old one back, but they said they had already shipped it out. What a waste.  I was bummed.

     

    Appreciate your time.  Thank you.  

  • Uzair 98 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2013 8:32 AM (in response to Jindokae)

    Hi Jindokae i bought a new ipad 3 it was on ios 5 i updated it to ios 7 but after the update i cant connect to my home wifi network but it connects with my friends wifi i didn't understand your this method can you please send me another simple and appropriate method.......Thanks..I am waiting for your reply

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.