Previous 1 2 3 Next 35 Replies Latest reply: Oct 3, 2014 9:26 AM by Kelly Wilkerson Branched to a new discussion.
Duvno Level 1 (0 points)

I've recently restored my iPhone to its original settings and now I'm trying to restore my latest backup and it doesnt work. The message that I get is 'iTunes could not restore the iPhone because the backup was corrupt or not compatible with the iPhone that is being restore'.


Note: I backed up the file the day before restoring it to its original settings so I do not think that compatibility is an issue.


Thanks for any help.

iPhone 4S, iOS 5.1.1
  • KC7GNM Level 4 (2,755 points)

    What probably happened there was a problem backing it up and it got corrupted. You may be out of luck unless you had an earlier backup that you can chose from.

  • Malignance Level 4 (3,375 points)

    If the backup you did before the restore is corrupt you could try to restore from your last sync. When selecting which backup to restore from your last sync will just show the device name without a date/time stamp. it may be out of date but it will be better then starting over.

  • AnanZjo Level 1 (0 points)

    Same Problem , no Luck


    even the when used the icloud backup it only restores an old copy not the most recent one and i don't know why

  • cable40D Level 1 (0 points)

    Same problem, all important notes is gone must be bugs within iOS

    When I sync my iphone to iTunes, it shows backup completed and how come it was corrupt during restore.

  • Franck CA Level 1 (0 points)



    I solved it !!


    I had the same problem : can't restore a previous backup, even using right click on my iphone in Itunes.

    I had a good backup in the directory :


    C:\Documents and Settings\myuser\Application Data\Apple Computer\MobileSync\Backup


    but Itunes didn't detect it.


    So I copied the full "Backup" directory in another location (copied, not moved)

    Then I create a new iphone with Itunes after restoring ipsw file, given the same name as it has previously.


    I did a sync+backup.


    At the end I checked the "Backup" directory and saw that Itunes recreated the same folder as the one I had copied earlier.


    This time in Ituens when I right click my iphone, I have the menu "restore from backup". But before select this option, I just renamed the new created directory in Backup to xxx.old , and copy back the saved one (the one with same name) into the C:\Documents and Settings\franckca\Application Data\Apple Computer\MobileSync\Backup directory.


    When the restoration was done, I recovered my last backup.


    Hope this helps.


  • Mike Brutvan Level 1 (5 points)

    i'm having a similar problem with a new iPad on a Mac -- i can't get older backups to restore any better than new ones, and it typically takes half an hour to fail, while maxing out all available RAM (on Mountain Lion).


    I am trying to restore from backup in order to clear off 11GB of phantom ("Other") memory use on the iPad that is probably left over from apps dying with large undeleted work file data remnants. 


    anybody get the above solution to work?  i haven't gone to the level of restoring to factory defaults if i can't be assured of getting back the several hours of preferences that would be lost if i can't restore from backups.  i have about 1GB of data free on a 64GB iPad -- i can start deleting music or movies to free up space, but that's really beside the point when there is more than 1/6 of the available space lost to garbage, which is growing every time i sync the device....


    the latest restore attempt just failed with the same error message as before


    any help?

  • simon.menzies Level 1 (0 points)

    Hi Franck CA I'm having the same problem there has just been an update to iTunes so it appaers the problem hasn't been dealt with as it's still occuring.

    Where abouts do i go/click to get to the location:-


    C:\Documents and Settings\myuser\Application Data\Apple Computer\MobileSync\Backup ?




    P.S do apple themselves read these pages anyone know?

  • simon.menzies Level 1 (0 points)

    P.s i use a Mac.


  • Franck CA Level 1 (0 points)

    Hello Simon,


    I do not use Mac to sync my IOS device. But did you try into the following location :






    /Volumes/<your_Macintosh_HD>/Users/<your_user>/Library/Application Support/MobileSync/Backup


    To go into those folders, use the "Go" menu in Finder (while your press the "Alt" option key). You'll see the Library icon appearing in the list, and just click on it, and navigate to subfolders.


    Hope this helps.

  • 3IPP3 Level 1 (0 points)

    Franck, you are the MAN!

  • Sheetal555 Level 1 (0 points)

    Hi Frank


    I am having the same issue with my iphone. I was updating my software to iOS 6 and during the restoration process, everything was only restored until the 16 August, even though I did a backup just prior to updating the software to iOS 6.


    I am trying to follow your instructions and am able to find the folder "Apple Computer" but there is nothing in there called "MobileSync" and so cannot proceed with the rest of your steps.


    Do you have any suggestions?


    Thank you for any assistance

  • Franck CA Level 1 (0 points)

    Hi Sheetal555,


    Are you using Windows 7 ? Vista ? Or Windows XP ?

    My original post was for XP.


    In Win7/Vista the location of "Apple Computer" folder are multiple, in the user space.

    You can find "Apple Computer" folder in :


    • C:\Users\my_user\AppData\Local\Apple Computer
    • C:\Users\my_user\AppData\LocalLow\Apple Computer
    • C:\Users\my_user\AppData\Roaming\Apple Computer


    Try in all of those folders.


    NOTE : I remember it is same locations for MS Vista, if this is your OS ?


    Another suggestion would be to unhide all invisible files and system files using the following procedure, and then do a search "backup" using "Agent Ransack" tool :


    1. Open the Control Panel (icons view).

    2. Click on the Folder Options icon.

    3. Follow "option 1" of the following URL :


    Agent Ransack tool can be found here :




  • Sheetal555 Level 1 (0 points)

    Hi Franck


    Thanks for your reply.


    Yes I am running on Windows 7.


    As it turns out, the problem is not with locating the backup, but that when iTunes was performing the backup, it did not complete it in full, I received an iTunes error (-50). So it only backed up until 16 August 2012 instead of 23 September 2012. Not sure why this happened. Tried to find other online solutions to this particular error but nothing has worked so far.


    If you have any suggestions that would be great, if not, no worries and thank you for your help



  • Stea7th Level 1 (0 points)

    Hi everyone..


    I have similar problem and have attempted many times to fix it but failed.


    I have just updated my iPhone 4S to iOS6 yesterday. It was iOS5.1.1 and was in jailbreak mode before the update.

    I did sync my iphone and did the 'Backup' as well before the update by using my latest iTunes via my laptop.

    The iOS6 update was successful.


    However, the 'Restore from backup' failed.. many times!! Everytime I tried to Restore from backup, i lost internet connection towards the end of the 'restore in progress'  process so it was never complete. I had to pull out the iphone cable or restart my pc every single time that happened. Because i cannot get an internet connection after that happened. I cannot connect to any wireless network, so I had to restart the pc!
    (the iPhone says 'Restore complete' as soon as I pulled out the cable. But phone stays as NEW phone, none of my backup data was restored).


    During the 'restore from backup' attempts (via iTunes 10.7 on laptop), I have tried:


    - Restoring to factory settings first and then restore from backup = tried many times and still failed.

    - Uninstalled Apple mobile device and iTunes and re-installed them = still failed.
    - Switched OFF the phone and hold the Home button while connecting to the laptop. Restored to factory settings, then tried to restore from backup = still failed!!

    - switching to different USB ports on my laptop including USB 2.0 and USB 3.0 = no luck, still failed.



    -Laptop is on Windows 7 and have had NO such problems so far. I have been using iPhone since 3GS.

    -Internet connection is via wireless router, steady connection.

    -My 3GS was on jailbreak mode before. I bought iPhone 4S and successfully restored from my '3GS backup' without any problem.

Previous 1 2 3 Next