7 Replies Latest reply: May 29, 2013 8:08 AM by tettingt
TslTay Level 1 Level 1

I am using configurator. I have experienced progress, yeah! I have 12 iPads. The one I setup with perfect settings and apps is named, A1.


I have successfully created a backup of A1, and call it Configurator Master BU.


When I supervise my remaining iPads, A2-A12, I have it set to restore from the above mentioned backup.I plug them in, and click apply. Even if an app was deleted, it comes back. Yeah! Since I am restoring from a backup of an iPad that was already configured, I don't get the iOS setup assistant anymore. Yeah!


I created a profile, and tried to set up a gmail email account there. The imap.gmail.com incoming email server just wouldn't work! So I decided to delete that 'payload' and go set up the email on A1 through Account settings. On the iPad A1, I also enabled Settings->General->Restrictions and set a password. I restricted allowing the users to change the email accounts. A1 works great.


The restored iPads do not.


When checking email, it says the account doesn't have a password.


When you go to settings, the account info is greyed-out.


When you go to restrictions, they are greyed out, except that you can select "enable restrictions".

Once you do that, you can go back in and set the email password.


How can I convince Configurator to keep the email and restrictions passwords when I restore form backups?


Thank you!


Configurator, Mac OS X (10.6.4), It is Lion, don't know the number
  • ohmygodidontcare Level 1 Level 1

    i would love an answer for this as well. i am working in a school setting up class sets of 20 i pads. i have created gmail and itunes accounts for each unit to enable the students to email, facetime, msg ect. but i cant get any of the passwords to stick after refreshing the supervised units eather using profiles or a standard backup.......i need to hand out these class sets working not promting passwords, this makes them virtually unusable as they cant communicate and i cant expect to easily teach 300 primary students how to do this ......





  • nsdjoey Level 3 Level 3

    Hi Taylor,


    That is strange... a Supervised Backup should hold on to usernames and passwords. I've been successful in deploying iPads with Configurator and restoring a Supervised Backup that had a restrictions password set. The restrictions password was present on all of the cart iPads.


    I haven't tried setting up a gmail account, but if I was in your shoes I would try this. Delete the original backup of A1. Create a new backup of A1 (with restrictions password and mail settings). Then unsupervise A2-A12. Re-supervise A2-A12 and restore the new backup.


    Not sure if this will work or not, but its what I would try. Hope this helps!


  • gyrhead Level 3 Level 3

    A restore from back up will not hold on to the restrictions password ( not for me anyway) but the email passwords and usernames should persist through the restore.  It has been my experience that the restrictions set through the the "General" tab need to be set manually on each iPad.

  • nsdjoey Level 3 Level 3

    Oops... you're right gyrhead. Restrictions aren't holding with Configurator. They do hold when you restore an encrypted backup in iTunes.

  • nsdjoey Level 3 Level 3

    Okay so the Restrictions thing has been bugging me because I know I've been able to have restrictions set without having to manually do it one by one. So I set up a test lab here of 5 iPads. Wiped them all and started new.


    I took one iPad (we'll call it A1). Went through the setup process, selecting country, wifi, terms, etc. Once the home screen came up, I set a restrictions password and set some restrictions. Then I launched iTunes and plugged A1 into the MacBook. I made an Encrypted Backup of A1. Ejected A1. Closed iTunes. Launched Apple Configurator. Took iPads A2-A5 and Supervised them (not restoring any backup). Then I launched iTunes. A2-A5 show up in iTunes. Then I restored the iTunes Encrypted Backup to A2-A5 (one at a time…ugh). After they finished restoring, I quit iTunes and launched Apple Configurator again. In the Supervise tab, I added apps and configuration profiles. They all installed seamlessly. I checked A2-A5 and the restrictions are all set on A2-A5.


    The drawback here is that you can't restore a Supervised backup to your iPads…only add/remove profiles and apps with Configurator. If an iPad ever needs a full backup restored, you would need to do it via iTunes Encrypted Backup in order for the Restrictions to hold. If you try to restore a Supervised backup with Configurator then you'll reset the Restrictions.


    Its kind of a roundabout way of doing it, but at least you won't have to manually set restrictions on every single iPad.



  • gyrhead Level 3 Level 3

    Before Configurator when we were setting up every device using USB and an iTunes back up all the settings would transfer through the encrypted back up, but this process was extremely time consuming and cumbersome. I have found it takes about 35 seconds to manually set the restrictions on each one. I appreciate your work around, but not sure if the overall time efficiency is any better.  Thanks for taking the time to test and post.

  • tettingt Level 1 Level 1


    If you are having problems restoring different backup images to iPads, look no further.  After you create a backup image, and before you try to restore it to more iPads, QUIT APPLE CONFIGURATOR.  Completely exit out of Apple Configurator, and open it back up, and restore away!  Between different backup images, whether you are creating or restoring, completely quit out of Apple Configurator. 


    For some reason, Apple Configurator has an issue with loading the default Supervision profile back onto the iPads between different backups.  Whenever I had the problem where my account passwords wouldn't transfer over, or my restrictions passcode wouldn't stick, I could see in the General tab that it no longer said that it was supervised, even though it was.  If I then refreshed with no changes made, the Supervision profile would then magically pop up in the General settings.  Quitting Apple Configurator was the only way to stop this from happening.  It would be awesome if this was fixed...