14 Replies Latest reply: Mar 30, 2013 4:27 AM by ami_ella
JG Here Level 1 Level 1
expertise.macosx
Mac OS X

Been using MobileMe and now iCloud for years.  Most of my data syncs fine between two desktops, a powerbook, iPhone and iPad, but not my Safari Bookmarks.  Since it became iCloud, my bookmarks don't sync well.  My iCal updated within minutes or less.  With Mobilme I could force a sync whenever I needed to.  I can't do this with iCloud.  I don't know why just the bookmarks don't sync.  All my machines are set up to do the same syncs.  What's with Bookmarks?  And, where's my manual sync control?


iPad, iOS 5.0.1, MacPro, MacBook Pro, iPad, iPhone
  • Winston Churchill Level 10 Level 10
    expertise.macosx
    Mac OS X

    Bookmark syncing is a little unpredictable at present.

     

    You would be best exporting bookmarks to your desktop on your Mac, turning bookmark syncing on on all your devices and then deleting all your bookmarks from all your devices. Leave things alone for a while and later check that each device still has no bookmarks. Once satisfied that all your devices have no bookmarks, re-import the bookmarks on your Mac and allow them to sync with all your other devices.

  • JG Here Level 1 Level 1
    expertise.macosx
    Mac OS X

    Thanks, Winston.  Thar idea might help me out for today, but if syncing is not working I will be back in the same bad place again within a day.  I remember before MobileMe I had to copy my bookmarks file to a thumbdrive and load it into my other machines at least every day twice.  Then MobileMe did it for me.  Now iCloud won't do that.  I'm going backwards!

  • Winston Churchill Level 10 Level 10
    expertise.macosx
    Mac OS X

    Bookmark syncing does work, it's just a bit of a pain to get it to work initially. Once I myself went through the procedure I explained, my bookmarks started syncing and have continued to do so since.

  • HotRod34 Level 1 Level 1

    I was experiencing the same problems with bookmarks not syncing lately, everything else seemed to be syncing just fine. Turning bookmark syncing off and back on in my iMac's iCloud Preferences seems to have it working for now.

  • JG Here Level 1 Level 1
    expertise.macosx
    Mac OS X

    Hot Rod,

     

    'For now' is the key phrase here.  All that does is 'merge' the bookmarks on your machine with the ones in the cloud.  Just that one time, too. I don't believe it is a sync, just a merge.

  • Winston Churchill Level 10 Level 10
    expertise.macosx
    Mac OS X

    For the avoidance of doubt, my bookmarks have been syncing properly for months. If I create a new bookmark today on any of my devices, it soon appears on all the rest, to me that's syncing, not just a merge.

  • JG Here Level 1 Level 1
    expertise.macosx
    Mac OS X

    You're right, Winston, that IS syncing.  But, by unchecking and then rechecking the Bookmarks button in iCloud preferences, it only merges.  Merging is self descriptive.  Syncing will also merge, but I believe it will also remove bookmarks on the currrent device if they were previously deleted on other devices.  That's what true syncing does.

  • Winston Churchill Level 10 Level 10
    expertise.macosx
    Mac OS X

    Then my bookmarks are 'truly' syncing, since I can delete a bookmark on any device and it gets deleted on all others.

  • JG Here Level 1 Level 1
    expertise.macosx
    Mac OS X

    I hope all of ours are!

     

    I just went through the process you previously recommended. I need to make a few changes and check each devices BM's.  Fingers are crossed (but not while I type).

  • HotRod34 Level 1 Level 1

    Since performing this action my bookmarks have been syncing across all my devices. Just created a new bookmark on my iPad and it is now on my iPhone and my iMac.

  • Zig3 Level 1 Level 1

    Mine work fine sometimes and then other times like today they do not sync at all.

  • moe-b Level 1 Level 1

    Checking and unchecking bookmark syncing worked for me perfectly, thanks!

  • mdz0739 Level 1 Level 1

    To add to these great suggestions, the timing of bookmark syncing on iOS devices is tied to the "Fetch New Data" settings on them.  To see changes the quickest between devices, turn "Push" on and make sure that iCloud fetch schedule is set to "Push".

     

    Here is how to do it on the iPhone 4S (same or similar on iPad):

    1. Go to "Settings"

    2. Go to "Mail, Contacts, Calendars"

    3. Select "Fetch New Data" and set "Push"  to "On"

    4. Scroll to bottom and select "Advanced"

    5. Select "iCloud" and set to "Push"

     

    Regards,

    Michael

  • ami_ella Level 1 Level 1

    I am using a MacPro, a MacBookAir and an iPhone. I had this problem: the Air and iPhon's bookmarks wer syncing, but not the MacPro's.

    What solved it for me was to check out of the old MobileMe account and then I unchecked and checked back the bookmarks sync.